Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
failed to launch xfce4-power-manager because of segfault
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ligang
n00b
n00b


Joined: 08 Oct 2007
Posts: 19

PostPosted: Thu Jan 17, 2013 3:10 pm    Post subject: failed to launch xfce4-power-manager because of segfault Reply with quote

hi, i have sucessfully emerged xfce4-power-manager, but the applicant failed to run, the error log is as follew:
<6>xfce4-power-man[7458]: segfault at 4 ip b715596a sp bfd20100 error 4 in libdbus-1.so.3.7.2[b7149000+34000]
<6>xfce4-power-man[7468]: segfault at 4 ip b716696a sp bfa54a70 error 4 in libdbus-1.so.3.7.2[b715a000+34000]
<6>xfce4-power-man[7707]: segfault at 4 ip b720296a sp bfcbb720 error 4 in libdbus-1.so.3.7.2[b71f6000+34000]
<6>xfce4-power-man[7730]: segfault at 4 ip b712f96a sp bf8b8b20 error 4 in libdbus-1.so.3.7.2[b7123000+34000]
<6>xfce4-power-man[7741]: segfault at 4 ip b718596a sp bfc77600 error 4 in libdbus-1.so.3.7.2[b7179000+34000]
<6>xfce4-power-man[7747]: segfault at 4 ip b716f96a sp bfeca8e0 error 4 in libdbus-1.so.3.7.2[b7163000+34000]

does anyone know how to solve this?
Back to top
View user's profile Send private message
ligang
n00b
n00b


Joined: 08 Oct 2007
Posts: 19

PostPosted: Thu Jan 17, 2013 4:07 pm    Post subject: Reply with quote

i just find that i forgot to add ck-launch-session to .xinitrc.
after i add consolekit to default level, the power-manager finally works!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum