Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] x11 abi 32
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Jonashrem
n00b
n00b


Joined: 03 Feb 2013
Posts: 17

PostPosted: Tue Oct 08, 2013 10:41 am    Post subject: [solved] x11 abi 32 Reply with quote

Hi there,

To install some 32bit binaries I enabled ABI_X86="64 32" in my make conf.

That worked fine til about a week ago but now my X11 libs doesn't want to emerge for 32 bit.

The only difference I see is that the new hav EAPI 5 and XORG_MULTILIB

Code:

EAPI=5
XORG_MULTILIB=yes


while the working ones have EAPI=4 (and no XORG_MULTILIB in ebuild )




This is the output of a world update
Code:

[ebuild     U ~] dev-libs/vala-common-0.22.0 [0.20.1]
[ebuild     U  ] x11-libs/libXxf86vm-1.1.3 [1.1.2-r1] ABI_X86="(-32*)"
[ebuild     U  ] x11-libs/libXcursor-1.1.14 [1.1.13-r1] ABI_X86="(-32*)"
[ebuild     U  ] x11-libs/libXinerama-1.1.3 [1.1.2-r1] ABI_X86="(-32*)"
[ebuild     U  ] x11-proto/videoproto-2.3.2 [2.3.1-r1] ABI_X86="(-32*)"
[ebuild     U  ] x11-libs/libXp-1.0.2 [1.0.1-r1] ABI_X86="(-32*)"
[ebuild     U  ] x11-libs/libXres-1.0.7 [1.0.6]
[ebuild     U  ] x11-misc/xorg-cf-files-1.0.5 [1.0.4]
[ebuild     U  ] x11-apps/sessreg-1.0.8 [1.0.7]
[ebuild     U  ] x11-apps/xwininfo-1.1.3 [1.1.2]
[ebuild     U  ] x11-apps/xlsclients-1.1.3 [1.1.2]
[ebuild     U  ] x11-apps/xrandr-1.4.1 [1.3.5]
[ebuild     U  ] x11-apps/xev-1.2.1 [1.2.0]
[ebuild     U  ] x11-misc/makedepend-1.0.5 [1.0.4]
[ebuild     U  ] x11-apps/xrefresh-1.0.5 [1.0.4]
[ebuild     U  ] x11-apps/xmodmap-1.0.8 [1.0.7]
[ebuild     U  ] x11-libs/libXv-1.0.10 [1.0.7-r1] ABI_X86="(-32*)"
[ebuild     U  ] x11-misc/imake-1.0.6 [1.0.5]
[ebuild     U  ] x11-apps/xvinfo-1.1.2 [1.1.1]
[ebuild     U  ] x11-themes/xcursor-themes-1.0.4 [1.0.3]
[ebuild   R   *] dev-libs/gobject-introspection-1.36.0-r1 [1.36.0-r1] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] x11-libs/libXvMC-1.0.8 [1.0.7-r1] ABI_X86="(-32*)"
[ebuild     U ~] virtual/udev-206-r3 [206-r2]
[ebuild     UD ] sys-apps/hwids-20130329 [20130717-r1]
[ebuild  NS   ~] cross-i686-mingw32/gcc-4.8.1-r1 [4.7.3-r1] USE="cxx doc fortran nls nptl openmp (-altivec) (-fixed-point) -gcj -go -graphite -gtk -hardened -libssp -lto -mudflap -multilib -multislot -nopie -nossp -objc -objc++ -objc-gc -regression-test -vanilla"
[ebuild     U  ] x11-libs/xpyb-1.3.1-r2 [1.3.1-r1]
[ebuild  NS   ~] dev-lang/vala-0.22.0 [0.20.1] USE="vapigen {-test}"
[ebuild   R   ~] media-libs/libsndfile-1.0.25-r1  USE="sqlite*"
[ebuild     U  ] dev-java/tomcat-servlet-api-6.0.37 [6.0.36]
[ebuild   R    ] dev-libs/redland-1.0.16 [1.0.16] USE="sqlite*"
[ebuild     U  ] x11-apps/mkfontscale-1.1.1 [1.1.0]
[ebuild   R    ] dev-libs/cyrus-sasl-2.1.26-r3  USE="sqlite*"
[ebuild  NS    ] dev-java/eclipse-ecj-4.2.1 [3.7.1] USE="ant"
[ebuild  NS    ] dev-java/ant-eclipse-ecj-4.2.1 [3.7.1]
[ebuild     U  ] net-fs/samba-3.6.19 [3.6.16]
[ebuild     U  ] gnome-base/librsvg-2.36.4-r1 [2.36.4]
[ebuild     U ~] dev-python/hgtools-4.0 [3.0.2]
[ebuild   R    ] dev-libs/apr-util-1.5.2  USE="sqlite*"
[ebuild     UD~] x11-libs/libX11-1.5.0-r1 [1.6.2] ABI_X86="32*"
[ebuild     U  ] x11-libs/libSM-1.2.2 [1.2.1-r1] ABI_X86="(-32*)"
[ebuild     U  ] x11-libs/libXi-1.7.2 [1.7] ABI_X86="(-32*)"
[ebuild     U  ] x11-libs/libXfont-1.4.6 [1.4.5-r1]
[ebuild     U  ] x11-libs/libXt-1.1.4 [1.1.3-r1] ABI_X86="(-32*)"
[ebuild     UD~] x11-libs/libXext-1.3.1-r1 [1.3.2] ABI_X86="32*"
[ebuild     UD~] x11-libs/libXfixes-5.0-r1 [5.0.1] ABI_X86="32*"
[ebuild     UD~] x11-libs/libXrender-0.9.7-r1 [0.9.8] ABI_X86="32*"
[ebuild     U  ] x11-apps/bdftopcf-1.0.4 [1.0.3]
[ebuild     U  ] x11-apps/xinput-1.6.1 [1.6.0]
[ebuild     U  ] x11-libs/libXmu-1.1.2 [1.1.1-r1] ABI_X86="(-32*)"
[ebuild     U  ] x11-libs/libXpm-3.5.11 [3.5.10-r1] ABI_X86="(-32*)"
[ebuild     UD~] x11-libs/libXrandr-1.4.0-r1 [1.4.2] ABI_X86="32*"
[ebuild     U  ] x11-apps/xwd-1.0.6 [1.0.5]
[ebuild     U  ] x11-apps/appres-1.0.4 [1.0.3]
[ebuild     U  ] x11-libs/libXaw-1.0.12 [1.0.11-r2] ABI_X86="(-32*)"
[ebuild     U  ] x11-apps/xsetroot-1.1.1 [1.1.0]
[ebuild     U  ] x11-apps/xhost-1.0.6 [1.0.5]
[ebuild     U  ] x11-apps/xkill-1.0.4 [1.0.3]
[ebuild     U  ] sys-apps/groff-1.22.2 [1.21]
[ebuild     U ~] www-client/google-chrome-31.0.1650.12_beta1 [31.0.1650.11_beta1]
[ebuild     U  ] x11-apps/xmessage-1.0.4 [1.0.3]
[ebuild     U  ] x11-apps/xdpyinfo-1.3.1 [1.3.0-r1]
[ebuild     U  ] x11-apps/xkbutils-1.0.4 [1.0.3]
[ebuild     U  ] x11-apps/bitmap-1.0.7 [1.0.6]
[ebuild   R    ] kde-base/kget-4.10.5  USE="sqlite*"
[ebuild   R    ] dev-lang/php-5.3.27  USE="sqlite*"
[ebuild     U  ] dev-python/pyopenssl-0.13.1 [0.13-r1]
[ebuild   R    ] kde-base/plasma-workspace-4.10.5-r2  USE="-debug*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libX11:0

  (x11-libs/libX11-1.6.2::gentoo, installed) pulled in by
    >=x11-libs/libX11-1.6[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXv-1.0.10::gentoo, ebuild scheduled for merge)

  (x11-libs/libX11-1.5.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libX11[abi_x86_32(-)] required by (net-im/skype-4.2.0.11-r1::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-xlibs-20130224-r2::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXv-1.0.7-r1::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libvdpau-0.5-r1::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXft-2.3.1-r1::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXrandr-1.4.0-r1::gentoo, ebuild scheduled for merge)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-video/ffmpeg-0.10.8::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXrender-0.9.7-r1::gentoo, ebuild scheduled for merge)
    >=x11-libs/libX11-1.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXext-1.3.1-r1::gentoo, ebuild scheduled for merge)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXinerama-1.1.2-r1::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXScrnSaver-1.2.2-r1::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXpm-3.5.10-r1::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXdamage-1.1.4-r1::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXvMC-1.0.7-r1::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXp-1.0.1-r1::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXcursor-1.1.13-r1::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXaw-1.0.11-r2::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXfixes-5.0-r1::gentoo, ebuild scheduled for merge)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXmu-1.1.1-r1::gentoo, installed)
    >=x11-libs/libX11-1.4.99.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXi-1.7::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXxf86vm-1.1.2-r1::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXtst-1.2.1-r1::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXxf86dga-1.1.3-r1::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXt-1.1.3-r1::gentoo, installed)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXcomposite-0.4.4-r1::gentoo, installed)

x11-libs/libXext:0

  (x11-libs/libXext-1.3.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXext[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-xlibs-20130224-r2::gentoo, installed)
    x11-libs/libXext[abi_x86_32(-)] required by (net-im/skype-4.2.0.11-r1::gentoo, installed)
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXmu-1.1.1-r1::gentoo, installed)
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXv-1.0.7-r1::gentoo, installed)
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libvdpau-0.5-r1::gentoo, installed)
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXrandr-1.4.0-r1::gentoo, ebuild scheduled for merge)
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXxf86dga-1.1.3-r1::gentoo, installed)
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXvMC-1.0.7-r1::gentoo, installed)
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXinerama-1.1.2-r1::gentoo, installed)
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXaw-1.0.11-r2::gentoo, installed)
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXft-2.3.1-r1::gentoo, installed)
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXpm-3.5.10-r1::gentoo, installed)
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-video/ffmpeg-0.10.8::gentoo, installed)
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXxf86vm-1.1.2-r1::gentoo, installed)
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXScrnSaver-1.2.2-r1::gentoo, installed)
    >=x11-libs/libXext-1.0.99.4[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXtst-1.2.1-r1::gentoo, installed)
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXp-1.0.1-r1::gentoo, installed)
    >=x11-libs/libXext-1.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXi-1.7::gentoo, installed)

  (x11-libs/libXext-1.3.2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/libXrender:0

  (x11-libs/libXrender-0.9.8::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libXrender-0.9.7-r1::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXrender[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-xlibs-20130224-r2::gentoo, installed)
    >=x11-libs/libXrender-0.8.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXft-2.3.1-r1::gentoo, installed)
    x11-libs/libXrender[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXrandr-1.4.0-r1::gentoo, ebuild scheduled for merge)
    >=x11-libs/libXrender-0.8.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXcursor-1.1.13-r1::gentoo, installed)

x11-libs/libXfixes:0

  (x11-libs/libXfixes-5.0.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libXfixes-5.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXfixes[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-xlibs-20130224-r2::gentoo, installed)
    x11-libs/libXfixes[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXdamage-1.1.4-r1::gentoo, installed)
    x11-libs/libXfixes[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXcursor-1.1.13-r1::gentoo, installed)
    x11-libs/libXfixes[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (media-video/ffmpeg-0.10.8::gentoo, installed)
    x11-libs/libXfixes[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXcomposite-0.4.4-r1::gentoo, installed)

x11-libs/libSM:0

  (x11-libs/libSM-1.2.1-r1::gentoo, installed) pulled in by
    x11-libs/libSM[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-xlibs-20130224-r2::gentoo, installed)
    x11-libs/libSM[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXt-1.1.3-r1::gentoo, installed)

  (x11-libs/libSM-1.2.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/libXvMC:0

  (x11-libs/libXvMC-1.0.7-r1::gentoo, installed) pulled in by
    x11-libs/libXvMC[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-xlibs-20130224-r2::gentoo, installed)

  (x11-libs/libXvMC-1.0.8::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/libXcursor:0

  (x11-libs/libXcursor-1.1.14::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libXcursor-1.1.13-r1::gentoo, installed) pulled in by
    x11-libs/libXcursor[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-xlibs-20130224-r2::gentoo, installed)

x11-libs/libXaw:0

  (x11-libs/libXaw-1.0.11-r2::gentoo, installed) pulled in by
    x11-libs/libXaw[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-xlibs-20130224-r2::gentoo, installed)

  (x11-libs/libXaw-1.0.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/libXmu:0

  (x11-libs/libXmu-1.1.1-r1::gentoo, installed) pulled in by
    x11-libs/libXmu[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-xlibs-20130224-r2::gentoo, installed)
    x11-libs/libXmu[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXaw-1.0.11-r2::gentoo, installed)

  (x11-libs/libXmu-1.1.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/libXxf86vm:0

  (x11-libs/libXxf86vm-1.1.3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libXxf86vm-1.1.2-r1::gentoo, installed) pulled in by
    x11-libs/libXxf86vm[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-xlibs-20130224-r2::gentoo, installed)

x11-libs/libXinerama:0

  (x11-libs/libXinerama-1.1.2-r1::gentoo, installed) pulled in by
    x11-libs/libXinerama[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-xlibs-20130224-r2::gentoo, installed)

  (x11-libs/libXinerama-1.1.3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/libXpm:0

  (x11-libs/libXpm-3.5.11::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libXpm-3.5.10-r1::gentoo, installed) pulled in by
    x11-libs/libXpm[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-xlibs-20130224-r2::gentoo, installed)
    x11-libs/libXpm[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXaw-1.0.11-r2::gentoo, installed)

x11-libs/libXt:0

  (x11-libs/libXt-1.1.3-r1::gentoo, installed) pulled in by
    x11-libs/libXt[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-xlibs-20130224-r2::gentoo, installed)
    x11-libs/libXt[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXaw-1.0.11-r2::gentoo, installed)
    x11-libs/libXt[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXpm-3.5.10-r1::gentoo, installed)
    x11-libs/libXt[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXmu-1.1.1-r1::gentoo, installed)

  (x11-libs/libXt-1.1.4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/libXv:0

  (x11-libs/libXv-1.0.10::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libXv-1.0.7-r1::gentoo, installed) pulled in by
    x11-libs/libXv[abi_x86_32(-)] required by (net-im/skype-4.2.0.11-r1::gentoo, installed)
    x11-libs/libXv[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-xlibs-20130224-r2::gentoo, installed)
    x11-libs/libXv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXvMC-1.0.7-r1::gentoo, installed)

x11-libs/libXp:0

  (x11-libs/libXp-1.0.1-r1::gentoo, installed) pulled in by
    x11-libs/libXp[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-xlibs-20130224-r2::gentoo, installed)

  (x11-libs/libXp-1.0.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/libXrandr:0

  (x11-libs/libXrandr-1.4.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXrandr[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-xlibs-20130224-r2::gentoo, installed)

  (x11-libs/libXrandr-1.4.2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/libXi:0

  (x11-libs/libXi-1.7.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libXi-1.7::gentoo, installed) pulled in by
    x11-libs/libXi[abi_x86_32(-)] required by (app-emulation/emul-linux-x86-xlibs-20130224-r2::gentoo, installed)
    x11-libs/libXi[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXtst-1.2.1-r1::gentoo, installed)

x11-proto/videoproto:0

  (x11-proto/videoproto-2.3.1-r1::gentoo, installed) pulled in by
    x11-proto/videoproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXvMC-1.0.7-r1::gentoo, installed)
    x11-proto/videoproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (x11-libs/libXv-1.0.7-r1::gentoo, installed)

  (x11-proto/videoproto-2.3.2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

sys-apps/hwids:0

  (sys-apps/hwids-20130717-r1::gentoo, installed) pulled in by
    >=sys-apps/hwids-20130717-r1[udev] required by (sys-fs/udev-207::poly-c, installed)

  (sys-apps/hwids-20130329::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.




What do I need to do, to compile the EAPI 5 ebuilds for multilib


Last edited by Jonashrem on Tue Oct 08, 2013 7:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Tue Oct 08, 2013 2:57 pm    Post subject: Reply with quote

/etc/portage/package.mask
#Required by xorg ~arch
<x11-libs/libX11-1.6.2
<x11-libs/libXext-1.3.2
<x11-libs/libXrender-0.9.8
<x11-libs/libXfixes-5.0-r1
<x11-libs/libSM-1.2.2
<x11-libs/libXvMC-1.0.8
<x11-libs/libXcursor-1.1.14
<x11-libs/libXaw-1.0.12
<x11-libs/libXmu-1.1.2
<x11-libs/libXxf86vm-1.1.3
<x11-libs/libXinerama-1.1.3
<x11-libs/libXpm-3.5.11
<x11-libs/libXt-1.1.4
<x11-libs/libXv-1.0.10
<x11-libs/libXp-1.0.2
<x11-libs/libXrandr-1.4.2
<x11-libs/libXi-1.7.2
<x11-proto/videoproto-2.3.2
<sys-apps/hwids-20130329

/etc/portage/package.keywords
app-emulation/emul-linux-x86-xlibs
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
Jonashrem
n00b
n00b


Joined: 03 Feb 2013
Posts: 17

PostPosted: Tue Oct 08, 2013 4:42 pm    Post subject: Reply with quote

thanks, but that didn't help.


Still doesn't want to build for abi_32
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1694
Location: Berlin, Germany

PostPosted: Tue Oct 08, 2013 5:11 pm    Post subject: Reply with quote

You need to unmask the abi_x86_32 USE flags for the affected packages. Or do it globally:
/etc/portage/profile/use.mask :
-abi_x86_32
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Tue Oct 08, 2013 5:16 pm    Post subject: Reply with quote

chithanh wrote:
You need to unmask the abi_x86_32 USE flags for the affected packages. Or do it globally:
/etc/portage/profile/use.mask :
-abi_x86_32


Or edit /etc/portage/make.conf
ABI_X86="32 64"
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1694
Location: Berlin, Germany

PostPosted: Tue Oct 08, 2013 5:25 pm    Post subject: Reply with quote

The unmasking must be done in addition to enabling the flags through make.conf or package.use.
Back to top
View user's profile Send private message
Jonashrem
n00b
n00b


Joined: 03 Feb 2013
Posts: 17

PostPosted: Tue Oct 08, 2013 6:53 pm    Post subject: Reply with quote

the useflag unmasking did the trick.

thank you very much
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum