Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems on startup
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Cripplys
n00b
n00b


Joined: 04 May 2011
Posts: 9

PostPosted: Mon Jan 14, 2013 3:36 pm    Post subject: Problems on startup Reply with quote

I've looked everywhere for this topic, but no-one seems to solved this. I have some problems with ConsoleKit and Kdm at startup.
Here's my last record from /var/log/rc.log :
Code:
rc default logging started at Mon Jan 14 15:38:14 2013

 * Starting D-BUS system messagebus ...
 [ ok ]
 * Starting NetworkManager ...
 [ ok ]
Connecting                  10sConnecting..                 9sConnecting...                8sConnecting.....              7sConnecting......             6sConne$
 [ ok ]
 * Starting ConsoleKit daemon ...
 * start-stop-daemon: did not create a valid pid in `/var/run/ConsoleKit/pid'
 [ !! ]
 * ERROR: consolekit failed to start
 * Mounting network filesystems ...
 [ ok ]
 * Setting clock via the NTP client 'ntpdate' ...
 [ ok ]
 * samba -> start: smbd ...
 [ ok ]
 * samba -> start: nmbd ...
 [ ok ]
 * Starting sshd ...
 [ ok ]
 * Doing udev cleanups
 * Setting up kdm ...
 * start-stop-daemon: did not create a valid pid in `/var/run/kdm.pid'
 * ERROR: could not start the Display Manager
 [ ok ]
 * Starting local
 [ ok ]

rc default logging stopped at Mon Jan 14 15:38:39 2013


I really don't know how to solve this error. Please help. 8O
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3823
Location: USA

PostPosted: Mon Jan 14, 2013 5:33 pm    Post subject: Reply with quote

It looks like the new openrc/baselayout wants a /run be tmpfs and /var/run to be a symlink to /run -- is your system setup like this?
(if not, then some investigation is needed... at least my machine was automatically set up like this during an upgrade...)
Should look something like this:

Code:
doujima:/var/run$ df /var/run
Filesystem     1K-blocks  Used Available Use% Mounted on
tmpfs             517420   816    516604   1% /run
doujima:/var/run$


Are all your /etc files updated (dispatch-conf, etc-update) ?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum