Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] aiuto per adattatore wireless usb Belkin
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Hal-10000
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jan 2013
Posts: 81

PostPosted: Thu Jan 10, 2013 10:36 pm    Post subject: [Risolto] aiuto per adattatore wireless usb Belkin Reply with quote

Ciao a tutti,
sono nuovo e questo e' il mio primo post.

Ho usato Archlinux per un anno circa e ho installato Gentoo da pochissimi giorni: tutto bene la prima fase, qualche problema con l'installazione di Xorg, poi risolto. Adesso uso LXDE e avvio Gentoo con il Grub 2.00 di Archlinux.

Il problema e' che sul mio notebook, Intel Core Duo 32 bit @1,73 ghz, 1 gb Ram, la cui scheda wireless interna e' defunta da tempo, non riesco ad attivare l'adattatore wireless usb Belkin F7D2101 v1, che invece va benissimo su Archlinux installato sullo stesso portatile.


Posto di seguito qualche output relativo alla Belkin usb wireless adapter F7D2101 v1



uname -a
Code:
hal-10000 sciacuddi # uname -a
Linux hal-10000 3.5.7-gentoo #10 SMP Wed Jan 9 13:28:08 CET 2013 i686 Genuine Intel(R) CPU T2250 @ 1.73GHz GenuineIntel GNU/Linux



lsusb
Code:
hal-10000 sciacuddi # lsusb
Bus 001 Device 002: ID 050d:845a Belkin Components F7D2101 802.11n Surf & Share Wireless Adapter v1000 [Realtek RTL8192SU]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub



lsmod
Code:
hal-10000 linux # lsmod
Module                  Size  Used by
rtl8192cu              84544  0
rtl8192c_common        50314  1 rtl8192cu
rtlwifi                83514  1 rtl8192cu
psmouse                55198  0



dmesg
Code:
hal-10000 linux # dmesg |grep 8192
[    0.459714] agpgart-intel 0000:00:00.0: detected 8192K stolen memory
[   11.193662] usbcore: registered new interface driver rtl8192cu



tuttavia l'interfaccia wlan0 non appare
Code:
hal-10000 linux # ifconfig -a
eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:13:a9:80:e2:13  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 16 


lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 16436
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 4  bytes 240 (240.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4  bytes 240 (240.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


sit0: flags=128<NOARP>  mtu 1480
        sit  txqueuelen 0  (IPv6-in-IPv4)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

hal-10000 linux #


questo e' /etc/conf.d/net
Code:
hal-10000 sciacuddi # cat nano /etc/conf.d/net
cat: nano: File o directory non esistente
# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /usr/share/doc/openrc*/net.example* and save your configuration
# in /etc/conf.d/net (this file :]!).
config_eth0="dhcp"
config_wlan0="dhcp"
modules="wpa_supplicant"
wpa_supplicant_wlan0="-Dr8712u"
wpa_supplicant_eth0="-Drt2571w"
wpa_supplicant_eth0="-Drt8192cu"


Ho provato anche a scaricare i driver originali RTL8192CU dal sito d Realtek, ma poi dando
Code:
make & make install
ottengo errori (error 1 e poi error 2).

Ho letto anche qualche altro post relativo allo stesso argomento sul forum internazionale, ma niente, non so piu' cosa provare.

Gradirei un aiuto, per favore

Grazie in anticipo per la pazienza e il tempo che mi vorrete dedicare.


EDIT
con questo comando si dovrebbe tirare su la linea, ma..
Code:
hal-10000 sciacuddi # ifconfig wlan0 up
wlan0: ERROR while getting interface flags: Nessun device corrisponde


non c'e' verso di far funzionare la chiavetta, che invece funziona egregiamente con Archlinux nello stesso portatile!!!
Ho provato anche a ricompilare il kernel inserendo i driver rtl8192su non come moduli, ma niente da fare....


Last edited by Hal-10000 on Mon Jan 14, 2013 7:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
Hal-10000
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jan 2013
Posts: 81

PostPosted: Sat Jan 12, 2013 11:13 am    Post subject: Reply with quote

up
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31908
Location: 56N 3W

PostPosted: Sun Jan 13, 2013 9:10 pm    Post subject: Reply with quote

Hal-10000,

Don't bump your posts until you have an answer. That causes them to drop out of the unanswered posts search.

Apologies for posting in English in the Italian forum.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2909
Location: Parma (Italy)

PostPosted: Mon Jan 14, 2013 8:41 am    Post subject: Reply with quote

non sono molto esperto in materia, ma se funziona su archlinux allora dev'essere un problema di configurazione da qualche parte nello stack.

quelle che mi vengono in mente sono: kernel (moduli e built-in), parametri di avvio, moduli caricati, firmware proprietari e no.

prova a fare un'analisi delle differenze tra i due sistemi e vedrai che il problema salta fuori.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Hal-10000
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jan 2013
Posts: 81

PostPosted: Mon Jan 14, 2013 12:08 pm    Post subject: Reply with quote

ti ringrazio per la risposta,

tu dici di provare a fare "un'analisi delle differenze tra i due sistemi", ..hehehe. probabilmente sopravaluti le mie conoscenze. Io non ho studi in materia alle spalle, la mia preparazione culturale e professionale e' in tutt'altro campo, quindi, anche se il mondo linux mi affascina e appassiona, alla fine, rimango solo un principiante. E questo anche se sono riuscito ad installare il mitico Gentoo.

Quindi, purtroppo, non saprei neppure da dove cominciare a fare questa analisi,

ti sarei grato se potessi darmi qualche indicazione in piu' (ma facile pero' ..... :lol:



EDIT:
l'unica cosa -tra quelle che hai detto- alla quale sono in grado di dirti qualcosa sono i moduli: in Archlinux per far partire all'avvio il modulo -driver della chiavetta ho dovuto creare un file, con lo stesso nome del driver e inserirlo in /etc/modules-load.d. Quindi ho: /etc/modules-load.d/r8712u.conf.

Per quanto riguarda il kernel di Gentoo, con menuconfig ho installato come modulo <M> il driver realtek RTL8192CU e poi ho dato il comando per ricompilare il kernel e rigenerato il Grub (quello di Arch quindi Grub 2.00 perche' e' con quello che faccio partire Gentoo).

altro non saprei dire
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2909
Location: Parma (Italy)

PostPosted: Mon Jan 14, 2013 2:03 pm    Post subject: Reply with quote

ripeto, non ho la tua chiavetta quindi posso solo darti indicazioni generiche.

comunque ti faccio notare che su arch il modulo che dici di caricare è r8712u , mentre in gentoo sostieni di utilizzarne un altro (rtl8192cu). A meno di errori di copia\incolla la cosa mi puzza.

Anche se fosse lo stesso modulo (e per giunta quello corretto), sei sicuro di caricarlo in gentoo?

Prova a vedere con il comando (da root)
Code:
# lsmod
nei due sistemi se ci sono moduli che pensi possano avere una qualche pertinenza al problema (ed eventualmente postali, magari passa qualcuno più esperto).

Ribadisco il fatto che se funziona su un sistema gnu\linux allora deve funzionare per forza anche in gentoo, il più è capire di cosa si ha bisogno.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Hal-10000
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jan 2013
Posts: 81

PostPosted: Mon Jan 14, 2013 4:36 pm    Post subject: Reply with quote

Onip wrote:
ti faccio notare che su arch il modulo che dici di caricare è r8712u , mentre in gentoo sostieni di utilizzarne un altro (rtl8192cu)



credo che si tratti della stessa cosa/driver infatti:
Code:
# cd /usr/src/linux
make menuconfig
qui ho
Code:
Driver devices --->

Staging drivers --->

 <M>   RealTek RTL8712U (RTL8192SU) Wireless LAN NIC driver
come vedi parla prima di rtl8712u e poi mette tra parentesi il rtl8192su, come se si trattasse di cose simili. Faccio presente che se scarichi dal sito di Realtek il driver 8192 e poi lo scompatti, cambia nome e diventa 8712

piu sopra poi c'e'
Code:
  <M>   RealTek RTL8192U Wireless LAN NIC driver   


non si capisce se entrambi vanno selezionati (e se si debba farlo come <M> oppure come <*> )


poi esistono altre opzioni ancora, infatti in
Code:
Device drivers --->

Network device support --->

Wireless Lan --->


  <M>   Realtek RTL8192CE/RTL8188CE Wireless Network Adapter       │ │ 
  │ │    <M>   Realtek RTL8192SE/RTL8191SE PCIe Wireless Network Adapter  │ │ 
  │ │    <M>   Realtek RTL8192DE/RTL8188DE PCIe Wireless Network Adapter  │ │ 
  │ │    <M>   Realtek RTL8192CU/RTL8188CU USB Wireless Network Adapter   


Come vedi la cosa e' abbastanza complessa. Andando per tentativi a caso, ho provato a ricompilare il kernel in vari modi e con varie combinazioni, ma niente. L'unico risultato che ho ottenuto e' che il touchpad non funziona piu neanche sotto Archlinux :evil:



per quanto riguarda lmod in Gentoo:
Code:
hal-10000 sciacuddi # lsmod
Module                  Size  Used by
r8712u                142374  0
psmouse                55198  0


mentre in Archlinux -tra tutti gli altri moduli ho estratto solo questo:
Code:
[root@mioarch mioarch]# lsmod | grep r8712u
r8712u                151917  0
usbcore               126796  4 uhci_hcd,ehci_hcd,r8712u,usbhid



il fatto e' che la chiavetta wireless non da' segni di vita, mentre sotto Archlinux il suo led inizia a lampeggiare gia' al boot.
Back to top
View user's profile Send private message
Hal-10000
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jan 2013
Posts: 81

PostPosted: Mon Jan 14, 2013 5:54 pm    Post subject: Reply with quote

ci sono riuscito!!!!!!

se a qualcuno interessa come, posso postare la configurazione del kernel che ho usato.



ma




Vi prego,




ora ditemi come devo fare a ripristinare il touchpad

anzi, no,


apro un nuovo thread.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum