Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Xfce4 shutdown/reboot buttons grey,
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
tybizzel
n00b
n00b


Joined: 10 Jan 2013
Posts: 3

PostPosted: Thu Jan 10, 2013 7:09 am    Post subject: [Solved] Xfce4 shutdown/reboot buttons grey, Reply with quote

As the topic says I'm having problems getting my shutdown and reboot buttons to work. My kernel is 3.7.1 gentoo-sources. I have followed http://forums.gentoo.org/viewtopic-t-905296-postdays-0-postorder-asc-highlight-xfce4+shutdown-start-25.html and http://forums.gentoo.org/viewtopic-t-858965-highlight-xfce4+shutdown.html but still cant get them. When I click the logout button nothing happens and shortly nothing responds and and i have to Ctrl Alt F1 log in as root and reboot. Brand new install.

ck-list-sessions when logging in with slim.
Code:
 
Session2:
   unix-user = '1000'
   realname = '(null)'
   seat = 'Seat1'
   session-type = 'x11'
   active = TRUE
   x11-display = ':0.0'
   x11-display-device = '/dev/tty7'
   display-device = ''
   remote-host-name = ''
   is-local = TRUE
   on-since = '2013-01-10T06:33:12.974240Z'
   login-session-id = '1'
Session1:
   unix-user = '1000'
   realname = '(null)'
   seat = 'Seat2'
   session-type = ''
   active = FALSE
   x11-display = ':0.0'
   x11-display-device = ''
   display-device = ''
   remote-host-name = ''
   is-local = TRUE
   on-since = '2013-01-10T06:33:12.960844Z'
   login-session-id = '1'

ck-list-sessions when started with startxfce4
Code:

Session1:
   unix-user = '1000'
   realname = '(null)'
   seat = 'Seat1'
   session-type = ''
   active = FALSE
   x11-display = ''
   x11-display-device = ''
   display-device = '/dev/tty1'
   remote-host-name = ''
   is-local = TRUE
   on-since = '2013-01-10T06:57:11.899568Z'
   login-session-id = '1'
   idle-since-hint = '2013-01-10T06:57:44.787058Z'

upower -d As user and root
Code:

(upower:2505): libupower-glib-WARNING **: Couldn't enumerate devices: Failed to execute program /usr/libexec/dbus-daemon-launch-helper: Success

(upower:2505): UPower-WARNING **: failed to enumerate: Failed to execute program /usr/libexec/dbus-daemon-launch-helper: Success

Should sys-apps/shadow be built with the audit flag?
Edit: Cause i pushed the wrong button. :)


Last edited by tybizzel on Thu Jan 10, 2013 8:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
mbar
Veteran
Veteran


Joined: 19 Jan 2005
Posts: 1952
Location: Poland

PostPosted: Thu Jan 10, 2013 10:31 am    Post subject: Reply with quote

Do you have "sudo" emerged?
Back to top
View user's profile Send private message
tybizzel
n00b
n00b


Joined: 10 Jan 2013
Posts: 3

PostPosted: Thu Jan 10, 2013 7:17 pm    Post subject: Reply with quote

I did not have sudo emerged. But it hasnt seemed to fix anything.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2133
Location: Finland

PostPosted: Thu Jan 10, 2013 7:44 pm    Post subject: Reply with quote

You need to get 'active = TRUE'

Use ~/.xinitrc with content of:

Code:

# cd ~
# cat .xinitrc
startxfce4 --with-ck-launch


Then use `startx` instead of `startxfce4 --with-ck-launch`

Then make sure the 'nox11' parameter is present as it should:

Code:

# grep nox11 /etc/pam.d/system-login
-session   optional   pam_ck_connector.so nox11
Back to top
View user's profile Send private message
Fitzcarraldo
Guru
Guru


Joined: 30 Aug 2008
Posts: 588
Location: United Kingdom

PostPosted: Thu Jan 10, 2013 7:57 pm    Post subject: Reply with quote

Even with "active = TRUE", the 'Shutdown' and 'Restart' options in the Xfce logout dialogue box were greyed out when I installed Xfce back in March last year. I solved it by following the procedure given by an Xfce developer in the Xfce Forums (link given a post in the Gentoo Forums thread No shutdown option in XFCE after world update [SOLVED]).
_________________
Fitzcarraldo's blog
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2133
Location: Finland

PostPosted: Thu Jan 10, 2013 8:06 pm    Post subject: Reply with quote

Fitzcarraldo wrote:
Even with "active = TRUE", the 'Shutdown' and 'Restart' options in the Xfce logout dialogue box were greyed out when I installed Xfce back in March last year. I solved it by following the procedure given by an Xfce developer in the Xfce Forums (link given a post in the Gentoo Forums thread No shutdown option in XFCE after world update [SOLVED]).


When you log into Console (TTY) you see 1 session which is 'active = TRUE' and when you `startxfce4 --with-ck-launch` or startx with that in ~/.xinitrc you should see TWO sessions. Currently your paste shows only ONE session. TWO sessions because the one is from when you logged into the shell and another when you startx, it just changes the 'active = TRUE' from one session to the another.
This implies the way you logged into your shell (TTY) did not work or pambase was emerged without USE="consolekit"..
Are you using something other than default agetty for TTY's (see /etc/inittab)?

And these are really covered in the links you earlier posted. Yeah, I realize the threads are quite long, but it's suprising how many people do something non-default and accidently break logging into shell or X

This is my ck-list-sessions using startxfce4 --with-ck-launch (well, I use startx for that). Notice the TWO sessions.

Code:

$ ck-list-sessions
Session3:
   unix-user = '1000'
   realname = '(null)'
   seat = 'Seat1'
   session-type = ''
   active = FALSE
   x11-display = ''
   x11-display-device = ''
   display-device = '/dev/tty1'
   remote-host-name = ''
   is-local = TRUE
   on-since = '2013-01-09T16:02:19.574362Z'
   login-session-id = '2'
   idle-since-hint = '2013-01-09T16:02:52.909669Z'
Session4:
   unix-user = '1000'
   realname = '(null)'
   seat = 'Seat1'
   session-type = ''
   active = TRUE
   x11-display = ':0'
   x11-display-device = '/dev/tty7'
   display-device = '/dev/tty1'
   remote-host-name = ''
   is-local = TRUE
   on-since = '2013-01-09T16:02:23.412168Z'
   login-session-id = '2'
Back to top
View user's profile Send private message
tybizzel
n00b
n00b


Joined: 10 Jan 2013
Posts: 3

PostPosted: Thu Jan 10, 2013 8:34 pm    Post subject: Reply with quote

I did a "emerge --noconfmem dbus dbus-glib polkit consolekit pambase sudo" and everything works proper now.
I think the problem was I had added AUDITSYSCALL to the kernel after these packages were built.
My ck-list-session after logging in with slim.
Code:

Session2:
   unix-user = '1000'
   realname = '(null)'
   seat = 'Seat1'
   session-type = 'x11'
   active = TRUE
   x11-display = ':0.0'
   x11-display-device = '/dev/tty7'
   display-device = ''
   remote-host-name = ''
   is-local = TRUE
   on-since = '2013-01-10T20:25:13.117137Z'
   login-session-id = '1'
Session1:
   unix-user = '1000'
   realname = '(null)'
   seat = 'Seat2'
   session-type = ''
   active = FALSE
   x11-display = ':0.0'
   x11-display-device = ''
   display-device = ''
   remote-host-name = ''
   is-local = TRUE
   on-since = '2013-01-10T20:25:13.103674Z'
   login-session-id = '1'

My upower -d
Code:

Daemon:
  daemon-version:  0.9.18
  can-suspend:     no
  can-hibernate    no
  on-battery:      no
  on-low-battery:  no
  lid-is-closed:   no
  lid-is-present:  no
  is-docked:       no

Thanks for the help yall even though it was a brain fart on my part.
Back to top
View user's profile Send private message
Fitzcarraldo
Guru
Guru


Joined: 30 Aug 2008
Posts: 588
Location: United Kingdom

PostPosted: Thu Jan 10, 2013 8:51 pm    Post subject: Reply with quote

ssuominen wrote:
Fitzcarraldo wrote:
Even with "active = TRUE", the 'Shutdown' and 'Restart' options in the Xfce logout dialogue box were greyed out when I installed Xfce back in March last year. I solved it by following the procedure given by an Xfce developer in the Xfce Forums (link given a post in the Gentoo Forums thread No shutdown option in XFCE after world update [SOLVED]).


When you log into Console (TTY) you see 1 session which is 'active = TRUE' and when you `startxfce4 --with-ck-launch` or startx with that in ~/.xinitrc you should see TWO sessions. Currently your paste shows only ONE session. TWO sessions because the one is from when you logged into the shell and another when you startx, it just changes the 'active = TRUE' from one session to the another.
This implies the way you logged into your shell (TTY) did not work or pambase was emerged without USE="consolekit"..
Are you using something other than default agetty for TTY's (see /etc/inittab)?

And these are really covered in the links you earlier posted. Yeah, I realize the threads are quite long, but it's suprising how many people do something non-default and accidently break logging into shell or X

This is my ck-list-sessions using startxfce4 --with-ck-launch (well, I use startx for that). Notice the TWO sessions.

Code:

$ ck-list-sessions
Session3:
   unix-user = '1000'
   realname = '(null)'
   seat = 'Seat1'
   session-type = ''
   active = FALSE
   x11-display = ''
   x11-display-device = ''
   display-device = '/dev/tty1'
   remote-host-name = ''
   is-local = TRUE
   on-since = '2013-01-09T16:02:19.574362Z'
   login-session-id = '2'
   idle-since-hint = '2013-01-09T16:02:52.909669Z'
Session4:
   unix-user = '1000'
   realname = '(null)'
   seat = 'Seat1'
   session-type = ''
   active = TRUE
   x11-display = ':0'
   x11-display-device = '/dev/tty7'
   display-device = '/dev/tty1'
   remote-host-name = ''
   is-local = TRUE
   on-since = '2013-01-09T16:02:23.412168Z'
   login-session-id = '2'


I and the laptop running Xfce are 5,000 km apart for the next couple of weeks (I'm typing this on my main laptop running KDE), but on the laptop with Xfce I use SLiM, not startx, and it does not have an ~/.xinitrc (in fact, if I recall correctly, SLiM wouldn't login if an ~/.xinitrc existed):

http://forums.gentoo.org/viewtopic-p-7123834.html#7123834

Fitzcarraldo wrote:
I also have Xfce with SLiM and ConsoleKit. You don't need ~/.xinitrc at all, and I don't have one. Why don't you delete it and rely on the XSESSION variable in /etc/env.d/90xsession instead?

Code:
fitzcarraldo@gateway9300 ~ $ ls -la ~/.xinitrc
ls: cannot access /home/fitzcarraldo/.xinitrc: No such file or directory


Code:
fitzcarraldo@gateway9300 ~ $ cat /etc/env.d/90xsession
XSESSION="Xfce4"


Code:
fitzcarraldo@gateway9300 ~ $ cat /etc/conf.d/xdm
DISPLAYMANAGER="slim"

Everything works correctly on the Xfce laptop, including the 'Shutdown', 'Restart' and 'Logout' options in the Xfce logout dialogue.
_________________
Fitzcarraldo's blog
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2133
Location: Finland

PostPosted: Fri Jan 11, 2013 6:54 am    Post subject: Reply with quote

Fitzcarraldo wrote:

I and the laptop running Xfce are 5,000 km apart for the next couple of weeks (I'm typing this on my main laptop running KDE), but on the laptop with Xfce I use SLiM, not startx, and it does not have an ~/.xinitrc (in fact, if I recall correctly, SLiM wouldn't login if an ~/.xinitrc existed):


Display Managers should use .xsession instead of .xinitrc. It's actually a real bug that SLIM uses .xinitrc instead of .xsession. I believe SLIM is the only Display Manager in Portage with that bug.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum