Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Cannot mount root filesystem after system update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
elomaniak
n00b
n00b


Joined: 27 Jan 2013
Posts: 47

PostPosted: Sun Jan 27, 2013 4:32 am    Post subject: [SOLVED] Cannot mount root filesystem after system update Reply with quote

Hello

I finally decided to switch to gentoo, to learn more about linux

but my configuration does not boot with the error
Cannot mount root filesystem after system update

VFS: Cannot open root device "sda2" or unknown-block(0,0)
Please append a correct "root=" boot option: here are the available partitions:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

fstab
Code:
# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sda1               /boot           reiserfs        notail,defaults         1 2
/dev/sda2               /               reiserfs        defaults,noatime        0 1


fdisk
Code:
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048    41945087    20971520   83  Linux
/dev/sda2        41945088   125045423    41550168   83  Linux


grub
Code:
default 0
timeout 10
#splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title Gentoo Linux 3.6.11
root (hd0,0)
kernel /boot/kernel-3.6.11-gentoo root=/dev/sda2
#initrd /boot/initramfs-genkernel-x86_64-3.6.11-gentoo


.config in /usr/src/linux
Code:
CONFIG_BUILDTIME_EXTABLE_SORT=y
CONFIG_X86_EXTENDED_PLATFORM=y
CONFIG_ARCH_PROC_KCORE_TEXT=y
CONFIG_SPARSEMEM_EXTREME=y
CONFIG_PAGEFLAGS_EXTENDED=y
CONFIG_HAVE_TEXT_POKE_SMP=y
# CONFIG_NET_EMATCH_TEXT is not set
# CONFIG_CFG80211_WEXT is not set
CONFIG_EXTRA_FIRMWARE=""
CONFIG_SERIAL_8250_EXTENDED=y
# External I2C/SMBus adapter drivers
# CONFIG_EXTCON is not set
# CONFIG_EXT2_FS is not set
CONFIG_EXT3_FS=y
# CONFIG_EXT3_DEFAULTS_TO_ORDERED is not set
CONFIG_EXT3_FS_XATTR=y
CONFIG_EXT3_FS_POSIX_ACL=y
CONFIG_EXT3_FS_SECURITY=y
# CONFIG_EXT4_FS is not set
# CONFIG_DEBUG_BLOCK_EXT_DEVT is not set
CONFIG_CONTEXT_SWITCH_TRACER=y


lspci -n
Code:
00:00.0 0600: 1022:1510
00:01.0 0300: 1002:9806
00:01.1 0403: 1002:1314
00:05.0 0604: 1022:1513
00:06.0 0604: 1022:1514
00:07.0 0604: 1022:1515
00:11.0 0106: 1002:4391
00:12.0 0c03: 1002:4397
00:12.2 0c03: 1002:4396
00:13.0 0c03: 1002:4397
00:13.2 0c03: 1002:4396
00:14.0 0c05: 1002:4385 (rev 42)
00:14.2 0403: 1002:4383 (rev 40)
00:14.3 0601: 1002:439d (rev 40)
00:14.4 0604: 1002:4384 (rev 40)
00:18.0 0600: 1022:1700 (rev 43)
00:18.1 0600: 1022:1701
00:18.2 0600: 1022:1702
00:18.3 0600: 1022:1703
00:18.4 0600: 1022:1704
00:18.5 0600: 1022:1718
00:18.6 0600: 1022:1716
00:18.7 0600: 1022:1719
01:00.0 0280: 10ec:8176 (rev 01)
02:00.0 0200: 1969:1083 (rev c0)
03:00.0 ff00: 10ec:5209 (rev 01)


Last edited by elomaniak on Sun Jan 27, 2013 11:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Sun Jan 27, 2013 5:02 am    Post subject: Reply with quote

elomaniak.

Welcome to gentoo - the fun has just begun :D

You set your root partition as follows:
Code:
/dev/sda2               /               reiserfs        defaults,noatime        0 1


Is CONFIG_REISERFS_FS set :?:

If not set it as =y (that is built-in, not as a module) :wink:
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
elomaniak
n00b
n00b


Joined: 27 Jan 2013
Posts: 47

PostPosted: Sun Jan 27, 2013 6:10 am    Post subject: Reply with quote

So just add this line to the .config?

Reiserfs is built in in the kernel <*> under filesystems
Back to top
View user's profile Send private message
wcg
Guru
Guru


Joined: 06 Jan 2009
Posts: 588

PostPosted: Sun Jan 27, 2013 8:56 am    Post subject: Reply with quote

Try this in grub.conf:
Code:

root (hd0,0)
kernel (hd0,0)/kernel-3.6.11-gentoo root=/dev/sda2

_________________
TIA
Back to top
View user's profile Send private message
elomaniak
n00b
n00b


Joined: 27 Jan 2013
Posts: 47

PostPosted: Sun Jan 27, 2013 12:41 pm    Post subject: Reply with quote

Config_reiserfs is set,

Changed /Boot/kernel.... To (hd0,0) and errored me before bootup that it has to be an absolute path or blocklist

Any suggestion?
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Sun Jan 27, 2013 1:33 pm    Post subject: Reply with quote

elomaniak,

Try adding the filesystem type to the kernel line:
Code:
title Gentoo Linux 3.6.11
root (hd0,0)
kernel /boot/kernel-3.6.11-gentoo root=/dev/sda2 rootfstype=reiserfs

_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
elomaniak
n00b
n00b


Joined: 27 Jan 2013
Posts: 47

PostPosted: Sun Jan 27, 2013 3:09 pm    Post subject: Reply with quote

This didnt work either

instead of VFS: Cannot open root device "sda2" or unknown-block(0,0)
i got another kernel panic but without an error message
dont know what else I can do

pls help
Back to top
View user's profile Send private message
windz
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2006
Posts: 88

PostPosted: Sun Jan 27, 2013 4:00 pm    Post subject: Reply with quote

Quote:
default 0
timeout 10
#splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title Gentoo Linux 3.6.11
root (hd0,0)
kernel /boot/kernel-3.6.11-gentoo root=/dev/sda2
#initrd /boot/initramfs-genkernel-x86_64-3.6.11-gentoo


I think you need to leave out the bold part "/boot" after the "kernel". Someone once told me, and I quote "You don't need /boot in the path because the boot partition /dev/sda1 is a separate partition. The root directory of that partition is what you see in /boot when you mount it. "

Does it work if you used the following:

Code:
timeout 10

title Gentoo Linux 3.6.11
root (hd0,0)
kernel /kernel-3.6.11-gentoo root=/dev/sda2
Back to top
View user's profile Send private message
FRIGN
n00b
n00b


Joined: 12 Jan 2013
Posts: 23
Location: Germany

PostPosted: Sun Jan 27, 2013 6:15 pm    Post subject: Reply with quote

You might also check if the kernel command line is enabled under
Code:
Processor type and features -> [ ] Built-in kernel command line
, overriding boot loader settings.
Back to top
View user's profile Send private message
elomaniak
n00b
n00b


Joined: 27 Jan 2013
Posts: 47

PostPosted: Sun Jan 27, 2013 8:35 pm    Post subject: Reply with quote

windz wrote:
Quote:
default 0
timeout 10
#splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title Gentoo Linux 3.6.11
root (hd0,0)
kernel /boot/kernel-3.6.11-gentoo root=/dev/sda2
#initrd /boot/initramfs-genkernel-x86_64-3.6.11-gentoo


I think you need to leave out the bold part "/boot" after the "kernel". Someone once told me, and I quote "You don't need /boot in the path because the boot partition /dev/sda1 is a separate partition. The root directory of that partition is what you see in /boot when you mount it. "

Does it work if you used the following:

Code:
timeout 10

title Gentoo Linux 3.6.11
root (hd0,0)
kernel /kernel-3.6.11-gentoo root=/dev/sda2


When i change this them it gives me the kernel panic
Cannot open root device sda2
Cannot open rootfs

@FRIGN
This Option is disabled in my kernel config

I hope anyone can help.
Back to top
View user's profile Send private message
elomaniak
n00b
n00b


Joined: 27 Jan 2013
Posts: 47

PostPosted: Sun Jan 27, 2013 9:53 pm    Post subject: Reply with quote

Ok finally my gentoo is running :)

The error was that the SCSI support was only a Module and not built in, seems that SAtA neues them to.

Thanks to all the people who helped me :)
Regards
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum