Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
portage gone crazy
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
curmudgeon
Veteran
Veteran


Joined: 08 Aug 2003
Posts: 1358

PostPosted: Fri Jan 11, 2013 2:48 am    Post subject: portage gone crazy Reply with quote

Code:

# emerge -p git

These are the packages that would be merged, in order:

Calculating dependencies -

!!! Problem resolving dependencies for dev-vcs/git
... done!

!!! The ebuild selected to satisfy "git" has unmet requirements.
- dev-vcs/git-1.7.12.4 USE="blksha1 (consolekit) curl gpg iconv nls pcre (policykit) subversion threads webdav -cgi -cvs -doc -emacs -gtk -highlight -perl (-ppcsha1) -python -test -tk -xinetd"

  The following REQUIRED_USE flag constraints are unsatisfied:
    subversion? ( perl )

  The above constraints are a subset of the following complete expression:
    cgi? ( perl ) cvs? ( perl ) subversion? ( perl ) webdav? ( curl )


I don't understand what is going on. Subversion already has the USE flag enabled.

Code:

# emerge -p subversion

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-vcs/subversion-1.7.7  USE="kde nls perl webdav-neon -apache2 -berkdb -ctypes-python -debug -doc -dso -extras -gnome-keyring -java -python -ruby -sasl -vim-syntax -webdav-serf" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


If I try to enable it for git as well (which I don't want), I get:

Code:

# USE=perl emerge -p git

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-perl/LWP-MediaTypes-6.20.0  19 kB
[ebuild  N     ] dev-perl/Encode-Locale-1.30.0  7 kB
[ebuild  N     ] virtual/perl-libnet-1.220.0-r1  0 kB
[ebuild  N     ] virtual/perl-IO-Compress-2.024  0 kB
[ebuild  N     ] virtual/perl-Compress-Raw-Zlib-2.024  0 kB
[ebuild  N     ] dev-perl/TermReadKey-2.300.0  37 kB
[ebuild  N     ] dev-perl/Net-SSLeay-1.490.0  377 kB
[ebuild  N     ] dev-perl/HTML-Tagset-3.200.0  8 kB
[ebuild  N     ] perl-core/Scalar-List-Utils-1.230.0  29 kB
[ebuild  N     ] perl-core/IO-1.25  52 kB
[ebuild  N     ] perl-core/Time-Local-1.200.0  19 kB
[ebuild  N     ] perl-core/Encode-2.430.0  1,956 kB
[ebuild  N     ] virtual/perl-digest-base-1.160.0-r1  0 kB
[ebuild  N     ] virtual/perl-Digest-SHA-5.47  0 kB
[ebuild  N     ] perl-core/version-0.940.0  103 kB
[ebuild  N     ] perl-core/Test-Harness-3.230.0  288 kB
[ebuild  N     ] virtual/perl-Archive-Tar-1.54  0 kB
[ebuild  N     ] perl-core/ExtUtils-CBuilder-0.27.03  30 kB
[ebuild  N     ] perl-core/Perl-OSType-1.2.0  USE="{-test}" 12 kB
[ebuild  N     ] perl-core/JSON-PP-2.272.0  41 kB
[ebuild  N     ] perl-core/CPAN-Meta-YAML-0.4.0  29 kB
[ebuild  N     ] perl-core/File-Spec-3.31  132 kB
[ebuild  N     ] perl-core/ExtUtils-Manifest-1.580.0  20 kB
[ebuild  N     ] perl-core/ExtUtils-Install-1.54  66 kB
[ebuild  N     ] perl-core/ExtUtils-Command-1.170.0  19 kB
[ebuild  N     ] perl-core/Test-Simple-0.980.0  105 kB
[ebuild  N     ] virtual/perl-File-Temp-0.220.0-r2  0 kB
[ebuild  N     ] virtual/perl-Scalar-List-Utils-1.230.0-r2  0 kB
[ebuild  N     ] virtual/perl-IO-1.25  0 kB
[ebuild  N     ] dev-perl/HTML-Parser-3.690.0  USE="{-test}" 88 kB
[ebuild  N     ] virtual/perl-Time-Local-1.200.0-r2  0 kB
[ebuild  N     ] virtual/perl-Encode-2.430.0  0 kB
[ebuild  N     ] perl-core/Digest-MD5-2.510.0  45 kB
[ebuild  N     ] virtual/perl-version-0.940.0  0 kB
[ebuild  N     ] virtual/perl-ExtUtils-CBuilder-0.27.03  0 kB
[ebuild  N     ] virtual/perl-JSON-PP-2.272.0-r1  0 kB
[ebuild  N     ] virtual/perl-CPAN-Meta-YAML-0.4.0  0 kB
[ebuild  N     ] virtual/perl-File-Spec-3.31  0 kB
[ebuild  N     ] virtual/perl-Test-Harness-3.230.0-r3  0 kB
[ebuild  N     ] virtual/perl-Perl-OSType-1.2.0-r1  0 kB
[ebuild  N     ] virtual/perl-ExtUtils-Manifest-1.580.0-r1  0 kB
[ebuild  N     ] virtual/perl-ExtUtils-Install-1.54  0 kB
[ebuild  N     ] virtual/perl-ExtUtils-Command-1.170.0-r3  0 kB
[ebuild  N     ] virtual/perl-Test-Simple-0.980.0-r2  0 kB
[ebuild  N     ] dev-perl/HTTP-Date-6.20.0  8 kB
[ebuild  N     ] dev-perl/Net-HTTP-6.30.0  14 kB
[ebuild  N     ] dev-perl/IO-Socket-SSL-1.440.0  USE="-idn" 68 kB
[ebuild  N     ] virtual/perl-Digest-MD5-2.510.0-r2  0 kB
[ebuild  N     ] dev-perl/WWW-RobotRules-6.10.0  9 kB
[ebuild  N     ] perl-core/ExtUtils-ParseXS-2.22.05  40 kB
[ebuild  N     ] perl-core/Module-Metadata-1.0.6  23 kB
[ebuild  N     ] perl-core/Parse-CPAN-Meta-1.440.100  8 kB
[ebuild  N     ] perl-core/Version-Requirements-0.101.20  15 kB
[ebuild  N     ] dev-perl/HTTP-Message-6.30.0  49 kB
[ebuild  N     ] dev-perl/Net-SMTP-SSL-1.10.0  2 kB
[ebuild  N     ] dev-perl/Digest-HMAC-1.30.0  8 kB
[ebuild  N     ] dev-perl/File-Listing-6.40.0  51 kB
[ebuild  N     ] virtual/perl-Parse-CPAN-Meta-1.440.100-r2  0 kB
[ebuild  N     ] virtual/perl-ExtUtils-ParseXS-2.22.05  0 kB
[ebuild  N     ] virtual/perl-Module-Metadata-1.0.6  0 kB
[ebuild  N     ] virtual/perl-Version-Requirements-0.101.20-r2  0 kB
[ebuild  N     ] dev-perl/Authen-SASL-2.160.0  USE="-kerberos" 45 kB
[ebuild  N     ] dev-perl/HTTP-Cookies-6.0.0  19 kB
[ebuild  N     ] dev-perl/HTTP-Daemon-6.10.0  19 kB
[ebuild  N     ] dev-perl/HTTP-Negotiate-6.0.0  9 kB
[ebuild  N     ] dev-perl/libwww-perl-6.30.0  USE="ssl" 129 kB
[ebuild  N     ] perl-core/ExtUtils-MakeMaker-6.620.0  406 kB
[ebuild  N     ] virtual/perl-ExtUtils-MakeMaker-6.620.0  0 kB
[ebuild  N     ] dev-perl/LWP-Protocol-https-6.20.0  4 kB
[ebuild  N     ] perl-core/CPAN-Meta-2.112.621  75 kB
[ebuild  N     ] virtual/perl-CPAN-Meta-2.112.621  0 kB
[ebuild  N     ] perl-core/Module-Build-0.380.0  299 kB
[ebuild  N     ] virtual/perl-Module-Build-0.380.0-r2  0 kB
[ebuild  N     ] dev-perl/Error-0.170.160  USE="{-test}" 21 kB
[ebuild     U  ] dev-vcs/git-1.7.12.4 [1.7.8.6] USE="blksha1 curl gpg%* iconv nls%* pcre%* perl* subversion threads webdav -cgi -cvs -doc -emacs -gtk -highlight% (-ppcsha1) -python {-test%} -tk -xinetd" 4,523 kB

Total: 75 packages (1 upgrade, 74 new), Size of downloads: 9,305 kB


I am NOT installing seventy-four NEW packages just to upgrade git!

Can someone tell me why the original emerge command is failing?
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 9127

PostPosted: Fri Jan 11, 2013 3:05 am    Post subject: Reply with quote

According to the output provided, for dev-vcs/git, if you have USE=subversion, then you must have USE=perl. If you want USE=-perl, then you must also set USE=-subversion.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum