Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Probkems with emerging on new system.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
cwr
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1707

PostPosted: Tue Jan 08, 2013 9:20 am    Post subject: Probkems with emerging on new system. Reply with quote

Using a current stage 3 and portage snapshot the system installs and boots ok (I'm using a pre-built
Gentoo kernel) but won't emerge anything. The first thing I tried was lafilefixer, and got the result:
Code:

... skipped package list ...

Total: 165 packages (165 new), Size of downloads: 0 kB

 * Error: circular dependencies:

(sys-libs/glibc-2.15-r3::gentoo, ebuild scheduled for merge) depends on
 (sys-devel/gcc-4.5.4::gentoo, ebuild scheduled for merge) (buildtime)
  (sys-libs/glibc-2.15-r3::gentoo, ebuild scheduled for merge) (buildtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.


(This is with the default make.conf and make.profile)

I can get the required packages down to 25 or so by choosing USE flags, but eg: bash is still required.
I haven't seen anything like this before, and changing Stage 3 files and portage snapshots, and syncing
portage, has no effect. It looks as if emerge can't find the system file list, which is in /usr/portage/profiles/base
The man page puts it in /etc/portage/make.profile/packages, but I assume that's out of date. Clearing
out /var/cache/edb doesn't change the result.

I can't find any significant differences with a working Gentoo system - does anyone have any ideas?

Thanks - Wiill
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6711
Location: Goose Creek SC

PostPosted: Tue Jan 08, 2013 5:37 pm    Post subject: Reply with quote

what do you get for:
Code:
emerge - s gcc glibc
gcc-config -l
emerge -- info
did you emerge portage? try package.mask glibc to earlier version(s)?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
cwr
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1707

PostPosted: Wed Jan 09, 2013 9:52 am    Post subject: Reply with quote

No, changing USE flags and masking had no useful effect. On about the fifth attempt with various
Stage 3 files and portage snapshots it all worked, and I have no idea why. It looks as if emerge
couldn't find the list of installed system packages, but I don't know where that's stored - I couldn't
find it anywhere in the file system. Why emerge suddenly found it I don't know - I was using the
standard install routine I've used for four or five years now without problems.

Will
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum