Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
/sbin/udev does not exist
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
johnnytheswede
n00b
n00b


Joined: 12 Mar 2010
Posts: 21

PostPosted: Mon Jan 07, 2013 8:05 am    Post subject: /sbin/udev does not exist Reply with quote

Hello,

I am doing a new install and after everything basic is in place I want to emerge the following:

dbus (works fine)
udev
xorg

and then on to some window manager.

I am doing these emerges when the system is running itself, ie not via a livecd. During the emerging of udev I can see /sbin/udevd, but when the emerge completes, it is gone, and hence the message "/sbin/udev does not exist" during startup. I have tried to read other posts about it and they mention etc-update, but do not mention at which point this should be invoked. I have tried to unmerge udev and the do etc-update and then re-emerge udev, but, nothing works. The frustrating thing is that I saw /sbin/udevd during the emerging of it but that it just should disappear after the emerge i completed feels ... well, absurd.

I hope you can help me.

/Johnny
_________________
I used to be undecided, but, uhm... now I don't really know anymore
Back to top
View user's profile Send private message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1483
Location: Switzerland (Romandie)

PostPosted: Mon Jan 07, 2013 11:13 am    Post subject: Reply with quote

Look normal to me:
Code:
 # equery f udev
 * Searching for udev ...
 * Contents of sys-fs/udev-196-r1:
...
/sbin
/sbin/udevadm -> ../usr/bin/udevadm
/usr
/usr/bin
/usr/bin/udevadm
...

The only executable in bin* is udevadm.
_________________
[[[ To any NSA and FBI agents reading that text: please consider ]]]
[[[ whether defending the US Constitution against all enemies, ]]]
[[[ foreign or domestic, requires you to follow Snowden's example. ]]]
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Mon Jan 07, 2013 11:17 am    Post subject: Reply with quote

did you run dispatch-conf or etc-update?
there was a 'recent' move or udev from / to /usr.

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum