Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
eix-0.27.4 highlights in white [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5282

PostPosted: Sun Jan 06, 2013 5:00 pm    Post subject: eix-0.27.4 highlights in white [SOLVED] Reply with quote

This isn't a bug, because everything works, but the white highlighting is SUPER annoying to the point where I've masked this version locally. So... feature request: no highlighting, thanks. :)
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org


Last edited by audiodef on Mon Jan 07, 2013 2:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4311

PostPosted: Sun Jan 06, 2013 5:09 pm    Post subject: Reply with quote

All colors can be cutomized. If you tell me more exactly which output is disturbing you, I can tell you how to change that.
(It would also be necessary to know whether you have a 256 color terminal and/or a black background; e.g. what is your $TERM and possibly $COLORFGBG).
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5282

PostPosted: Sun Jan 06, 2013 10:38 pm    Post subject: Reply with quote

I hope you know that while I do find that default white highlighting annoying, I was otherwise trying to be humorous. :)

Well, I use rxvt-unicode, set to either black background or transparent, with 256 colors. eix-0.27.4 shows up in my terminal with all output having a white background. Previous versions don't do that.

Is that enough to go on?
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
GFCCAE6xF
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 232

PostPosted: Sun Jan 06, 2013 10:59 pm    Post subject: Reply with quote

I use DARK=true in /etc/eixrc which seems to be the most basic way of changing that.
Image related --> difference without and with DARK=true: http://postimage.org/image/j5l6lai0b/
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4311

PostPosted: Mon Jan 07, 2013 2:18 pm    Post subject: Reply with quote

audiodef wrote:
Well, I use rxvt-unicode, set to either black background or transparent

There are two issues involved here:
  • eix heuristics (falsely) gives that your background is white.
  • In case the heurstic is false, it forces a white background to give at least a readable result, since the colors used would be unreadable on e.g. a black background
Since rxvt-unicode sets COLORFGBG, the eix heuristiccs should actually detect that your background is black. However, recently I learnt that there are some modes in rxvt-unicode in which COLORFGBG does not have the content "foreground;background" but also a third string which is not handled by the default heuristics. Currently, as a workaround, you can "fix" this part of the heuristics by setting (e.g. in /etc/eixrc):
Code:
COLORFGBF_DARK=';0?[02-689]$ ;1[0-46]$ ;[a-km-vxz][a-z]*$'
(use the correct quotation marks!) which will be the default value in the next eix release.

In case that you have transparent terminal, it is better to force DARK=true or DARK=false, depending on the color of your "true" background (for which the heuristics does not work at all, of course).

The second issue is to avoid forcing the assumed background color: For white background, this is avoided by setting BG3=none, for black background by setting BG1=none. Both is not the default, because with this setting the result can be unreadable if the background color guess is wrong.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5282

PostPosted: Mon Jan 07, 2013 2:29 pm    Post subject: Reply with quote

Thanks for the explanation, mv. Turns out DARK=true fixes it in my case. :)
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum