Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 3 update is overburdening me
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
floppes
n00b
n00b


Joined: 06 Jan 2005
Posts: 67
Location: Darmstadt, Germany

PostPosted: Wed Jan 01, 2014 3:57 pm    Post subject: Gnome 3 update is overburdening me Reply with quote

I had a nicely running system with Gnome 2.32.1 until a few weeks ago Gnome 3.8 ebuilds started showing up in my "emerge -uDp world". So I decided to switch over. I successfully switched to systemd and followed the Gnome upgrade guide until the step where to perform

Code:
emerge -avuDN --keep-going world gnome-base/gnome


This is giving me:

Code:
floppes-laptop ~ #emerge -avuDN --keep-going world gnome-base/gnome

These are the packages that would be merged, in order:

Calculating dependencies... done!
[...]

Total: 555 packages (130 upgrades, 148 new, 25 in new slots, 252 reinstalls, 6 uninstalls), Size of downloads: 905,492 kB
Conflict: 23 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

gnome-extra/evolution-data-server:0

  (gnome-extra/evolution-data-server-3.8.5::gentoo, ebuild scheduled for merge) pulled in by
    gnome-extra/evolution-data-server[vala] required by (gnome-extra/gnome-contacts-3.8.3::gentoo, ebuild scheduled for merge)
    >=gnome-extra/evolution-data-server-3.8.5:=[gnome-online-accounts?,weather?] required by (mail-client/evolution-3.8.5::gentoo, ebuild scheduled for merge)
    (and 6 more with the same problems)

  (gnome-extra/evolution-data-server-2.32.3-r3::gentoo, ebuild scheduled for merge) pulled in by
    <gnome-extra/evolution-data-server-3.6 required by (dev-python/evolution-python-2.32.0::gentoo, installed)
    (and 1 more with the same problem)

dev-libs/libgweather:2

  (dev-libs/libgweather-2.30.3::gentoo, ebuild scheduled for merge) pulled in by
    <dev-libs/libgweather-2.91:2 required by (gnome-extra/evolution-data-server-2.32.3-r3::gentoo, ebuild scheduled for merge)

  (dev-libs/libgweather-3.8.3::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libgweather-3.5.1:2= required by (gnome-base/gnome-panel-3.8.0-r1::gentoo, ebuild scheduled for merge)
    (and 2 more with the same problem)

gnome-extra/gnome-media:2

  (gnome-extra/gnome-media-3.4.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (gnome-extra/gnome-media-2.32.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    <gnome-extra/gnome-media-2.91 required by (dev-python/gnome-media-python-2.32.0::gentoo, installed)

media-libs/libpng:0

  (media-libs/libpng-1.5.17-r1::gentoo, installed) pulled in by
    >=media-libs/libpng-1.4.3[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

  (media-libs/libpng-1.5.17-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

media-libs/freetype:2

  (media-libs/freetype-2.4.11::gentoo, installed) pulled in by
    >=media-libs/freetype-2[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

  (media-libs/freetype-2.4.11::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

media-libs/lcms:0

  (media-libs/lcms-1.19::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/lcms-1.19::gentoo, installed) pulled in by
    >=media-libs/lcms-1.15:0[python] required by (media-libs/sk1libs-0.9.1::gentoo, installed)

virtual/jpeg:0

  (virtual/jpeg-0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/jpeg-0::gentoo, installed) pulled in by
    virtual/jpeg:0[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

media-libs/libmng:0

  (media-libs/libmng-1.0.10-r1::gentoo, installed) pulled in by
    media-libs/libmng[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

  (media-libs/libmng-1.0.10-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

sys-libs/zlib:0

  (sys-libs/zlib-1.2.8-r1::gentoo, installed) pulled in by
    sys-libs/zlib[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

  (sys-libs/zlib-1.2.8-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

app-arch/bzip2:0

  (app-arch/bzip2-1.0.6-r3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-arch/bzip2-1.0.6-r3::gentoo, installed) pulled in by
    app-arch/bzip2[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

virtual/libffi:0

  (virtual/libffi-3.0.11::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/libffi-3.0.11::gentoo, ebuild scheduled for merge) pulled in by
    virtual/libffi[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/glib-2.36.4-r1::gentoo, ebuild scheduled for merge)

virtual/libiconv:0

  (virtual/libiconv-0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/libiconv-0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/libiconv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/glib-2.36.4-r1::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-libs/libjpeg-turbo-1.3.0::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libjpeg-turbo-1.2.0:0[static-libs?] (>=media-libs/libjpeg-turbo-1.2.0:0) required by (virtual/jpeg-0::gentoo, ebuild scheduled for merge)

  (media-libs/jpeg-8d::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/jpeg-8d:0[static-libs?] (>=media-libs/jpeg-8d:0[static-libs]) required by (virtual/jpeg-0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by www-client/firefox-24.2.0[gstreamer]
# required by @selected
# required by @world (argument)
>=media-plugins/gst-plugins-meta-0.10-r8:0.10 ffmpeg

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.


Edit: My previous text was too long, had to shorten the list of packages. The full log is here.
Back to top
View user's profile Send private message
amasidlover
Apprentice
Apprentice


Joined: 16 Jun 2002
Posts: 275
Location: Manchester, UK

PostPosted: Sun Jan 05, 2014 9:57 am    Post subject: Reply with quote

I eventually found adding --backtrace=150 sorted out the blocks for me.

Also I found it failed in the middle due to perl 5.16 coming in and this gives an error with XML::Parser not found - I then had to do 'perl-cleaner modules' and restart the world update once perl cleaner finished.
_________________
http://www.axiomtech.co.uk
http://www.zednax.com
Back to top
View user's profile Send private message
floppes
n00b
n00b


Joined: 06 Jan 2005
Posts: 67
Location: Darmstadt, Germany

PostPosted: Sun Jan 05, 2014 7:15 pm    Post subject: Reply with quote

Thanks for the suggestion, but it didn't help even with --backtrack=300:

Code:
floppes-laptop ~ # emerge -avuDN --keep-going --backtrack=300 world gnome-base/gnome

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-arch/bzip2-1.0.6-r3  USE="-static -static-libs*" 0 kB
[ebuild     U  ] sys-devel/gnuconfig-20130516 [20130111] 51 kB
[ebuild   R    ] dev-libs/libffi-3.0.11  USE="-debug -static-libs* {-test}" 0 kB
[ebuild   R    ] dev-libs/libusb-1.0.9:1  USE="-debug -doc -static-libs*" 0 kB
[ebuild   R    ] virtual/libiconv-0  0 kB
[ebuild   R    ] media-libs/libogg-1.3.0  USE="-static-libs*" 0 kB
[ebuild   R    ] dev-libs/kpathsea-6.1.0_p20120701  USE="-doc -source -static-libs*" 0 kB
[ebuild   R    ] media-libs/libdvdcss-1.2.13:1.2  USE="-doc -static-libs*" 0 kB
[ebuild   R    ] dev-libs/libyaml-0.1.4  USE="-doc -examples -static-libs* {-test}" 0 kB
[ebuild   R    ] media-libs/webrtc-audio-processing-0.1  USE="-static-libs*" 0 kB
[ebuild  N     ] dev-libs/libdaemon-0.14-r1  USE="-doc -examples -static-libs" 333 kB
[ebuild   R    ] media-libs/libdiscid-0.2.2  USE="-static-libs*" 0 kB
[ebuild   R    ] dev-util/boost-build-1.52.0-r1  USE="-examples -python* {-test}" 0 kB
[ebuild  N     ] media-libs/jpeg-6b-r9:62  0 kB
[ebuild   R    ] dev-libs/libx86-1.1-r3  USE="-static-libs*" 0 kB
[ebuild   R    ] dev-libs/eventlog-0.2.12  USE="-static-libs*" 0 kB
[ebuild   R    ] virtual/libffi-3.0.11  0 kB
[ebuild  N     ] app-text/docbook-dsssl-stylesheets-1.79  0 kB
[ebuild   R    ] sys-libs/mtdev-1.1.4  USE="-static-libs*" 0 kB
[ebuild  N     ] sys-apps/keyutils-1.5.5  62 kB
[ebuild     U  ] app-emulation/emul-linux-x86-baselibs-20131008-r6 [20131008-r4] USE="development" ABI_X86="(-32)" 0 kB

[... shortened ...]

[ebuild  N     ] sys-apps/baobab-3.8.2  1,014 kB
[ebuild  N     ] gnome-extra/gnome-search-tool-3.6.0  670 kB
[ebuild  N     ] app-dicts/gnome-dictionary-3.8.0:0/6  USE="ipv6 -debug" 715 kB
[uninstall     ] gnome-extra/gnome-utils-2.32.0-r2  USE="ipv6 -bonobo -debug -doc {-test}"
[blocks b      ] <gnome-extra/gnome-utils-3.4 ("<gnome-extra/gnome-utils-3.4" is blocking app-admin/gnome-system-log-3.8.1, app-dicts/gnome-dictionary-3.8.0, media-gfx/gnome-font-viewer-3.8.0, sys-apps/baobab-3.8.2, gnome-extra/gnome-search-tool-3.6.0, media-gfx/gnome-screenshot-3.8.3)
[ebuild  N     ] gnome-base/gnome-extra-apps-3.8.0-r1:3.0  USE="games shotwell tracker" 0 kB
[ebuild     U  ] gnome-base/gnome-3.8.0-r1:2.0 [2.32.1-r2:2.0] USE="bluetooth%* cdr classic%* cups extras%* -accessibility -flashback% (-dvdr%*) (-ldap%*) (-mono%) (-policykit%*)" 0 kB
[blocks B      ] media-libs/jpeg:0 ("media-libs/jpeg:0" is blocking media-libs/libjpeg-turbo-1.3.0)

Total: 555 packages (130 upgrades, 148 new, 25 in new slots, 252 reinstalls, 6 uninstalls), Size of downloads: 905,492 kB
Conflict: 23 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

gnome-extra/evolution-data-server:0

  (gnome-extra/evolution-data-server-3.8.5::gentoo, ebuild scheduled for merge) pulled in by
    gnome-extra/evolution-data-server[vala] required by (gnome-extra/gnome-contacts-3.8.3::gentoo, ebuild scheduled for merge)
    >=gnome-extra/evolution-data-server-3.8.5:=[gnome-online-accounts?,weather?] required by (mail-client/evolution-3.8.5::gentoo, ebuild scheduled for merge)
    (and 6 more with the same problems)

  (gnome-extra/evolution-data-server-2.32.3-r3::gentoo, ebuild scheduled for merge) pulled in by
    <gnome-extra/evolution-data-server-3.6 required by (dev-python/evolution-python-2.32.0::gentoo, installed)
    (and 1 more with the same problem)

dev-libs/libgweather:2

  (dev-libs/libgweather-2.30.3::gentoo, ebuild scheduled for merge) pulled in by
    <dev-libs/libgweather-2.91:2 required by (gnome-extra/evolution-data-server-2.32.3-r3::gentoo, ebuild scheduled for merge)

  (dev-libs/libgweather-3.8.3::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libgweather-3.5.1:2= required by (gnome-base/gnome-panel-3.8.0-r1::gentoo, ebuild scheduled for merge)
    (and 2 more with the same problem)

gnome-extra/gnome-media:2

  (gnome-extra/gnome-media-3.4.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (gnome-extra/gnome-media-2.32.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    <gnome-extra/gnome-media-2.91 required by (dev-python/gnome-media-python-2.32.0::gentoo, installed)

media-libs/libpng:0

  (media-libs/libpng-1.5.17-r1::gentoo, installed) pulled in by
    >=media-libs/libpng-1.4.3[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

  (media-libs/libpng-1.5.17-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

media-libs/freetype:2

  (media-libs/freetype-2.4.11::gentoo, installed) pulled in by
    >=media-libs/freetype-2[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

  (media-libs/freetype-2.4.11::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

media-libs/lcms:0

  (media-libs/lcms-1.19::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/lcms-1.19::gentoo, installed) pulled in by
    >=media-libs/lcms-1.15:0[python] required by (media-libs/sk1libs-0.9.1::gentoo, installed)

virtual/jpeg:0

  (virtual/jpeg-0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/jpeg-0::gentoo, installed) pulled in by
    virtual/jpeg:0[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

media-libs/libmng:0

  (media-libs/libmng-1.0.10-r1::gentoo, installed) pulled in by
    media-libs/libmng[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

  (media-libs/libmng-1.0.10-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

sys-libs/zlib:0

  (sys-libs/zlib-1.2.8-r1::gentoo, installed) pulled in by
    sys-libs/zlib[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

  (sys-libs/zlib-1.2.8-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

app-arch/bzip2:0

  (app-arch/bzip2-1.0.6-r3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-arch/bzip2-1.0.6-r3::gentoo, installed) pulled in by
    app-arch/bzip2[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

virtual/libffi:0

  (virtual/libffi-3.0.11::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/libffi-3.0.11::gentoo, ebuild scheduled for merge) pulled in by
    virtual/libffi[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/glib-2.36.4-r1::gentoo, ebuild scheduled for merge)

virtual/libiconv:0

  (virtual/libiconv-0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/libiconv-0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/libiconv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/glib-2.36.4-r1::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-libs/libjpeg-turbo-1.3.0::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libjpeg-turbo-1.2.0:0[static-libs?] (>=media-libs/libjpeg-turbo-1.2.0:0) required by (virtual/jpeg-0::gentoo, ebuild scheduled for merge)

  (media-libs/jpeg-8d::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/jpeg-8d:0[static-libs?] (>=media-libs/jpeg-8d:0[static-libs]) required by (virtual/jpeg-0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by www-client/firefox-24.2.0[gstreamer]
# required by @selected
# required by @world (argument)
>=media-plugins/gst-plugins-meta-0.10-r8:0.10 ffmpeg

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.
floppes-laptop ~ #
Back to top
View user's profile Send private message
amasidlover
Apprentice
Apprentice


Joined: 16 Jun 2002
Posts: 275
Location: Manchester, UK

PostPosted: Sun Jan 05, 2014 9:29 pm    Post subject: Reply with quote

Looks like its offering you the option to do an automatic change (add --autounmask-write at the end of the emerge command then do dispatch-conf/etc-update). I'd try that and see if that does it (although I'm not terribly optimistic).
_________________
http://www.axiomtech.co.uk
http://www.zednax.com
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1551

PostPosted: Mon Jan 06, 2014 12:02 am    Post subject: Reply with quote

Focus on the blocker, as that's the main thing keeping it from continuing.

Quote:
[blocks B ] media-libs/jpeg:0 ("media-libs/jpeg:0" is blocking media-libs/libjpeg-turbo-1.3.0)


The solution is simple here, unmerge and mask the one you don't want and pick the other; the reverse dependencies (packages that depend on these) can help you choose.
Back to top
View user's profile Send private message
floppes
n00b
n00b


Joined: 06 Jan 2005
Posts: 67
Location: Darmstadt, Germany

PostPosted: Sat Jan 11, 2014 11:06 am    Post subject: Reply with quote

I went for libjpeg-turbo, but I still get this:

Code:
Total: 547 packages (128 upgrades, 2 downgrades, 142 new, 25 in new slots, 250 reinstalls, 7 uninstalls), Size of downloads: 892,770 kB
Conflict: 19 blocks

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

gnome-extra/evolution-data-server:0

  (gnome-extra/evolution-data-server-3.8.5::gentoo, ebuild scheduled for merge) pulled in by
    gnome-extra/evolution-data-server[vala] required by (gnome-extra/gnome-contacts-3.8.3::gentoo, ebuild scheduled for merge)
    >=gnome-extra/evolution-data-server-3.8.5:=[gnome-online-accounts?,weather?] required by (mail-client/evolution-3.8.5::gentoo, ebuild scheduled for merge)
    (and 6 more with the same problems)

  (gnome-extra/evolution-data-server-2.32.3-r3::gentoo, ebuild scheduled for merge) pulled in by
    <gnome-extra/evolution-data-server-3.6 required by (dev-python/evolution-python-2.32.0::gentoo, installed)
    (and 1 more with the same problem)

dev-libs/libgweather:2

  (dev-libs/libgweather-2.30.3::gentoo, ebuild scheduled for merge) pulled in by
    <dev-libs/libgweather-2.91:2 required by (gnome-extra/evolution-data-server-2.32.3-r3::gentoo, ebuild scheduled for merge)

  (dev-libs/libgweather-3.8.3::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libgweather-3.5.1:2= required by (gnome-base/gnome-panel-3.8.0-r1::gentoo, ebuild scheduled for merge)
    (and 2 more with the same problem)

dev-lang/python:2.7

  (dev-lang/python-2.7.5-r3::gentoo, installed) pulled in by
    =dev-lang/python-2*[tk] required by (media-gfx/skencil-0.6.18_pre20080519::gentoo, installed)

  (dev-lang/python-2.7.5-r3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

gnome-extra/gnome-media:2

  (gnome-extra/gnome-media-3.4.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (gnome-extra/gnome-media-2.32.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    <gnome-extra/gnome-media-2.91 required by (dev-python/gnome-media-python-2.32.0::gentoo, installed)

media-libs/libpng:0

  (media-libs/libpng-1.5.17-r1::gentoo, installed) pulled in by
    >=media-libs/libpng-1.4.3[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

  (media-libs/libpng-1.5.17-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

media-libs/lcms:0

  (media-libs/lcms-1.19::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/lcms-1.19::gentoo, installed) pulled in by
    >=media-libs/lcms-1.15:0[python] required by (media-libs/sk1libs-0.9.1::gentoo, installed)
    media-libs/lcms:0[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

media-libs/freetype:2

  (media-libs/freetype-2.4.11::gentoo, installed) pulled in by
    >=media-libs/freetype-2[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

  (media-libs/freetype-2.4.11::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

virtual/jpeg:0

  (virtual/jpeg-0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/jpeg-0::gentoo, installed) pulled in by
    virtual/jpeg:0[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

media-libs/libjpeg-turbo:0

  (media-libs/libjpeg-turbo-1.3.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/libjpeg-turbo-1.3.0::gentoo, installed) pulled in by
    >=media-libs/libjpeg-turbo-1.2.0:0[static-libs?] required by (virtual/jpeg-0::gentoo, installed)

media-libs/libmng:0

  (media-libs/libmng-1.0.10-r1::gentoo, installed) pulled in by
    media-libs/libmng[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

  (media-libs/libmng-1.0.10-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

sys-libs/zlib:0

  (sys-libs/zlib-1.2.8-r1::gentoo, installed) pulled in by
    sys-libs/zlib[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

  (sys-libs/zlib-1.2.8-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

app-arch/bzip2:0

  (app-arch/bzip2-1.0.6-r3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-arch/bzip2-1.0.6-r3::gentoo, installed) pulled in by
    app-arch/bzip2[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, ebuild scheduled for merge)

virtual/libffi:0

  (virtual/libffi-3.0.11::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/libffi-3.0.11::gentoo, ebuild scheduled for merge) pulled in by
    virtual/libffi[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/glib-2.36.4-r1::gentoo, ebuild scheduled for merge)

virtual/libiconv:0

  (virtual/libiconv-0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/libiconv-0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/libiconv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/glib-2.36.4-r1::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


How can I solve this?
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1551

PostPosted: Sat Jan 11, 2014 3:16 pm    Post subject: Reply with quote

Increase backtracking and/or try to manually upgrade each one listed; if upgrading doesn't work due to a blocker, you can attempt to mask one of both. Worst case, the reverse dependencies need both; in which case you'll need to make a choice based on those reverse dependencies, which means masking the reverse dependencies of one of both as well to get going.
Back to top
View user's profile Send private message
floppes
n00b
n00b


Joined: 06 Jan 2005
Posts: 67
Location: Darmstadt, Germany

PostPosted: Thu Jan 16, 2014 5:41 pm    Post subject: Reply with quote

Thanks, I finally got it :)

I emerged all packages without conflicts individually. Then I unmerged all Gnome packages, set USE="-gnome" and switched to profile default/linux/amd64/13.0/desktop. Emerged all packages with changed USE flags. Then I switched back to default/linux/amd64/13.0/desktop/gnome/systemd, had some conflicts to solve and after about 12 hours of emerging I have Gnome 3.8.

Yay, I love my Gentoo again!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum