Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
layman / portage error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
curmudgeon
Veteran
Veteran


Joined: 08 Aug 2003
Posts: 1356

PostPosted: Sat Aug 31, 2013 1:08 am    Post subject: layman / portage error Reply with quote

No idea what this means (or what to do about it), and since it appears rather esoteric, it seems best to ask here if anyone understands this message.

Code:

# layman -s sunrise

 * Fetching remote list,...
 * Fetching new list... http://www.gentoo.org/proj/en/overlays/repositories.xml
 * Last-modified: Fri, 23 Aug 2013 04:50:03 GMT
 * Fetch Ok

 * Syncing selected overlays,...
 * Running Git... # ( cd /usr/portage/local/layman/sunrise  && /usr/bin/git pull )
remote: Counting objects: 269, done.
remote: Compressing objects: 100% (194/194), done.
remote: Total 197 (delta 105), reused 0 (delta 0)
Receiving objects: 100% (197/197), 46.06 KiB | 51 KiB/s, done.
Resolving deltas: 100% (105/105), completed with 46 local objects.
From git://git.overlays.gentoo.org/proj/sunrise-reviewed
   a026aa0..8b843a6  master     -> origin/master
Updating a026aa0..8b843a6
Fast-forward

[...]

 *
 * Succeeded:
 * ------
 * Successfully synchronized overlay "sunrise".
 *

 * CLI: Errors occurred processing action sync
 * update_news() failed running portage news reporter function
 * Error was; No module named _emerge.actions
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2557
Location: Richmond, BC, Canada

PostPosted: Sat Aug 31, 2013 11:42 pm    Post subject: Reply with quote

Thanks curmudgeon, looks like a minor bug in my layman code. It was trying to import portage's news module to report any news items from the sunrise overlay. There was a change quite some time ago.

What portage version did this occur for?
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
curmudgeon
Veteran
Veteran


Joined: 08 Aug 2003
Posts: 1356

PostPosted: Sat Aug 31, 2013 11:49 pm    Post subject: Reply with quote

dol-sen wrote:
What portage version did this occur for?


I had just recently updated to the latest stable version - 2.1.12.2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum