Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with webdav davfs2 input/output error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Silmano
n00b
n00b


Joined: 10 Mar 2012
Posts: 38

PostPosted: Wed Jan 02, 2013 4:21 pm    Post subject: Problem with webdav davfs2 input/output error Reply with quote

I've installed and configured davfs2 to mount my box.com account in a command line only Gentoo machine. I've configured it so a user can mount it with its custom credentials, so the user can mount and unmount without problems.

Once the FS is mounted, I can ls to check the contents or do a copy from my local disk to the mount point (so its copied online).

The weird problem I'm having is that I don't seem to be able to copy from the FS to the local disk. A copy will return the "Input/Output error" when trying to do so. I've also tried the following:
cat /davfs2_fs/example_file.txt => will output the contents of the file
cp /davfs2_fs/example_file.txt /tmp => will give the I/O error
wc -l /davfs2_fs/example_file.txt => will give the I/O error as well
cp asd /davfs2_fs && ls /davfs2_fs => will copy 'asd' file to the FS and then list all the files (including the new one).

Any clue what could be the problem? The only thing I've tried (without luck) is setting use_locks 0 in the main config file (/etc/davfs2/davfs2.conf)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum