Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
qt-4.8.4, smplayer-0.8.1 segfault
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
wcg
Guru
Guru


Joined: 06 Jan 2009
Posts: 588

PostPosted: Tue Jan 01, 2013 3:59 am    Post subject: qt-4.8.4, smplayer-0.8.1 segfault Reply with quote

fyi, smplayer-0.8.1 segfaults at startup when linked
against qt-[core,dbus,script,gui]-4.8.4. Upgrade at
your own risk. (ebuilds for earlier qt versions are
missing from /usr/portage/x11-libs/qt-core/, etc.)

(x86_64-pc-linux-gnu, no multilib)
_________________
TIA
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3874
Location: Irgendwo im Nirgendwo

PostPosted: Tue Jan 01, 2013 10:23 am    Post subject: Reply with quote

fyi, have been running smplayer-0.8.1 with qt-4.8.4 without crashes. smplayer-0.8.2.1 worked fine, too.
Switched to (testing) smplayer2 + mplayer2, which work fine, too.

If there are crashes you should post a backtrace:
http://www.gentoo.org/proj/en/qa/backtraces.xml
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
wcg
Guru
Guru


Joined: 06 Jan 2009
Posts: 588

PostPosted: Wed Jan 02, 2013 3:39 pm    Post subject: Reply with quote

[edit] (dual post)
_________________
TIA


Last edited by wcg on Wed Jan 02, 2013 3:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
wcg
Guru
Guru


Joined: 06 Jan 2009
Posts: 588

PostPosted: Wed Jan 02, 2013 3:43 pm    Post subject: Reply with quote

I know how to post a backtrace, thanks for the link anyway.

I only used smplayer for audio 99% of the time, so I simply
unmerged qt and smplayer. I am using mplayer in text mode
for audio instead. (I logged smplayer-mplayer ouput awhile
ago, back when it did not segfault on startup, and cloned
the equalizer settings I had arrived at with smplayer's equalizer
into /etc/mplayer/mplayer.conf., so mplayer always uses
those equalizer settings without needing to pass them on
the command line. I will not need to change that mplayer.conf
option unless I move the speakers or get different ones.)

Doing that induced me to spend a weekend in the mplayer
manual, figuring out the audio mplayer.conf or command
line options, but once I did that, good to go.:-)
_________________
TIA
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum