Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gentoo installieren - Frage zu Kapitel 8 - env-update
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
CabalRAF
n00b
n00b


Joined: 25 Dec 2012
Posts: 1

PostPosted: Tue Dec 25, 2012 4:00 pm    Post subject: gentoo installieren - Frage zu Kapitel 8 - env-update Reply with quote

Hi,

ich bin gerade zum ersten mal dabei ein gentoo-system (minimal) aufzuspielen. Leider hänge ich grad bei der Anleitung in Kapitel 8 fest: http://www.gentoo.org/doc/de/handbook/handbook-amd64.xml?part=1&chap=8

Hier steht ganz unten, man soll folgenden Befehl ausführen:
Code:
env-update && source /etc/profile


Danach fliegt man aus der chroot-Umgebung raus und landet auf der livecd im ordner init.d
Muss ich nun wieder chroot ausführen? Und falls ja, wie? Denn einfach die Befehle aus Kapitel 6 ausführen geht leider nicht. (cp -L /etc/resolv.conf /mnt/gentoo/etc/: no such file or directory)
(mount: mount point /mnt/gentoo/proc does not exist)

Grüße
Cabal
Back to top
View user's profile Send private message
Schorchgrinder
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jun 2006
Posts: 81
Location: Lower Uncton

PostPosted: Wed Dec 26, 2012 12:27 pm    Post subject: Reply with quote

Hört sich mehr so an als ob du irgendwo einen Fehler beim chroot hast. evtl mal die gemounteten Sachen überprüfen.
_________________
AMD Athlon 1000 Mhz, RIVA TNT2/TNT2 Pro, Creative Labs SB Live, 1500 MB Arbeitsspeicher
damit läuft der Rechner unter Gentoo immer noch recht gut

AMD Athlon II X4 600e 2200 Mhz, Nvidia G210, 4GB RAM
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1375
Location: Bardowick, Germany

PostPosted: Thu Dec 27, 2012 1:31 pm    Post subject: Reply with quote

Oder aber du bist immer noch im chroot und der Teil "source /etc/profile" ersetzt schlicht den Wert für PS1, so dass der kleine Text "(chroot) " nicht mehr drin steht. ;)
Code:
 # grep PS1 /etc/profile
        # Newer bash ebuilds include /etc/bash/bashrc which will setup PS1
                PS1='\u@\h \w \$ '
        PS1="${USER:-$(whoami 2>/dev/null)}@$(uname -n 2>/dev/null) \$ "
Ich tippe also ganz stark darauf, dass du nicht aus dem chroot rausgeflogen bist.

Ein Hinweis, warum ich darauf komme dies zu vermuten, ist, dass du schreibst du wärst in "/etc/init.d". Laut Handbuch müsstest du dort nach dem Abschnitt "Netzwerk beim Systemstart aktivieren" auch sein, und zwar im chroot. :)
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 400
Location: münchen.de

PostPosted: Fri Dec 28, 2012 11:54 am    Post subject: Reply with quote

Hört sich so an, als ob du beim mounten (Kapitel 6) was vergessen hast:
Code:

mount -t proc none /mnt/gentoo/proc
mount --rbind /sys /mnt/gentoo/sys
mount --rbind /dev /mnt/gentoo/dev

_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Fri Mar 29, 2013 8:44 pm    Post subject: Reply with quote

Moved from Deutsche Dokumentation to Deutsches Forum (German).
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum