Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Zenbook wireless recieves SIGHUP and disconnects chronically
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
ShadowHawkBV
Apprentice
Apprentice


Joined: 27 Mar 2004
Posts: 262

PostPosted: Sun Dec 30, 2012 3:38 pm    Post subject: Zenbook wireless recieves SIGHUP and disconnects chronically Reply with quote

Well thanks to moving cfg80211 and mac80211 into the kernel instead of being modules, I can finally use the wireless on my ASUS Zenbook UX31E-DH51. Problem is it constantly drops the connection whether it's active or not. /var/log/messages shows this:
Code:
 sudo tail messages
Password:
Dec 30 10:00:39 ShadowUltraBook dbus[2123]: [system] Activating service name='org.gnome.SettingsDaemon.DateTimeMechanism' (using servicehelper)
Dec 30 10:00:39 ShadowUltraBook dbus[2123]: [system] Successfully activated service 'org.gnome.SettingsDaemon.DateTimeMechanism'
Dec 30 10:00:40 ShadowUltraBook blueman-mechanism: Starting blueman-mechanism
Dec 30 10:00:40 ShadowUltraBook dbus[2123]: [system] Successfully activated service 'org.blueman.Mechanism'
Dec 30 10:00:40 ShadowUltraBook blueman-mechanism: loading Network
Dec 30 10:00:40 ShadowUltraBook blueman-mechanism: loading Ppp
Dec 30 10:00:40 ShadowUltraBook blueman-mechanism: loading Config
Dec 30 10:00:40 ShadowUltraBook blueman-mechanism: loading RfKill
Dec 30 10:01:19 ShadowUltraBook dhcpcd[3183]: wlan0: checking for 192.168.1.164
Dec 30 10:01:23 ShadowUltraBook dhcpcd[3183]: wlan0: sending IPv6 Router Solicitation
Dec 30 10:01:23 ShadowUltraBook dhcpcd[3183]: wlan0: leased 192.168.1.164 for 3932100 seconds
Dec 30 10:01:23 ShadowUltraBook avahi-daemon[2156]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.1.164.
Dec 30 10:01:23 ShadowUltraBook avahi-daemon[2156]: New relevant interface wlan0.IPv4 for mDNS.
Dec 30 10:01:23 ShadowUltraBook avahi-daemon[2156]: Registering new address record for 192.168.1.164 on wlan0.IPv4.
Dec 30 10:01:23 ShadowUltraBook dhcpcd[3183]: forked to background, child pid 3214
Dec 30 10:01:27 ShadowUltraBook dhcpcd[3214]: wlan0: sending IPv6 Router Solicitation
Dec 30 10:01:32 ShadowUltraBook dhcpcd[3214]: received SIGHUP, releasing
Dec 30 10:01:32 ShadowUltraBook dhcpcd[3214]: wlan0: removing interface
Dec 30 10:01:32 ShadowUltraBook dhcpcd[3235]: sending signal 1 to pid 3214
Dec 30 10:01:32 ShadowUltraBook dhcpcd[3235]: waiting for pid 3214 to exit
Dec 30 10:01:32 ShadowUltraBook avahi-daemon[2156]: Interface wlan0.IPv6 no longer relevant for mDNS.
Dec 30 10:01:32 ShadowUltraBook avahi-daemon[2156]: Leaving mDNS multicast group on interface wlan0.IPv6 with address fe80::e2b9:a5ff:fed1:4d0e.
Dec 30 10:01:32 ShadowUltraBook avahi-daemon[2156]: Withdrawing address record for fe80::e2b9:a5ff:fed1:4d0e on wlan0.
Dec 30 10:01:32 ShadowUltraBook kernel: [   67.946387] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Dec 30 10:01:35 ShadowUltraBook sudo:   smengie : TTY=pts/0 ; PWD=/var/log ; USER=root ; COMMAND=/bin/tail messages
Dec 30 10:01:35 ShadowUltraBook sudo: pam_unix(sudo:session): session opened for user root by smengie(uid=0)


The /var/log/wicd/wicd.log contains(Note: The final is me connecting using eth0 so I can actually post this message):
Code:
 2012/12/30 10:00:31 :: wicd initializing...
2012/12/30 10:00:31 :: ---------------------------
2012/12/30 10:00:31 :: wicd is version 1.7.2.4 768
2012/12/30 10:00:31 :: setting backend to external
2012/12/30 10:00:31 :: trying to load backend external
2012/12/30 10:00:31 :: successfully loaded backend external
2012/12/30 10:00:31 :: WARNING: No path found for dhclient
2012/12/30 10:00:31 :: WARNING: No path found for pump
2012/12/30 10:00:31 :: WARNING: No path found for udhcpc
2012/12/30 10:00:31 :: WARNING: No path found for ktsuss
2012/12/30 10:00:31 :: WARNING: No path found for ip
2012/12/30 10:00:31 :: WARNING: No path found for resolvconf
2012/12/30 10:00:31 :: trying to load backend external
2012/12/30 10:00:31 :: successfully loaded backend external
2012/12/30 10:00:31 :: WARNING: No path found for dhclient
2012/12/30 10:00:31 :: WARNING: No path found for pump
2012/12/30 10:00:31 :: WARNING: No path found for udhcpc
2012/12/30 10:00:31 :: WARNING: No path found for ktsuss
2012/12/30 10:00:31 :: WARNING: No path found for ip
2012/12/30 10:00:31 :: WARNING: No path found for resolvconf
2012/12/30 10:00:31 :: Automatically detected wireless interface wlan0
2012/12/30 10:00:31 :: setting wireless interface wlan0
2012/12/30 10:00:31 :: Couldn't detect a wired interface.
2012/12/30 10:00:31 :: setting wired interface eth0
2012/12/30 10:00:31 :: setting wpa driver wext
2012/12/30 10:00:31 :: setting use global dns to False
2012/12/30 10:00:31 :: setting global dns
2012/12/30 10:00:31 :: global dns servers are None None None
2012/12/30 10:00:31 :: domain is None
2012/12/30 10:00:31 :: search domain is None
2012/12/30 10:00:31 :: setting automatically reconnect when connection drops True
2012/12/30 10:00:31 :: found wired_connect_mode in configuration 1
2012/12/30 10:00:31 :: found should_verify_ap in configuration 1
2012/12/30 10:00:31 :: Setting dhcp client to 0
2012/12/30 10:00:31 :: found show_never_connect in configuration False
2012/12/30 10:00:31 :: Wireless configuration file found...
2012/12/30 10:00:31 :: Wired configuration file found...
2012/12/30 10:00:31 :: chmoding configuration files 0600...
2012/12/30 10:00:31 :: chowning configuration files root:root...
2012/12/30 10:00:31 :: Using wireless interface...wlan0
2012/12/30 10:00:31 :: Using wired interface...eth0
2012/12/30 10:00:31 :: scanning start
2012/12/30 10:00:31 :: ifconfig wlan0 up
2012/12/30 10:00:31 :: iwlist wlan0 scan
2012/12/30 10:00:32 :: scanning done
2012/12/30 10:00:32 :: found 1 networks:
2012/12/30 10:00:32 :: found afterscript in configuration None
2012/12/30 10:00:32 :: found dhcphostname in configuration ShadowUltraBook
2012/12/30 10:00:32 :: found ip in configuration None
2012/12/30 10:00:32 :: found dns_domain in configuration None
2012/12/30 10:00:32 :: found gateway in configuration None
2012/12/30 10:00:32 :: found use_global_dns in configuration 0
2012/12/30 10:00:32 :: found postdisconnectscript in configuration None
2012/12/30 10:00:32 :: found beforescript in configuration None
2012/12/30 10:00:32 :: found netmask in configuration None
2012/12/30 10:00:32 :: found usedhcphostname in configuration 1
2012/12/30 10:00:32 :: found predisconnectscript in configuration None
2012/12/30 10:00:32 :: found enctype in configuration wpa-psk
2012/12/30 10:00:32 :: found dns3 in configuration None
2012/12/30 10:00:32 :: found dns2 in configuration None
2012/12/30 10:00:32 :: found search_domain in configuration None
2012/12/30 10:00:32 :: found use_settings_globally in configuration 0
2012/12/30 10:00:32 :: found use_static_dns in configuration 0
2012/12/30 10:00:32 :: found apsk in configuration *****
2012/12/30 10:00:32 :: found automatic in configuration 0
2012/12/30 10:00:32 :: found dns1 in configuration None
2012/12/30 10:00:36 :: ifconfig wlan0
2012/12/30 10:00:36 :: iwconfig wlan0
2012/12/30 10:00:36 :: GetCurrentNetworkID: Returning -1, current network not found
2012/12/30 10:00:36 :: Autoconnecting...
2012/12/30 10:00:36 :: Starting wireless autoconnect...
2012/12/30 10:00:36 :: No wired connection present, attempting to autoconnect to wireless network
2012/12/30 10:00:36 :: scanning start
2012/12/30 10:00:36 :: ifconfig wlan0 up
2012/12/30 10:00:36 :: iwlist wlan0 scan
2012/12/30 10:00:37 :: scanning done
2012/12/30 10:00:37 :: found 1 networks:
2012/12/30 10:00:37 :: found afterscript in configuration None
2012/12/30 10:00:37 :: found dhcphostname in configuration ShadowUltraBook
2012/12/30 10:00:37 :: found ip in configuration None
2012/12/30 10:00:37 :: found dns_domain in configuration None
2012/12/30 10:00:37 :: found gateway in configuration None
2012/12/30 10:00:37 :: found use_global_dns in configuration 0
2012/12/30 10:00:37 :: found postdisconnectscript in configuration None
2012/12/30 10:00:37 :: found beforescript in configuration None
2012/12/30 10:00:37 :: found netmask in configuration None
2012/12/30 10:00:37 :: found usedhcphostname in configuration 1
2012/12/30 10:00:37 :: found predisconnectscript in configuration None
2012/12/30 10:00:37 :: found enctype in configuration wpa-psk
2012/12/30 10:00:37 :: found dns3 in configuration None
2012/12/30 10:00:37 :: found dns2 in configuration None
2012/12/30 10:00:37 :: found search_domain in configuration None
2012/12/30 10:00:37 :: found use_settings_globally in configuration 0
2012/12/30 10:00:37 :: found use_static_dns in configuration 0
2012/12/30 10:00:37 :: found apsk in configuration *****
2012/12/30 10:00:37 :: found automatic in configuration 0
2012/12/30 10:00:37 :: found dns1 in configuration None
2012/12/30 10:00:37 :: ShadowRealm_wireless has profile
2012/12/30 10:00:37 :: Unable to autoconnect, you'll have to manually connect
2012/12/30 10:00:39 :: iwconfig wlan0
2012/12/30 10:00:41 :: ifconfig wlan0
2012/12/30 10:00:41 :: iwconfig wlan0
2012/12/30 10:00:41 :: GetCurrentNetworkID: Returning -1, current network not found
2012/12/30 10:00:41 :: Autoconnecting...
2012/12/30 10:00:41 :: Starting wireless autoconnect...
2012/12/30 10:00:41 :: No wired connection present, attempting to autoconnect to wireless network
2012/12/30 10:00:41 :: scanning start
2012/12/30 10:00:41 :: ifconfig wlan0 up
2012/12/30 10:00:41 :: iwlist wlan0 scan
2012/12/30 10:00:42 :: scanning done
2012/12/30 10:00:42 :: found 1 networks:
2012/12/30 10:00:42 :: found afterscript in configuration None
2012/12/30 10:00:42 :: found dhcphostname in configuration ShadowUltraBook
2012/12/30 10:00:42 :: found ip in configuration None
2012/12/30 10:00:42 :: found dns_domain in configuration None
2012/12/30 10:00:42 :: found gateway in configuration None
2012/12/30 10:00:42 :: found use_global_dns in configuration 0
2012/12/30 10:00:42 :: found postdisconnectscript in configuration None
2012/12/30 10:00:42 :: found beforescript in configuration None
2012/12/30 10:00:42 :: found netmask in configuration None
2012/12/30 10:00:42 :: found usedhcphostname in configuration 1
2012/12/30 10:00:42 :: found predisconnectscript in configuration None
2012/12/30 10:00:42 :: found enctype in configuration wpa-psk
2012/12/30 10:00:42 :: found dns3 in configuration None
2012/12/30 10:00:42 :: found dns2 in configuration None
2012/12/30 10:00:42 :: found search_domain in configuration None
2012/12/30 10:00:42 :: found use_settings_globally in configuration 0
2012/12/30 10:00:42 :: found use_static_dns in configuration 0
2012/12/30 10:00:42 :: found apsk in configuration *****
2012/12/30 10:00:42 :: found automatic in configuration 0
2012/12/30 10:00:42 :: found dns1 in configuration None
2012/12/30 10:00:42 :: ShadowRealm_wireless has profile
2012/12/30 10:00:42 :: Unable to autoconnect, you'll have to manually connect
2012/12/30 10:00:46 :: ifconfig wlan0
2012/12/30 10:00:46 :: iwconfig wlan0
2012/12/30 10:00:46 :: GetCurrentNetworkID: Returning -1, current network not found
2012/12/30 10:00:46 :: Autoconnecting...
2012/12/30 10:00:46 :: Starting wireless autoconnect...
2012/12/30 10:00:46 :: No wired connection present, attempting to autoconnect to wireless network
2012/12/30 10:00:46 :: scanning start
2012/12/30 10:00:46 :: ifconfig wlan0 up
2012/12/30 10:00:46 :: iwlist wlan0 scan
2012/12/30 10:00:47 :: scanning done
2012/12/30 10:00:47 :: found 1 networks:
2012/12/30 10:00:47 :: found afterscript in configuration None
2012/12/30 10:00:47 :: found dhcphostname in configuration ShadowUltraBook
2012/12/30 10:00:47 :: found ip in configuration None
2012/12/30 10:00:47 :: found dns_domain in configuration None
2012/12/30 10:00:47 :: found gateway in configuration None
2012/12/30 10:00:47 :: found use_global_dns in configuration 0
2012/12/30 10:00:47 :: found postdisconnectscript in configuration None
2012/12/30 10:00:47 :: found beforescript in configuration None
2012/12/30 10:00:47 :: found netmask in configuration None
2012/12/30 10:00:47 :: found usedhcphostname in configuration 1
2012/12/30 10:00:47 :: found predisconnectscript in configuration None
2012/12/30 10:00:47 :: found enctype in configuration wpa-psk
2012/12/30 10:00:47 :: found dns3 in configuration None
2012/12/30 10:00:47 :: found dns2 in configuration None
2012/12/30 10:00:47 :: found search_domain in configuration None
2012/12/30 10:00:47 :: found use_settings_globally in configuration 0
2012/12/30 10:00:47 :: found use_static_dns in configuration 0
2012/12/30 10:00:47 :: found apsk in configuration *****
2012/12/30 10:00:47 :: found automatic in configuration 0
2012/12/30 10:00:47 :: found dns1 in configuration None
2012/12/30 10:00:47 :: ShadowRealm_wireless has profile
2012/12/30 10:00:47 :: Unable to autoconnect, you'll have to manually connect
2012/12/30 10:00:51 :: ifconfig wlan0
2012/12/30 10:00:51 :: iwconfig wlan0
2012/12/30 10:00:51 :: GetCurrentNetworkID: Returning -1, current network not found
2012/12/30 10:00:51 :: Autoconnecting...
2012/12/30 10:00:51 :: Starting wireless autoconnect...
2012/12/30 10:00:51 :: No wired connection present, attempting to autoconnect to wireless network
2012/12/30 10:00:51 :: scanning start
2012/12/30 10:00:51 :: ifconfig wlan0 up
2012/12/30 10:00:51 :: iwlist wlan0 scan
2012/12/30 10:00:52 :: scanning done
2012/12/30 10:00:52 :: found 1 networks:
2012/12/30 10:00:52 :: found afterscript in configuration None
2012/12/30 10:00:52 :: found dhcphostname in configuration ShadowUltraBook
2012/12/30 10:00:52 :: found ip in configuration None
2012/12/30 10:00:52 :: found dns_domain in configuration None
2012/12/30 10:00:52 :: found gateway in configuration None
2012/12/30 10:00:52 :: found use_global_dns in configuration 0
2012/12/30 10:00:52 :: found postdisconnectscript in configuration None
2012/12/30 10:00:52 :: found beforescript in configuration None
2012/12/30 10:00:52 :: found netmask in configuration None
2012/12/30 10:00:52 :: found usedhcphostname in configuration 1
2012/12/30 10:00:52 :: found predisconnectscript in configuration None
2012/12/30 10:00:52 :: found enctype in configuration wpa-psk
2012/12/30 10:00:52 :: found dns3 in configuration None
2012/12/30 10:00:52 :: found dns2 in configuration None
2012/12/30 10:00:52 :: found search_domain in configuration None
2012/12/30 10:00:52 :: found use_settings_globally in configuration 0
2012/12/30 10:00:52 :: found use_static_dns in configuration 0
2012/12/30 10:00:52 :: found apsk in configuration *****
2012/12/30 10:00:52 :: found automatic in configuration 0
2012/12/30 10:00:52 :: found dns1 in configuration None
2012/12/30 10:00:52 :: ShadowRealm_wireless has profile
2012/12/30 10:00:52 :: Unable to autoconnect, you'll have to manually connect
2012/12/30 10:00:56 :: ifconfig wlan0
2012/12/30 10:01:01 :: ifconfig wlan0
2012/12/30 10:01:06 :: ifconfig wlan0
2012/12/30 10:01:10 :: found default in configuration 0
2012/12/30 10:01:10 :: Reading wired profile wired-default
2012/12/30 10:01:10 :: found afterscript in configuration None
2012/12/30 10:01:10 :: found dhcphostname in configuration ShadowUltraBook
2012/12/30 10:01:10 :: found postdisconnectscript in configuration None
2012/12/30 10:01:10 :: found dns_domain in configuration None
2012/12/30 10:01:10 :: found gateway in configuration None
2012/12/30 10:01:10 :: found use_global_dns in configuration 0
2012/12/30 10:01:10 :: found lastused in configuration True
2012/12/30 10:01:10 :: found encryption_enabled in configuration 0
2012/12/30 10:01:10 :: found beforescript in configuration None
2012/12/30 10:01:10 :: found ip in configuration None
2012/12/30 10:01:10 :: found broadcast in configuration None
2012/12/30 10:01:10 :: found netmask in configuration None
2012/12/30 10:01:10 :: found usedhcphostname in configuration 1
2012/12/30 10:01:10 :: found predisconnectscript in configuration None
2012/12/30 10:01:10 :: found enctype in configuration None
2012/12/30 10:01:10 :: found default in configuration 0
2012/12/30 10:01:10 :: found dns2 in configuration None
2012/12/30 10:01:10 :: found search_domain in configuration None
2012/12/30 10:01:10 :: found use_static_dns in configuration 0
2012/12/30 10:01:10 :: found dns3 in configuration None
2012/12/30 10:01:10 :: found profilename in configuration wired-default
2012/12/30 10:01:10 :: found dns1 in configuration None
2012/12/30 10:01:10 :: scanning start
2012/12/30 10:01:10 :: ifconfig wlan0 up
2012/12/30 10:01:10 :: iwlist wlan0 scan
2012/12/30 10:01:11 :: scanning done
2012/12/30 10:01:11 :: found 1 networks:
2012/12/30 10:01:11 :: found afterscript in configuration None
2012/12/30 10:01:11 :: found dhcphostname in configuration ShadowUltraBook
2012/12/30 10:01:11 :: found ip in configuration None
2012/12/30 10:01:11 :: found dns_domain in configuration None
2012/12/30 10:01:11 :: found gateway in configuration None
2012/12/30 10:01:11 :: found use_global_dns in configuration 0
2012/12/30 10:01:11 :: found postdisconnectscript in configuration None
2012/12/30 10:01:11 :: found beforescript in configuration None
2012/12/30 10:01:11 :: found netmask in configuration None
2012/12/30 10:01:11 :: found usedhcphostname in configuration 1
2012/12/30 10:01:11 :: found predisconnectscript in configuration None
2012/12/30 10:01:11 :: found enctype in configuration wpa-psk
2012/12/30 10:01:11 :: found dns3 in configuration None
2012/12/30 10:01:11 :: found dns2 in configuration None
2012/12/30 10:01:11 :: found search_domain in configuration None
2012/12/30 10:01:11 :: found use_settings_globally in configuration 0
2012/12/30 10:01:11 :: found use_static_dns in configuration 0
2012/12/30 10:01:11 :: found apsk in configuration *****
2012/12/30 10:01:11 :: found automatic in configuration 0
2012/12/30 10:01:11 :: found dns1 in configuration None
2012/12/30 10:01:11 :: iwconfig wlan0
2012/12/30 10:01:11 :: ifconfig wlan0
2012/12/30 10:01:13 :: Connecting to wireless network ShadowRealm_wireless
2012/12/30 10:01:13 :: /sbin/dhcpcd -k wlan0
2012/12/30 10:01:13 :: ifconfig wlan0 0.0.0.0
2012/12/30 10:01:13 :: /bin/route del dev wlan0
2012/12/30 10:01:13 :: ifconfig wlan0 down
2012/12/30 10:01:13 :: ifconfig wlan0 up
2012/12/30 10:01:13 :: wpa_cli -i wlan0 terminate
2012/12/30 10:01:13 :: Putting interface down
2012/12/30 10:01:13 :: ifconfig wlan0 down
2012/12/30 10:01:13 :: Releasing DHCP leases...
2012/12/30 10:01:13 :: /sbin/dhcpcd -k wlan0
2012/12/30 10:01:13 :: Setting false IP...
2012/12/30 10:01:13 :: ifconfig wlan0 0.0.0.0
2012/12/30 10:01:13 :: Stopping wpa_supplicant
2012/12/30 10:01:13 :: wpa_cli -i wlan0 terminate
2012/12/30 10:01:13 :: Flushing the routing table...
2012/12/30 10:01:13 :: /bin/route del dev wlan0
2012/12/30 10:01:13 :: iwconfig wlan0 mode managed
2012/12/30 10:01:13 :: Putting interface up...
2012/12/30 10:01:13 :: ifconfig wlan0 up
2012/12/30 10:01:15 :: enctype is wpa-psk
2012/12/30 10:01:15 :: Attempting to authenticate...
2012/12/30 10:01:15 :: ['wpa_supplicant', '-B', '-i', 'wlan0', '-c', '/var/lib/wicd/configurations/0022b0d4ba46', '-Dwext']
2012/12/30 10:01:15 :: ['iwconfig', 'wlan0', 'essid', '--', 'ShadowRealm_wireless']
2012/12/30 10:01:15 :: iwconfig wlan0 channel 1
2012/12/30 10:01:15 :: iwconfig wlan0 ap 00:22:B0:D4:BA:46
2012/12/30 10:01:15 :: WPA_CLI RESULT IS DISCONNECTED
2012/12/30 10:01:16 :: WPA_CLI RESULT IS DISCONNECTED
2012/12/30 10:01:17 :: WPA_CLI RESULT IS ASSOCIATED
2012/12/30 10:01:18 :: WPA_CLI RESULT IS COMPLETED
2012/12/30 10:01:18 :: Running DHCP with hostname ShadowUltraBook
2012/12/30 10:01:18 :: /sbin/dhcpcd -h ShadowUltraBook --noipv4ll wlan0
2012/12/30 10:01:18 :: dhcpcd[3183]: version 5.6.4 starting
2012/12/30 10:01:18 ::
2012/12/30 10:01:19 :: dhcpcd[3183]: wlan0: sending IPv6 Router Solicitation
2012/12/30 10:01:19 ::
2012/12/30 10:01:19 :: dhcpcd[3183]: wlan0: broadcasting for a lease
2012/12/30 10:01:19 ::
2012/12/30 10:01:19 :: dhcpcd[3183]: wlan0: offered 192.168.1.164 from 192.168.1.99
2012/12/30 10:01:19 ::
2012/12/30 10:01:19 :: dhcpcd[3183]: wlan0: acknowledged 192.168.1.164 from 192.168.1.99
2012/12/30 10:01:19 ::
2012/12/30 10:01:19 :: dhcpcd[3183]: wlan0: checking for 192.168.1.164
2012/12/30 10:01:19 ::
2012/12/30 10:01:23 :: dhcpcd[3183]: wlan0: sending IPv6 Router Solicitation
2012/12/30 10:01:23 ::
2012/12/30 10:01:23 :: dhcpcd[3183]: wlan0: leased 192.168.1.164 for 3932100 seconds
2012/12/30 10:01:23 ::
2012/12/30 10:01:23 :: dhcpcd[3183]: forked to background, child pid 3214
2012/12/30 10:01:23 ::
2012/12/30 10:01:23 ::
2012/12/30 10:01:23 :: DHCP connection successful
2012/12/30 10:01:23 :: not verifying
2012/12/30 10:01:23 :: Connecting thread exiting.
2012/12/30 10:01:23 :: ifconfig wlan0
2012/12/30 10:01:23 :: IP Address is: 192.168.1.164
2012/12/30 10:01:24 :: Sending connection attempt result success
2012/12/30 10:01:24 :: iwconfig wlan0
2012/12/30 10:01:26 :: ifconfig wlan0
2012/12/30 10:01:26 :: iwconfig wlan0
2012/12/30 10:01:28 :: ifconfig wlan0
2012/12/30 10:01:28 :: iwconfig wlan0
2012/12/30 10:01:32 :: ifconfig wlan0
2012/12/30 10:01:32 :: Forced disconnect on
2012/12/30 10:01:32 :: iwconfig wlan0
2012/12/30 10:01:32 :: /sbin/dhcpcd -k wlan0
2012/12/30 10:01:32 :: ifconfig wlan0 0.0.0.0
2012/12/30 10:01:32 :: /bin/route del dev wlan0
2012/12/30 10:01:32 :: ifconfig wlan0 down
2012/12/30 10:01:32 :: ifconfig wlan0 up
2012/12/30 10:01:32 :: wpa_cli -i wlan0 terminate
2012/12/30 10:01:34 :: ifconfig wlan0
2012/12/30 10:01:38 :: ifconfig wlan0
2012/12/30 10:01:40 :: ifconfig wlan0
2012/12/30 10:01:44 :: ifconfig wlan0
2012/12/30 10:01:46 :: ifconfig wlan0
2012/12/30 10:01:50 :: ifconfig wlan0
2012/12/30 10:01:52 :: ifconfig wlan0
2012/12/30 10:01:56 :: ifconfig wlan0
2012/12/30 10:01:58 :: ifconfig wlan0
2012/12/30 10:02:02 :: ifconfig wlan0
2012/12/30 10:02:04 :: ifconfig wlan0
2012/12/30 10:02:08 :: ifconfig wlan0
2012/12/30 10:02:10 :: ifconfig wlan0
2012/12/30 10:02:14 :: ifconfig wlan0
2012/12/30 10:02:18 :: ifconfig wlan0
2012/12/30 10:02:20 :: ifconfig wlan0
2012/12/30 10:02:24 :: ifconfig wlan0
2012/12/30 10:02:28 :: ifconfig wlan0
2012/12/30 10:02:30 :: ifconfig wlan0
2012/12/30 10:02:34 :: ifconfig wlan0
2012/12/30 10:02:36 :: ifconfig wlan0
2012/12/30 10:02:40 :: ifconfig wlan0
2012/12/30 10:02:42 :: ifconfig wlan0
2012/12/30 10:02:46 :: ifconfig wlan0
2012/12/30 10:02:48 :: ifconfig wlan0
2012/12/30 10:02:52 :: ifconfig wlan0
2012/12/30 10:02:54 :: ifconfig wlan0
2012/12/30 10:02:58 :: ifconfig wlan0
2012/12/30 10:03:00 :: ifconfig wlan0
2012/12/30 10:03:01 :: Connecting to wireless network ShadowRealm_wireless
2012/12/30 10:03:01 :: iwconfig wlan0
2012/12/30 10:03:01 :: /sbin/dhcpcd -k wlan0
2012/12/30 10:03:01 :: ifconfig wlan0 0.0.0.0
2012/12/30 10:03:01 :: /bin/route del dev wlan0
2012/12/30 10:03:01 :: ifconfig wlan0 down
2012/12/30 10:03:01 :: ifconfig wlan0 up
2012/12/30 10:03:01 :: wpa_cli -i wlan0 terminate
2012/12/30 10:03:01 :: Putting interface down
2012/12/30 10:03:01 :: ifconfig wlan0 down
2012/12/30 10:03:01 :: Releasing DHCP leases...
2012/12/30 10:03:01 :: /sbin/dhcpcd -k wlan0
2012/12/30 10:03:01 :: Setting false IP...
2012/12/30 10:03:01 :: ifconfig wlan0 0.0.0.0
2012/12/30 10:03:01 :: Stopping wpa_supplicant
2012/12/30 10:03:01 :: wpa_cli -i wlan0 terminate
2012/12/30 10:03:01 :: Flushing the routing table...
2012/12/30 10:03:01 :: /bin/route del dev wlan0
2012/12/30 10:03:01 :: iwconfig wlan0 mode managed
2012/12/30 10:03:01 :: Putting interface up...
2012/12/30 10:03:01 :: ifconfig wlan0 up
2012/12/30 10:03:03 :: enctype is wpa-psk
2012/12/30 10:03:03 :: Attempting to authenticate...
2012/12/30 10:03:03 :: ['wpa_supplicant', '-B', '-i', 'wlan0', '-c', '/var/lib/wicd/configurations/0022b0d4ba46', '-Dwext']
2012/12/30 10:03:03 :: ['iwconfig', 'wlan0', 'essid', '--', 'ShadowRealm_wireless']
2012/12/30 10:03:03 :: iwconfig wlan0 channel 1
2012/12/30 10:03:03 :: iwconfig wlan0 ap 00:22:B0:D4:BA:46
2012/12/30 10:03:03 :: WPA_CLI RESULT IS DISCONNECTED
2012/12/30 10:03:04 :: WPA_CLI RESULT IS ASSOCIATED
2012/12/30 10:03:05 :: WPA_CLI RESULT IS COMPLETED
2012/12/30 10:03:05 :: Running DHCP with hostname ShadowUltraBook
2012/12/30 10:03:05 :: /sbin/dhcpcd -h ShadowUltraBook --noipv4ll wlan0
2012/12/30 10:03:05 :: dhcpcd[3341]: version 5.6.4 starting
2012/12/30 10:03:05 ::
2012/12/30 10:03:05 :: dhcpcd[3341]: wlan0: sending IPv6 Router Solicitation
2012/12/30 10:03:05 ::
2012/12/30 10:03:05 :: dhcpcd[3341]: wlan0: rebinding lease of 192.168.1.164
2012/12/30 10:03:05 ::
2012/12/30 10:03:05 :: dhcpcd[3341]: wlan0: acknowledged 192.168.1.164 from 192.168.1.99
2012/12/30 10:03:05 ::
2012/12/30 10:03:05 :: dhcpcd[3341]: wlan0: checking for 192.168.1.164
2012/12/30 10:03:05 ::
2012/12/30 10:03:09 :: dhcpcd[3341]: wlan0: sending IPv6 Router Solicitation
2012/12/30 10:03:09 ::
2012/12/30 10:03:10 :: dhcpcd[3341]: wlan0: carrier lost
2012/12/30 10:03:10 ::
2012/12/30 10:03:13 :: dhcpcd[3341]: wlan0: carrier acquired
2012/12/30 10:03:13 ::
2012/12/30 10:03:13 :: dhcpcd[3341]: wlan0: sending IPv6 Router Solicitation
2012/12/30 10:03:13 ::
2012/12/30 10:03:13 :: dhcpcd[3341]: wlan0: rebinding lease of 192.168.1.164
2012/12/30 10:03:13 ::
2012/12/30 10:03:13 :: dhcpcd[3341]: wlan0: acknowledged 192.168.1.164 from 192.168.1.99
2012/12/30 10:03:13 ::
2012/12/30 10:03:13 :: dhcpcd[3341]: wlan0: checking for 192.168.1.164
2012/12/30 10:03:13 ::
2012/12/30 10:03:17 :: dhcpcd[3341]: wlan0: sending IPv6 Router Solicitation
2012/12/30 10:03:17 ::
2012/12/30 10:03:18 :: dhcpcd[3341]: wlan0: leased 192.168.1.164 for 3932100 seconds
2012/12/30 10:03:18 ::
2012/12/30 10:03:18 :: dhcpcd[3341]: forked to background, child pid 3384
2012/12/30 10:03:18 ::
2012/12/30 10:03:18 ::
2012/12/30 10:03:18 :: DHCP connection successful
2012/12/30 10:03:18 :: not verifying
2012/12/30 10:03:18 :: Connecting thread exiting.
2012/12/30 10:03:18 :: ifconfig wlan0
2012/12/30 10:03:18 :: IP Address is: 192.168.1.164
2012/12/30 10:03:18 :: Sending connection attempt result success
2012/12/30 10:03:18 :: iwconfig wlan0
2012/12/30 10:03:21 :: ifconfig wlan0
2012/12/30 10:03:21 :: iwconfig wlan0
2012/12/30 10:03:24 :: ifconfig wlan0
2012/12/30 10:03:24 :: iwconfig wlan0
2012/12/30 10:03:26 :: ifconfig wlan0
2012/12/30 10:03:26 :: iwconfig wlan0
2012/12/30 10:03:29 :: ifconfig wlan0
2012/12/30 10:03:29 :: iwconfig wlan0
2012/12/30 10:03:31 :: ifconfig wlan0
2012/12/30 10:03:31 :: iwconfig wlan0
2012/12/30 10:03:34 :: ifconfig wlan0
2012/12/30 10:03:34 :: iwconfig wlan0
2012/12/30 10:03:36 :: ifconfig wlan0
2012/12/30 10:03:36 :: iwconfig wlan0
2012/12/30 10:03:39 :: ifconfig wlan0
2012/12/30 10:03:39 :: iwconfig wlan0
2012/12/30 10:03:41 :: ifconfig wlan0
2012/12/30 10:03:41 :: iwconfig wlan0
2012/12/30 10:03:44 :: ifconfig wlan0
2012/12/30 10:03:44 :: Forced disconnect on
2012/12/30 10:03:44 :: iwconfig wlan0
2012/12/30 10:03:44 :: /sbin/dhcpcd -k wlan0
2012/12/30 10:03:44 :: ifconfig wlan0 0.0.0.0
2012/12/30 10:03:44 :: /bin/route del dev wlan0
2012/12/30 10:03:44 :: ifconfig wlan0 down
2012/12/30 10:03:44 :: ifconfig wlan0 up
2012/12/30 10:03:44 :: wpa_cli -i wlan0 terminate
2012/12/30 10:03:47 :: ifconfig wlan0
2012/12/30 10:03:48 :: Connecting to wireless network ShadowRealm_wireless
2012/12/30 10:03:48 :: iwconfig wlan0
2012/12/30 10:03:48 :: /sbin/dhcpcd -k wlan0
2012/12/30 10:03:48 :: ifconfig wlan0 0.0.0.0
2012/12/30 10:03:48 :: /bin/route del dev wlan0
2012/12/30 10:03:48 :: ifconfig wlan0 down
2012/12/30 10:03:48 :: ifconfig wlan0 up
2012/12/30 10:03:48 :: wpa_cli -i wlan0 terminate
2012/12/30 10:03:48 :: Putting interface down
2012/12/30 10:03:48 :: ifconfig wlan0 down
2012/12/30 10:03:48 :: Releasing DHCP leases...
2012/12/30 10:03:48 :: /sbin/dhcpcd -k wlan0
2012/12/30 10:03:48 :: Setting false IP...
2012/12/30 10:03:48 :: ifconfig wlan0 0.0.0.0
2012/12/30 10:03:48 :: Stopping wpa_supplicant
2012/12/30 10:03:48 :: wpa_cli -i wlan0 terminate
2012/12/30 10:03:48 :: Flushing the routing table...
2012/12/30 10:03:48 :: /bin/route del dev wlan0
2012/12/30 10:03:48 :: iwconfig wlan0 mode managed
2012/12/30 10:03:48 :: Putting interface up...
2012/12/30 10:03:48 :: ifconfig wlan0 up
2012/12/30 10:03:50 :: enctype is wpa-psk
2012/12/30 10:03:50 :: Attempting to authenticate...
2012/12/30 10:03:50 :: ['wpa_supplicant', '-B', '-i', 'wlan0', '-c', '/var/lib/wicd/configurations/0022b0d4ba46', '-Dwext']
2012/12/30 10:03:51 :: ['iwconfig', 'wlan0', 'essid', '--', 'ShadowRealm_wireless']
2012/12/30 10:03:51 :: iwconfig wlan0 channel 1
2012/12/30 10:03:51 :: iwconfig wlan0 ap 00:22:B0:D4:BA:46
2012/12/30 10:03:51 :: WPA_CLI RESULT IS DISCONNECTED
2012/12/30 10:03:52 :: WPA_CLI RESULT IS ASSOCIATED
2012/12/30 10:03:53 :: WPA_CLI RESULT IS COMPLETED
2012/12/30 10:03:53 :: Running DHCP with hostname ShadowUltraBook
2012/12/30 10:03:53 :: /sbin/dhcpcd -h ShadowUltraBook --noipv4ll wlan0
2012/12/30 10:03:53 :: dhcpcd[3459]: version 5.6.4 starting
2012/12/30 10:03:53 ::
2012/12/30 10:03:53 :: dhcpcd[3459]: wlan0: sending IPv6 Router Solicitation
2012/12/30 10:03:53 ::
2012/12/30 10:03:53 :: dhcpcd[3459]: wlan0: rebinding lease of 192.168.1.164
2012/12/30 10:03:53 ::
2012/12/30 10:03:53 :: dhcpcd[3459]: wlan0: acknowledged 192.168.1.164 from 192.168.1.99
2012/12/30 10:03:53 ::
2012/12/30 10:03:53 :: dhcpcd[3459]: wlan0: checking for 192.168.1.164
2012/12/30 10:03:53 ::
2012/12/30 10:03:57 :: dhcpcd[3459]: wlan0: sending IPv6 Router Solicitation
2012/12/30 10:03:57 ::
2012/12/30 10:03:58 :: dhcpcd[3459]: wlan0: leased 192.168.1.164 for 3932100 seconds
2012/12/30 10:03:58 ::
2012/12/30 10:03:58 :: dhcpcd[3459]: forked to background, child pid 3488
2012/12/30 10:03:58 ::
2012/12/30 10:03:58 ::
2012/12/30 10:03:58 :: DHCP connection successful
2012/12/30 10:03:58 :: not verifying
2012/12/30 10:03:58 :: Connecting thread exiting.
2012/12/30 10:03:58 :: ifconfig wlan0
2012/12/30 10:03:58 :: IP Address is: 192.168.1.164
2012/12/30 10:03:58 :: Sending connection attempt result success
2012/12/30 10:03:58 :: iwconfig wlan0
2012/12/30 10:04:00 :: ifconfig wlan0
2012/12/30 10:04:00 :: iwconfig wlan0
2012/12/30 10:04:02 :: ifconfig wlan0
2012/12/30 10:04:02 :: Forced disconnect on
2012/12/30 10:04:02 :: iwconfig wlan0
2012/12/30 10:04:02 :: /sbin/dhcpcd -k wlan0
2012/12/30 10:04:02 :: ifconfig wlan0 0.0.0.0
2012/12/30 10:04:02 :: /bin/route del dev wlan0
2012/12/30 10:04:02 :: ifconfig wlan0 down
2012/12/30 10:04:02 :: ifconfig wlan0 up
2012/12/30 10:04:02 :: wpa_cli -i wlan0 terminate
2012/12/30 10:04:04 :: ifconfig wlan0
2012/12/30 10:04:07 :: ifconfig wlan0
2012/12/30 10:04:09 :: ifconfig wlan0
2012/12/30 10:04:10 :: ifconfig eth0
2012/12/30 10:04:10 :: ifconfig eth0 up
2012/12/30 10:04:13 :: ifconfig wlan0
2012/12/30 10:04:13 :: ifconfig eth0
2012/12/30 10:04:13 :: iwconfig wlan0
2012/12/30 10:04:13 :: /sbin/dhcpcd -k wlan0
2012/12/30 10:04:13 :: ifconfig wlan0 0.0.0.0
2012/12/30 10:04:13 :: /bin/route del dev wlan0
2012/12/30 10:04:13 :: ifconfig wlan0 down
2012/12/30 10:04:13 :: ifconfig wlan0 up
2012/12/30 10:04:13 :: wpa_cli -i wlan0 terminate
2012/12/30 10:04:13 :: /sbin/dhcpcd -k eth0
2012/12/30 10:04:13 :: ifconfig eth0 0.0.0.0
2012/12/30 10:04:13 :: /bin/route del dev eth0
2012/12/30 10:04:13 :: ifconfig eth0 down
2012/12/30 10:04:13 :: ifconfig eth0 up
2012/12/30 10:04:14 :: wpa_cli -i eth0 terminate
2012/12/30 10:04:14 :: found lastused in configuration True
2012/12/30 10:04:14 :: Putting interface down
2012/12/30 10:04:14 :: ifconfig eth0 down
2012/12/30 10:04:14 :: Releasing DHCP leases...
2012/12/30 10:04:14 :: /sbin/dhcpcd -k eth0
2012/12/30 10:04:14 :: Setting false IP...
2012/12/30 10:04:14 :: ifconfig eth0 0.0.0.0
2012/12/30 10:04:15 :: Stopping wpa_supplicant
2012/12/30 10:04:15 :: wpa_cli -i eth0 terminate
2012/12/30 10:04:15 :: Flushing the routing table...
2012/12/30 10:04:15 :: /bin/route del dev eth0
2012/12/30 10:04:15 :: Putting interface up...
2012/12/30 10:04:15 :: ifconfig eth0 up
2012/12/30 10:04:17 :: Running DHCP with hostname ShadowUltraBook
2012/12/30 10:04:17 :: /sbin/dhcpcd -h ShadowUltraBook --noipv4ll eth0
2012/12/30 10:04:17 :: dhcpcd[3554]: version 5.6.4 starting
2012/12/30 10:04:17 ::
2012/12/30 10:04:17 :: dhcpcd[3554]: eth0: sending IPv6 Router Solicitation
2012/12/30 10:04:17 ::
2012/12/30 10:04:17 :: dhcpcd[3554]: eth0: broadcasting for a lease
2012/12/30 10:04:17 ::
2012/12/30 10:04:17 :: dhcpcd[3554]: eth0: offered 192.168.1.22 from 192.168.1.99
2012/12/30 10:04:17 ::
2012/12/30 10:04:17 :: dhcpcd[3554]: eth0: acknowledged 192.168.1.22 from 192.168.1.99
2012/12/30 10:04:17 ::
2012/12/30 10:04:17 :: dhcpcd[3554]: eth0: checking for 192.168.1.22
2012/12/30 10:04:17 ::
2012/12/30 10:04:21 :: dhcpcd[3554]: eth0: sending IPv6 Router Solicitation
2012/12/30 10:04:21 ::
2012/12/30 10:04:21 :: dhcpcd[3554]: eth0: leased 192.168.1.22 for 3932100 seconds
2012/12/30 10:04:21 ::
2012/12/30 10:04:21 :: dhcpcd[3554]: forked to background, child pid 3583
2012/12/30 10:04:21 ::
2012/12/30 10:04:21 ::
2012/12/30 10:04:21 :: DHCP connection successful
2012/12/30 10:04:21 :: Connecting thread exiting.
2012/12/30 10:04:21 :: ifconfig eth0

I have turned off the wireless powersave option in the kernel. Wicd is the only thing running to allow connection to the networks.
Code:
                acpid |      default                 
         avahi-daemon |      default                 
             bootmisc | boot                         
           consolekit |      default                 
                 dbus |      default                 
                devfs |                       sysinit
                dmesg |                       sysinit
                 fsck | boot                         
             hostname | boot                         
              hwclock | boot                         
              keymaps | boot                         
            killprocs |              shutdown       
          laptop_mode |      default                 
           lm_sensors |      default                 
                local |      default                 
           localmount | boot                         
              modules | boot                         
             mount-ro |              shutdown       
                 mtab | boot                         
               net.lo | boot                         
             netmount |      default                 
               procfs | boot                         
                 root | boot                         
            savecache |              shutdown       
                 swap | boot                         
            swapfiles | boot                         
               sysctl | boot                         
                sysfs |                       sysinit
            syslog-ng |      default                 
         termencoding | boot                         
       tmpfiles.setup | boot                         
                 udev |                       sysinit
           udev-mount |                       sysinit
       udev-postmount |      default                 
              urandom | boot                         
           vixie-cron |      default                 
                 wicd |      default                 
                  xdm |      default


I have tried the stable and the unstable versions of wpa_supplicant with the same results. The solutions I've found all involve firmware, and the linux-firmware packages don't have anything for the ath9k devices. I've also tried changing between WEP, WPA1 and WPA2 encryption with the same results. Is it possible that this is connected to the lack of an led lighting for the wireless, though rfkill shows the card is turned on?
Code:
sudo rfkill list all
0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no

Thank you for any help.
_________________
This space for rent... Well maybe to give away.. Heck.. i'll pay you to take it.

Lost Linux Neophyte
AMD Phenom(tm) II X4 955
Socket 939 AMD64X2 4200,
Intel Core i7-2670QM
Intel Core i5-2557M
Pure 64bit frustration :-)
Back to top
View user's profile Send private message
ShadowHawkBV
Apprentice
Apprentice


Joined: 27 Mar 2004
Posts: 262

PostPosted: Mon Dec 31, 2012 12:23 am    Post subject: Reply with quote

I have found a work around, but I really want to find a complete fix. using
Code:
sudo iwconfig wlan0 power off

Seems to keep from dropping the link, but being an ultrabook, I don't like what it will do to my battery life not having the power save mode working.

With this bit of info, does anyone have an idea for a better fix?
_________________
This space for rent... Well maybe to give away.. Heck.. i'll pay you to take it.

Lost Linux Neophyte
AMD Phenom(tm) II X4 955
Socket 939 AMD64X2 4200,
Intel Core i7-2670QM
Intel Core i5-2557M
Pure 64bit frustration :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum