Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] strange error w/new libpwquality dependency
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Sat Dec 29, 2012 4:25 pm    Post subject: [SOLVED] strange error w/new libpwquality dependency Reply with quote

This error is strange in the sense that it configures and compiles fine, but after stripping it errs with Excessive files found in the / partition

The build log is here: http://bpaste.net/show/67103/

It's not a disk space or inode problem
Code:
Filesystem      Size  Used Avail Use% Mounted on
/dev/sdb14       18G  9.9G  7.2G  58% /

Filesystem     Inodes IUsed IFree IUse% Mounted on
/dev/sdb14       1.2M  546k  569k   49% /

I checked the bug list and got Zarro Boogs found :?

I masked gnome-base/gnome-control-center and sys-apps/gnome-disk-utility to get the remaining 67 packages updated.

Any clues would be appreciated :)
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)


Last edited by BillWho on Sat Dec 29, 2012 6:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8833

PostPosted: Sat Dec 29, 2012 5:25 pm    Post subject: Reply with quote

Look at the actual die message, a few lines farther down. This package installed a static library into /lib64, which install_qa_check correctly considers to be a severe bug. This probably happens only with USE=static-libs, so other people have not noticed it yet. If I am right, you can get rid of the error by removing USE=static-libs. Why do you have USE=static-libs on this package?

Separately, this is a bug that should be reported.
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Sat Dec 29, 2012 6:24 pm    Post subject: Reply with quote

Hu wrote:
Look at the actual die message, a few lines farther down. This package installed a static library into /lib64, which install_qa_check correctly considers to be a severe bug. This probably happens only with USE=static-libs, so other people have not noticed it yet. If I am right, you can get rid of the error by removing USE=static-libs. Why do you have USE=static-libs on this package?

Separately, this is a bug that should be reported.


Thanks Hu, that went right over my head :oops: In my defense though, it's not at all that hard to do :D

I enabled static-libs a long time ago for experimentation purposes and just left it alone. I actually forgot it was enabled. I never encountered an error with it set until now.

Adding dev-libs/libpwquality -static-libs to package.mask did the trick. I filed a bug report for this error.

272 packages will be rebuilt as a consequence of disabling it so I should probably just bite the bullet soon :)
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum