Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cave/paludis: problem updating python-exec
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
andi456
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2005
Posts: 123
Location: Germany

PostPosted: Tue Nov 05, 2013 3:00 pm    Post subject: cave/paludis: problem updating python-exec Reply with quote

Hi everybody,

again there are problems with python dependent packages. This time dev-lang/python-exec and dev-python/python-exec are causing trouble. When I try to update the former package, I get the following error:
Code:
These are the actions I will take, in order:

n   dev-lang/python-exec:2::gentoo 2.0 to ::installed [cycle 1]
    "Python script wrapper"
    PYTHON_TARGETS: (jython2_5) (jython2_7) (pypy2_0) (python2_6) (python2_7) (python3_2) (python3_3) build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: dev-python/python-exec-10000.2:2::gentoo
    In dependency cycle with existing packages: dev-lang/python-exec:2, dev-python/python-exec:0, dev-python/python-exec:2

s   dev-python/python-exec:0::gentoo 10000.1 to ::installed [cycle 1]
    "Compatibility package for dev-lang/python-exec"
    PYTHON_TARGETS: (jython2_5) (jython2_7) (pypy2_0) (python2_6) (python2_7) (python3_2) (python3_3) build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: !<dev-python/python-exec-10000 from dev-lang/python-exec-0.3.1:0::gentoo, !<dev-python/python-exec-10000 from dev-lang/python-exec-2.0:2::gentoo, dev-libs/libxml2-2.9.1-r1:2::installed, 12 more

u   dev-python/python-exec:2::gentoo 10000.2 to ::installed replacing 2.0-r3 [cycle 1]
    PYTHON_TARGETS: (jython2_5) (jython2_7) (pypy2_0) (python2_6) (python2_7) (python3_2) (python3_3) build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: !<dev-python/python-exec-10000 from dev-lang/python-exec-0.3.1:0::gentoo, !<dev-python/python-exec-10000 from dev-lang/python-exec-2.0:2::gentoo, dev-libs/boost-1.52.0-r6:0::installed, 6 more

Total: 1 upgrades, 1 new slot installs, 1 new installs

Build Options:
    dwarf_compress:                Compress DWARF2+ debug information
    optional_tests:                Run tests considered by the package to be optional
    symbols:                       How to handle debug symbols in installed files
    trace:                         Trace actions executed by the package (very noisy, for debugging broken builds only)
    work:                          Whether to preserve or remove working directories

python_targets:
    jython2_5:                     Build with Jython 2.5
    jython2_7:                     Build with Jython 2.7
    pypy2_0:                       Build with PyPy 2.0
    python2_6:                     Build with Python 2.6
    python2_7:                     Build with Python 2.7
    python3_2:                     Build with Python 3.2
    python3_3:                     Build with Python 3.3

I encountered the following errors:

!   dev-lang/python-exec
    Reasons: target, dev-python/python-exec-10000.1:0::gentoo, dev-python/python-exec-10000.2:2::gentoo
    Unsuitable candidates:
      * dev-lang/python-exec-0.3.1:0::gentoo
        Did not meet dev-lang/python-exec:0[python_targets_jython2_5(-)?,python_targets_jython2_7(-)?,python_targets_pypy2_0(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy2_0(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)], use existing if possible, installing to / from dev-python/python-exec-10000.1:0::gentoo
            Flag 'python_targets_pypy2_0' enabled if it is enabled for 'dev-python/python-exec-10000.1:0::gentoo', assuming disabled if missing; Flag 'python_targets_python3_3' enabled if it is enabled for 'dev-python/python-exec-10000.1:0::gentoo', assuming disabled if missing
      * dev-lang/python-exec-0.9999:0::gentoo
        Masked by keyword
            Keywords

Should I unmask dev-lang/python-exec-0.9999:0 and if so, how? My entry in /etc/paludis/package_unmask.conf doesn't seem to have the desired effect:
Code:
=dev-lang/python-exec-0.9999

I tried this because some guys managed to work around the problem with portage http://forums.gentoo.org/viewtopic-p-7433360.html.

What else could I try?

Thanks in advance.

Regards Andreas
Back to top
View user's profile Send private message
yoshi314
l33t
l33t


Joined: 30 Dec 2004
Posts: 823
Location: PL

PostPosted: Tue Nov 05, 2013 9:10 pm    Post subject: Reply with quote

i'd try the resolve command with -Km -km

that will offer to rebuild packages whose ebuilds in installed db differ from portage ebuilds. those ebuilds often introduce obsolete dependency restrictions (yes, they sometimes change without version bump!)

you could also try --explain "dev-lang/python-exec" --explain "dev-python/python-exec" which might add extra info on why specific version was taken into consideration or eliminated and what is blocking it.

Quote:
Flag 'python_targets_pypy2_0' enabled if it is enabled for 'dev-python/python-exec-10000.1:0::gentoo', assuming disabled if missing; Flag 'python_targets_python3_3' enabled if it is enabled for 'dev-python/python-exec-10000.1:0::gentoo', assuming disabled if missing
check those too.
_________________
~amd64
shrink your /usr/portage with squashfs+aufs
Back to top
View user's profile Send private message
andi456
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2005
Posts: 123
Location: Germany

PostPosted: Tue Nov 05, 2013 10:19 pm    Post subject: Reply with quote

Unfortunately the problem persists with cave resolve -km -Km dev-lang/python-exec. So I tried the --explain option which hasn't made it any clearer for me so far:

Code:
cave resolve dev-python/python-exec --explain "dev-lang/python-exec"
These are the actions I will take, in order:

n   dev-lang/python-exec:2::gentoo 2.0 to ::installed [cycle 1]
    "Python script wrapper"
    PYTHON_TARGETS: (jython2_5) (jython2_7) (pypy2_0) (python2_6) (python2_7) (python3_2) (python3_3) build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: dev-python/python-exec-10000.2:2::gentoo
    In dependency cycle with existing packages: dev-lang/python-exec:2, dev-python/python-exec:0, dev-python/python-exec:2

s   dev-python/python-exec:0::gentoo 10000.1 to ::installed [cycle 1]
    "Compatibility package for dev-lang/python-exec"
    PYTHON_TARGETS: (jython2_5) (jython2_7) (pypy2_0) (python2_6) (python2_7) (python3_2) (python3_3) build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: !<dev-python/python-exec-10000 from dev-lang/python-exec-2.0:2::gentoo, dev-libs/libxml2-2.9.1-r1:2::installed, dev-libs/libxslt-1.1.28-r1:0::installed, 11 more

u   dev-python/python-exec:2::gentoo 10000.2 to ::installed replacing 2.0-r3 [cycle 1]
    PYTHON_TARGETS: (jython2_5) (jython2_7) (pypy2_0) (python2_6) (python2_7) (python3_2) (python3_3) build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: target, !<dev-python/python-exec-10000 from dev-lang/python-exec-2.0:2::gentoo, dev-libs/boost-1.52.0-r6:0::installed, 6 more

Total: 1 upgrades, 1 new slot installs, 1 new installs

Build Options:
    dwarf_compress:                Compress DWARF2+ debug information
    optional_tests:                Run tests considered by the package to be optional
    symbols:                       How to handle debug symbols in installed files
    trace:                         Trace actions executed by the package (very noisy, for debugging broken builds only)
    work:                          Whether to preserve or remove working directories

python_targets:
    jython2_5:                     Build with Jython 2.5
    jython2_7:                     Build with Jython 2.7
    pypy2_0:                       Build with PyPy 2.0
    python2_6:                     Build with Python 2.6
    python2_7:                     Build with Python 2.7
    python3_2:                     Build with Python 3.2
    python3_3:                     Build with Python 3.3

I encountered the following errors:

!   dev-lang/python-exec
    Reasons: dev-python/python-exec-10000.1:0::gentoo, dev-python/python-exec-10000.2:2::gentoo
    Unsuitable candidates:
      * dev-lang/python-exec-0.3.1:0::gentoo
        Did not meet dev-lang/python-exec:0[python_targets_jython2_5(-)?,python_targets_jython2_7(-)?,python_targets_pypy2_0(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy2_0(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)], use existing if possible, installing to / from dev-python/python-exec-10000.2:2::gentoo
            Flag 'python_targets_pypy2_0' enabled if it is enabled for 'dev-python/python-exec-10000.2:2::gentoo', assuming disabled if missing; Flag 'python_targets_python3_3' enabled if it is enabled for 'dev-python/python-exec-10000.2:2::gentoo', assuming disabled if missing
      * dev-lang/python-exec-0.9999:0::gentoo
        Masked by keyword
            Keywords

Explaining requested decisions:

For dev-lang/python-exec:0::(install_to_slash):
    The following constraints were in action:
      * dev-lang/python-exec:0[python_targets_jython2_5(-)?,python_targets_jython2_7(-)?,python_targets_pypy2_0(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy2_0(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)], use existing if possible, installing to /
        Because of dev-lang/python-exec:0[python_targets_jython2_5(-)?,python_targets_jython2_7(-)?,python_targets_pypy2_0(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy2_0(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)] from dev-python/python-exec-10000.1:0::gentoo, key 'Run dependencies', labelled 'RDEPEND'
        Because of dev-lang/python-exec:0[python_targets_jython2_5(-)?,python_targets_jython2_7(-)?,python_targets_pypy2_0(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy2_0(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)] from dev-python/python-exec-10000.2:2::gentoo, key 'Run dependencies', labelled 'RDEPEND'
    No decision could be made
For dev-lang/python-exec:2::(install_to_slash):
    The following constraints were in action:
      * dev-lang/python-exec:2[python_targets_jython2_5(-)?,python_targets_jython2_7(-)?,python_targets_pypy2_0(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy2_0(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)], use existing if possible, installing to /
        Because of dev-lang/python-exec:2[python_targets_jython2_5(-)?,python_targets_jython2_7(-)?,python_targets_pypy2_0(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy2_0(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)] from dev-python/python-exec-10000.2:2::gentoo, key 'Run dependencies', labelled 'RDEPEND'
    The decision made was:
        Use origin ID dev-lang/python-exec-2.0:2::gentoo
        Install to repository installed

Code:
cave resolve dev-lang/python-exec --explain "dev-python/python-exec"
These are the actions I will take, in order:

n   dev-lang/python-exec:2::gentoo 2.0 to ::installed [cycle 1]
    "Python script wrapper"
    PYTHON_TARGETS: (jython2_5) (jython2_7) (pypy2_0) (python2_6) (python2_7) (python3_2) (python3_3) build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: target, dev-python/python-exec-10000.2:2::gentoo
    In dependency cycle with existing packages: dev-lang/python-exec:2, dev-python/python-exec:0, dev-python/python-exec:2

s   dev-python/python-exec:0::gentoo 10000.1 to ::installed [cycle 1]
    "Compatibility package for dev-lang/python-exec"
    PYTHON_TARGETS: (jython2_5) (jython2_7) (pypy2_0) (python2_6) (python2_7) (python3_2) (python3_3) build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: !<dev-python/python-exec-10000 from dev-lang/python-exec-2.0:2::gentoo, dev-libs/libxml2-2.9.1-r1:2::installed, dev-libs/libxslt-1.1.28-r1:0::installed, 11 more

u   dev-python/python-exec:2::gentoo 10000.2 to ::installed replacing 2.0-r3 [cycle 1]
    PYTHON_TARGETS: (jython2_5) (jython2_7) (pypy2_0) (python2_6) (python2_7) (python3_2) (python3_3) build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: !<dev-python/python-exec-10000 from dev-lang/python-exec-2.0:2::gentoo, dev-libs/boost-1.52.0-r6:0::installed, dev-python/pyelftools-0.21-r4:0::installed, 5 more

Total: 1 upgrades, 1 new slot installs, 1 new installs

Build Options:
    dwarf_compress:                Compress DWARF2+ debug information
    optional_tests:                Run tests considered by the package to be optional
    symbols:                       How to handle debug symbols in installed files
    trace:                         Trace actions executed by the package (very noisy, for debugging broken builds only)
    work:                          Whether to preserve or remove working directories

python_targets:
    jython2_5:                     Build with Jython 2.5
    jython2_7:                     Build with Jython 2.7
    pypy2_0:                       Build with PyPy 2.0
    python2_6:                     Build with Python 2.6
    python2_7:                     Build with Python 2.7
    python3_2:                     Build with Python 3.2
    python3_3:                     Build with Python 3.3

I encountered the following errors:

!   dev-lang/python-exec
    Reasons: dev-python/python-exec-10000.1:0::gentoo, dev-python/python-exec-10000.2:2::gentoo
    Unsuitable candidates:
      * dev-lang/python-exec-0.3.1:0::gentoo
        Did not meet dev-lang/python-exec:0[python_targets_jython2_5(-)?,python_targets_jython2_7(-)?,python_targets_pypy2_0(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy2_0(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)], use existing if possible, installing to / from dev-python/python-exec-10000.1:0::gentoo
            Flag 'python_targets_pypy2_0' enabled if it is enabled for 'dev-python/python-exec-10000.1:0::gentoo', assuming disabled if missing; Flag 'python_targets_python3_3' enabled if it is enabled for 'dev-python/python-exec-10000.1:0::gentoo', assuming disabled if missing
      * dev-lang/python-exec-0.9999:0::gentoo
        Masked by keyword
            Keywords

Explaining requested decisions:

For dev-python/python-exec:0::(install_to_slash):
    The following constraints were in action:
      * !<dev-python/python-exec-10000, use existing if possible, installing to / (nothing is fine too)
        Because of !<dev-python/python-exec-10000 from dev-lang/python-exec-2.0:2::gentoo
      * dev-python/python-exec:0/0=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-)], use existing if possible, installing to /
        Because of dev-python/python-exec:0/0=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-)] from dev-libs/libxslt-1.1.28-r1:0::installed, key 'Run dependencies', labelled 'RDEPEND', conditions 'python?'
        Because of dev-python/python-exec:0/0=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-)] from net-libs/libproxy-0.4.11-r1:0::installed, key 'Run dependencies', labelled 'RDEPEND', conditions 'python?'
      * dev-python/python-exec:0/0=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_single_target_python2_6(+)?,python_single_target_python2_7(+)?], use existing if possible, installing to /
        Because of dev-python/python-exec:0/0=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_single_target_python2_6(+)?,python_single_target_python2_7(+)?] from sys-fs/cryptsetup-1.6.2:0::installed, key 'Run dependencies', labelled 'RDEPEND', conditions 'python?'
        Because of dev-python/python-exec:0/0=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_single_target_python2_6(+)?,python_single_target_python2_7(+)?] from sys-libs/talloc-2.1.0:0::installed, key 'Run dependencies', labelled 'RDEPEND'
        Because of dev-python/python-exec:0/0=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_single_target_python2_6(+)?,python_single_target_python2_7(+)?] from sys-libs/tdb-1.2.12-r1:0::installed, key 'Run dependencies', labelled 'RDEPEND', conditions 'python?'
        Because of dev-python/python-exec:0/0=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_single_target_python2_6(+)?,python_single_target_python2_7(+)?] from sys-libs/tevent-0.9.19:0::installed, key 'Run dependencies', labelled 'RDEPEND'
      * dev-python/python-exec:0/0=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)], use existing if possible, installing to /
        Because of dev-python/python-exec:0/0=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] from dev-libs/libxml2-2.9.1-r1:2::installed, key 'Run dependencies', labelled 'RDEPEND', conditions 'python?'
        Because of dev-python/python-exec:0/0=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] from dev-python/PyQt4-4.10.2:0::installed, key 'Run dependencies', labelled 'RDEPEND'
        Because of dev-python/python-exec:0/0=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] from dev-python/dbus-python-1.2.0:0::installed, key 'Run dependencies', labelled 'RDEPEND'
        Because of dev-python/python-exec:0/0=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] from dev-python/sip-4.14.7:0::installed, key 'Run dependencies', labelled 'RDEPEND'
        Because of dev-python/python-exec:0/0=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] from x11-proto/xcb-proto-1.8-r3:0::installed, key 'Run dependencies', labelled 'RDEPEND'
      * dev-python/python-exec:0[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)], use existing if possible, installing to /
        Because of dev-python/python-exec:0[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] from dev-python/PyQt4-4.10.2:0::installed, key 'Run dependencies', labelled 'RDEPEND'
      * dev-python/python-exec:0[python_targets_python2_7(-)?,python_single_target_python2_7(+)?], use existing if possible, installing to /
        Because of dev-python/python-exec:0[python_targets_python2_7(-)?,python_single_target_python2_7(+)?] from media-libs/alsa-lib-1.0.27.2:0::installed, key 'Run dependencies', labelled 'RDEPEND', conditions 'python?'
        Because of dev-python/python-exec:0[python_targets_python2_7(-)?,python_single_target_python2_7(+)?] from sys-apps/usbutils-007:0::installed, key 'Run dependencies', labelled 'RDEPEND', conditions 'python?'
    The decision made was:
        Use origin ID dev-python/python-exec-10000.1:0::gentoo
        Install to repository installed
For dev-python/python-exec:2::(install_to_slash):
    The following constraints were in action:
      * !<dev-python/python-exec-10000, use existing if possible, installing to / (nothing is fine too)
        Because of !<dev-python/python-exec-10000 from dev-lang/python-exec-2.0:2::gentoo
      * dev-python/python-exec:2/2=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_single_target_python2_6(+)?,python_single_target_python2_7(+)?], use existing if possible, installing to /
        Because of dev-python/python-exec:2/2=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_single_target_python2_6(+)?,python_single_target_python2_7(+)?] from kde-base/plasma-workspace-4.11.2-r1:4::installed, key 'Run dependencies', labelled 'RDEPEND', conditions 'python?'
      * dev-python/python-exec:2/2=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)], use existing if possible, installing to /
        Because of dev-python/python-exec:2/2=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] from dev-libs/boost-1.52.0-r6:0::installed, key 'Run dependencies', labelled 'RDEPEND', conditions 'python?'
        Because of dev-python/python-exec:2/2=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] from kde-base/pykde4-4.11.2-r1:4::installed, key 'Run dependencies', labelled 'RDEPEND'
        Because of dev-python/python-exec:2/2=[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] from media-libs/lcms-1.19-r1:0::installed, key 'Run dependencies', labelled 'RDEPEND', conditions 'python?'
      * dev-python/python-exec:2/2=[python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_single_target_python2_7(+)?,python_single_target_python3_2(+)?,python_single_target_python3_3(+)?], use existing if possible, installing to /
        Because of dev-python/python-exec:2/2=[python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_single_target_python2_7(+)?,python_single_target_python3_2(+)?,python_single_target_python3_3(+)?] from sys-apps/util-linux-2.24:0::installed, key 'Run dependencies', labelled 'RDEPEND', conditions 'python?'
      * dev-python/python-exec:2[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_single_target_python2_6(+)?,python_single_target_python2_7(+)?], use existing if possible, installing to /
        Because of dev-python/python-exec:2[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_single_target_python2_6(+)?,python_single_target_python2_7(+)?] from sys-apps/paludis-1.4.2-r1:0::installed, key 'Run dependencies', labelled 'RDEPEND', conditions 'python?'
      * dev-python/python-exec:2[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)], use existing if possible, installing to /
        Because of dev-python/python-exec:2[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] from dev-python/pyelftools-0.21-r4:0::installed, key 'Run dependencies', labelled 'RDEPEND'
    The decision made was:
        Use origin ID dev-python/python-exec-10000.2:2::gentoo
        Install to repository installed
            Replacing dev-python/python-exec-2.0-r3:2::installed
Back to top
View user's profile Send private message
cengique
n00b
n00b


Joined: 17 Mar 2012
Posts: 11
Location: United States

PostPosted: Wed Nov 06, 2013 4:29 am    Post subject: Reply with quote

You need to manually remove dev-python/python-exec and intall the other one instead:
Code:
emerge --unmerge python-exec
emerge dev-lang/python-exec

Got it from here:
http://www.gossamer-threads.com/lists/gentoo/dev/280385
Back to top
View user's profile Send private message
christian.
n00b
n00b


Joined: 11 Sep 2013
Posts: 5

PostPosted: Fri Nov 08, 2013 10:24 am    Post subject: Reply with quote

cengique wrote:
You need to manually remove dev-python/python-exec and intall the other one instead:

Not sure if that's correct. It might be. Though, now that I have resolved the issue on my system both packages are still installed.

I solved the problem by executing:

Code:
cave resolve -c1 dev-python/python-exec dev-lang/python-exec -x
Back to top
View user's profile Send private message
andi456
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2005
Posts: 123
Location: Germany

PostPosted: Fri Nov 08, 2013 10:38 am    Post subject: Reply with quote

This seems to be causing even more trouble, as it pulls in a few other unresolved problems...The error messages look as follows:
Code:
cave resolve -c1 dev-python/python-exec dev-lang/python-exec -x

r   dev-lang/python-exec:2::gentoo 2.0 to ::installed replacing 2.0 [cycle 1]
    PYTHON_TARGETS: (jython2_5) (jython2_7) (pypy2_0) (python2_6) (python2_7) (python3_2) (python3_3) build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: target, dev-python/python-exec-10000.2:2::gentoo, net-print/cups-1.6.4:0::installed
    In dependency cycle with existing packages: dev-lang/python-exec:2, dev-libs/mpfr:0, dev-python/python-exec:0, dev-python/python-exec:2, sys-apps/portage:0

u   dev-libs/mpfr:0::gentoo 3.1.2-r1 to ::installed replacing 3.1.1 [cycle 1]
    -static-libs build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: dev-libs/mpc-1.0.1:0::installed, dev-libs/rasqal-0.9.30:0::installed, sys-devel/gcc-4.5.4:4.5::installed, 3 more
    1.02 MBytes to download

r   dev-python/python-exec:0::gentoo 10000.1 to ::installed replacing 10000.1 [cycle 1]
    PYTHON_TARGETS: (jython2_5) (jython2_7) (pypy2_0)* (python2_6) (python2_7) (python3_2) (python3_3)* build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: target, !<dev-python/python-exec-10000 from dev-lang/python-exec-2.0:2::gentoo, dev-libs/libxml2-2.9.1-r1:2::installed, 12 more

r   dev-python/python-exec:2::gentoo 10000.2 to ::installed replacing 10000.2 [cycle 1]
    PYTHON_TARGETS: (jython2_5) (jython2_7) (pypy2_0) (python2_6) (python2_7) (python3_2) (python3_3) build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: target, !<dev-python/python-exec-10000 from dev-lang/python-exec-2.0:2::gentoo, dev-libs/boost-1.52.0-r6:0::installed, 8 more

r   sys-apps/portage:0::gentoo 2.2.7 to ::installed replacing 2.2.7 [cycle 1]
    -build -doc -epydoc (ipc) (-pypy2_0) -python2 -python3 (-selinux) xattr* LINGUAS: -ru PYTHON_TARGETS: -pypy2_0 python2_6 python2_7 python3_2 -python3_3 (-python3_4) build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: !!<sys-apps/portage-2.1.9 from dev-lang/python-2.6.8-r3:2.6::installed, !!<sys-apps/portage-2.1.9 from dev-lang/python-2.7.5-r4:2.7::installed, !<sys-apps/portage-2.1.10.41 from app-misc/ca-certificates-20130119:0::installed, 3 more

u   x11-drivers/nvidia-drivers:0::gentoo 331.17 to ::installed replacing 331.13
    X acpi (multilib) -pax_kernel tools build_options: -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: !=x11-drivers/nvidia-drivers-180* from x11-libs/libvdpau-0.7:0::installed, !=x11-drivers/nvidia-drivers-185* from x11-libs/libvdpau-0.7:0::installed, !=x11-drivers/nvidia-drivers-190* from x11-libs/libvdpau-0.7:0::installed, x11-base/xorg-drivers-1.14:0::installed
    57.10 MBytes to download

Total: 4 reinstalls, 2 upgrades, 58.13 MBytes to download

USE:
    xattr:                         Add support for extended attributes (filesystem-stored metadata)

python_targets:
    pypy2_0:                       Build with PyPy 2.0
    python3_3:                     Build with Python 3.3

I encountered the following errors:

!   dev-lang/python-exec
    Reasons: target, dev-python/python-exec-10000.1:0::gentoo, dev-python/python-exec-10000.2:2::gentoo
    Unsuitable candidates:
      * dev-lang/python-exec-0.3.1:0::installed
        Did not meet dev-lang/python-exec, never using existing, installing to / from target
      * dev-lang/python-exec-0.3.1:0::gentoo
        Did not meet dev-lang/python-exec:0[python_targets_jython2_5(-)?,python_targets_jython2_7(-)?,python_targets_pypy2_0(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy2_0(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-)], use existing if same, installing to / from dev-python/python-exec-10000.2:2::gentoo (and 1 more)
            Flag 'python_targets_pypy2_0' enabled if it is enabled for 'dev-python/python-exec-10000.2:2::gentoo', assuming disabled if missing; Flag 'python_targets_python3_3' enabled if it is enabled for 'dev-python/python-exec-10000.2:2::gentoo', assuming disabled if missing
      * dev-lang/python-exec-0.9999:0::gentoo
        Masked by keyword
            Keywords
!   dev-lang/python
    Reasons: app-admin/python-updater-0.11:0::installed, dev-libs/libgamin-0.1.10-r3:0::installed, dev-libs/libnatspec-0.2.6:0::installed, 5 more
    Unsuitable candidates:
      * dev-lang/python-2.5.4-r6:2.5::installed
!   dev-lang/python
    Reasons: app-admin/python-updater-0.11:0::installed, dev-libs/libnatspec-0.2.6:0::installed, sys-apps/file-5.12-r1:0::installed, 2 more
    Unsuitable candidates:
      * dev-lang/python-3.1.5-r1:3.1::installed
!   net-fs/samba
    Reasons: !!<net-fs/samba-3.6.0[ldb] from sys-libs/ldb-1.1.16:0::gentoo, !!>=net-fs/samba-4.0.0[ldb] from sys-libs/ldb-1.1.16:0::gentoo, gnome-base/gvfs-1.12.3-r1:0::installed, 2 more
    Unsuitable candidates:
      * net-fs/samba-3.5.21:0::gentoo
        Did not meet >=net-fs/samba-4.0.0_alpha1, use existing if same, installing to / from restarted because of net-fs/cifs-utils-6.2:0::gentoo
      * net-fs/samba-3.5.22:0::gentoo
        Did not meet >=net-fs/samba-4.0.0_alpha1, use existing if same, installing to / from restarted because of net-fs/cifs-utils-6.2:0::gentoo
      * net-fs/samba-3.6.16:0::gentoo
        Did not meet >=net-fs/samba-4.0.0_alpha1, use existing if same, installing to / from restarted because of net-fs/cifs-utils-6.2:0::gentoo
      * net-fs/samba-3.6.19:0::gentoo
        Did not meet >=net-fs/samba-4.0.0_alpha1, use existing if same, installing to / from restarted because of net-fs/cifs-utils-6.2:0::gentoo
      * net-fs/samba-4.0.10-r1:0::gentoo
        Masked by repository
            Patrick Lauer <patrick@gentoo.org> (07 Apr 2010) Lars Wendler <polynomial-c@gentoo.org> (14 Oct 2013) Keeping samba-4.0 masked until bug #447022 is fixed. 4.1 masked for testing.
        Did not meet >=net-fs/samba-3.4.6[smbclient], use existing if same, installing to / from gnome-base/gvfs-1.12.3-r1:0::installed
            Flag 'smbclient' enabled
      * net-fs/samba-4.1.0-r1:0::gentoo
        Masked by repository
            Patrick Lauer <patrick@gentoo.org> (07 Apr 2010) Lars Wendler <polynomial-c@gentoo.org> (14 Oct 2013) Keeping samba-4.0 masked until bug #447022 is fixed. 4.1 masked for testing.
        Did not meet >=net-fs/samba-3.4.6[smbclient], use existing if same, installing to / from gnome-base/gvfs-1.12.3-r1:0::installed
            Flag 'smbclient' enabled
!   sys-kernel/gentoo-sources
    Reasons: virtual/linux-sources-0:0::installed
    Unsuitable candidates:
      * sys-kernel/gentoo-sources-3.8.6:3.8.6::installed
!   sys-kernel/gentoo-sources
    Reasons: virtual/linux-sources-0:0::installed
    Unsuitable candidates:
      * sys-kernel/gentoo-sources-3.8.8:3.8.8::installed
!   sys-kernel/gentoo-sources
    Reasons: virtual/linux-sources-0:0::installed
    Unsuitable candidates:
      * sys-kernel/gentoo-sources-3.9.0:3.9.0::installed
!   sys-kernel/gentoo-sources
    Reasons: virtual/linux-sources-0:0::installed
    Unsuitable candidates:
      * sys-kernel/gentoo-sources-3.9.2:3.9.2::installed
!   sys-kernel/gentoo-sources
    Reasons: virtual/linux-sources-0:0::installed
    Unsuitable candidates:
      * sys-kernel/gentoo-sources-3.9.4:3.9.4::installed
!   sys-kernel/gentoo-sources
    Reasons: virtual/linux-sources-0:0::installed
    Unsuitable candidates:
      * sys-kernel/gentoo-sources-3.9.7:3.9.7::installed
!   sys-kernel/gentoo-sources
    Reasons: virtual/linux-sources-0:0::installed
    Unsuitable candidates:
      * sys-kernel/gentoo-sources-3.10.1:3.10.1::installed
!   sys-kernel/gentoo-sources
    Reasons: virtual/linux-sources-0:0::installed
    Unsuitable candidates:
      * sys-kernel/gentoo-sources-3.11.2:3.11.2::installed
Back to top
View user's profile Send private message
sirro
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1471
Location: aachen.nrw.de.eu

PostPosted: Sat Nov 09, 2013 1:43 pm    Post subject: Reply with quote

I resolved this by reinstalling all packages that depend on dev-python/python-exec and uninstalling it at the same time. Basically something like this:
Code:
cave resolve -x1 $(equery d dev-python/python-exec|sed -e 's#^#=#') \!dev-python/python-exec


The reinstallation of all those packages ensures that they all depend on the new dev-lang/python-exec instead of the old dev-python/python-exec.

IIRC the uninstall of dev-python/python-exec isn't really needed to solve this, but after this it's unused anyway.
Back to top
View user's profile Send private message
andi456
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2005
Posts: 123
Location: Germany

PostPosted: Sun Nov 10, 2013 3:45 pm    Post subject: Reply with quote

Well, I'm not sure, if I understood you correctly but this is what I got when I issue cave resolve -1 $(equery d dev-python/python-exec|sed -e 's#^#=#') \!dev-python/python-exec:
Code:
These are the actions I will take, in order:

<   dev-python/python-exec 10000.1:0::installed
    Reasons: target

<   dev-python/python-exec 10000.2:2::installed
    Reasons: target

Total: 2 uninstalls

I cannot proceed without being permitted to do the following:

X   app-accessibility/speech-dispatcher 0.8-r2:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   app-portage/gentoolkit 0.3.0.8-r2:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.2:2::installed (DEPEND), dependent upon dev-python/python-exec-10000.2:2::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   app-text/asciidoc 8.6.8-r1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-java/java-config 2.1.12-r1:2::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-libs/boost 1.52.0-r6:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.2:2::installed (DEPEND), dependent upon dev-python/python-exec-10000.2:2::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-libs/libxml2 2.9.1-r1:2::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-libs/libxslt 1.1.28-r1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/PyQt4 4.10.2:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/argparse 1.2.1-r2:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/beautifulsoup 3.2.1-r1:python-2::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/beautifulsoup 4.1.3-r1:4::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/cython 0.19.1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.2:2::installed (DEPEND), dependent upon dev-python/python-exec-10000.2:2::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/dbus-python 1.2.0:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/docutils 0.10:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/feedparser 5.1.3-r1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/imaging 1.1.7-r2:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.2:2::installed (DEPEND), dependent upon dev-python/python-exec-10000.2:2::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/lxml 3.2.1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/m2crypto 0.21.1-r1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/mygpoclient 1.7-r1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/numpy 1.7.1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.2:2::installed (DEPEND), dependent upon dev-python/python-exec-10000.2:2::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/pycairo 1.10.0-r4:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/pycrypto 2.6.1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.2:2::installed (DEPEND), dependent upon dev-python/python-exec-10000.2:2::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/pyelftools 0.21-r4:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.2:2::installed (DEPEND), dependent upon dev-python/python-exec-10000.2:2::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/pygments 1.6:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/pygobject 2.28.6-r53:2::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/pygobject 3.2.2-r1:3::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/python-dateutil 2.1-r1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/setuptools 0.8-r1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/simplejson 3.3.1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.2:2::installed (DEPEND), dependent upon dev-python/python-exec-10000.2:2::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/sip 4.14.7:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/six 1.3.0:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-python/wxpython 2.8.12.1-r1:2.8::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-util/gdbus-codegen 2.36.4-r1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   dev-vcs/subversion 1.7.13:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   kde-misc/kanyremote 6.3.1:4::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   media-libs/alsa-lib 1.0.27.2:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   media-libs/avidemux-plugins 2.6.5-r1:2.6::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   media-libs/lcms 1.19-r1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.2:2::installed (DEPEND), dependent upon dev-python/python-exec-10000.2:2::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   net-libs/libproxy 0.4.11-r1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   net-wireless/bluez 4.101-r7:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.2:2::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   sys-apps/paludis 1.4.2-r1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.2:2::installed (DEPEND), dependent upon dev-python/python-exec-10000.2:2::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   sys-apps/usbutils 007:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   sys-apps/util-linux 2.24:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.2:2::installed (DEPEND), dependent upon dev-python/python-exec-10000.2:2::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   sys-devel/llvm 3.3-r1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.2:2::installed (DEPEND), dependent upon dev-python/python-exec-10000.2:2::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   sys-fs/cryptsetup 1.6.2:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   sys-libs/talloc 2.1.0:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   sys-libs/tdb 1.2.12-r1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   sys-libs/tevent 0.9.19:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   virtual/python-argparse 1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   x11-libs/libxcb 1.9.1:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   x11-libs/xpyb 1.3.1-r2:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.2:2::installed (DEPEND), dependent upon dev-python/python-exec-10000.2:2::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

X   x11-proto/xcb-proto 1.8-r3:0::installed
    Will be broken by uninstalls:
    Reasons: dependent upon dev-python/python-exec-10000.1:0::installed (DEPEND), dependent upon dev-python/python-exec-10000.1:0::installed (RDEPEND)
    Cannot proceed without: --uninstalls-may-break or --remove-if-dependent

Does this mean that I need to add --uninstalls-may-break '*/*' and all the dependent packages will be reinstalled?
Back to top
View user's profile Send private message
sirro
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1471
Location: aachen.nrw.de.eu

PostPosted: Sun Nov 10, 2013 4:34 pm    Post subject: Reply with quote

Quote:
Does this mean that I need to add --uninstalls-may-break '*/*' and all the dependent packages will be reinstalled?

There must be something different on your system than on mine. I had a quick look at my bash_history and there is no uninstalls-may-break or something like that anywhere near my command.
From the output I'd guess that uninstalls-may-break will really break these packages, so I cannot advise to do this.

I'm sorry that the command wasn't a help to you.
Back to top
View user's profile Send private message
yoshi314
l33t
l33t


Joined: 30 Dec 2004
Posts: 823
Location: PL

PostPosted: Tue Nov 12, 2013 7:45 am    Post subject: Reply with quote

do you have any PYTHON_TARGETS enabled?
_________________
~amd64
shrink your /usr/portage with squashfs+aufs
Back to top
View user's profile Send private message
andi456
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2005
Posts: 123
Location: Germany

PostPosted: Wed Nov 13, 2013 6:04 pm    Post subject: Reply with quote

Yes, I have:
Code:
*/* PYTHON_TARGETS: -*  python2_6 python2_7 python3_2


I do not remember, which packages required these targets, but I am quite sure that I had to add them during some update procedure.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum