Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Compiz
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Kate Monster
Apprentice
Apprentice


Joined: 13 Jun 2006
Posts: 224
Location: Clarkston, Michigan

PostPosted: Thu Apr 19, 2012 6:19 pm    Post subject: Compiz Reply with quote

Hi there,

I'm trying to get compiz working. However, both 0.8.8 and 0.9.2 do not work. 0.8.8 crashes the X server, complaining of "Resource temporarily unavailable after 142 requests", sorry, I would have the exact error message, but it's past the backlog in my terminal and I don't feel like crashing X again for it :P

0.9.2 fails during configuration. Error message is as follows:
Code:
Plugin configure check results:

  ini           : Yes
  kde           : Yes
  obs           : Yes
  blur          : Yes
  dbus          : Yes
  cube          : Yes
  fade          : Yes
  glib          : Yes
  move          : Yes
  zoom          : Yes
  copytex       : Yes
  clone         : Yes
  decor         : Yes
  annotate      : Yes
  place         : Yes
  regex         : Yes
  scale         : Yes
  water         : Yes
  composite     : Yes
  switcher      : Yes
  commands      : Yes
  gnomecompat   : Yes
  imgpng        : Yes
  imgsvg        : Yes
  compiztoolbox : Yes
  opengl        : Yes
  resize        : Yes
  rotate        : Yes
  wobbly        : Yes
  inotify       : Yes
  screenshot    : Yes

************************************************************

WARNING:
"FindCompiz.cmake" file not found in cmake module directories.
It should be installed to allow building of external compiz packages.
Call "sudo make findcompiz_install" to install it.

************************************************************

-- <<< Gentoo configuration >>>
Build type      Gentoo
Install path    /usr
Compiler flags:
C               -Wall
C++             -Wall
Linker flags:
Executable       -Wl,-O1 -Wl,--as-needed
Module           -Wl,-O1 -Wl,--as-needed
Shared           -Wl,-O1 -Wl,--as-needed

-- Configuring incomplete, errors occurred!
 * ERROR: x11-wm/compiz-0.9.2 failed (configure phase):
 *   cmake failed
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_configure
 *   environment, line 2822:  Called cmake-utils_src_configure
 *   environment, line  712:  Called _execute_optionaly 'src_configure'
 *   environment, line  309:  Called enable_cmake-utils_src_configure
 *   environment, line 1032:  Called die
 * The specific snippet of code:
 *       "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
 *
 * If you need support, post the output of 'emerge --info =x11-wm/compiz-0.9.2',
 * the complete build log and the output of 'emerge -pqv =x11-wm/compiz-0.9.2'.
 * This ebuild is from an overlay named 'desktop-effects': '/var/lib/layman/desktop-effects/'
 * The complete build log is located at '/var/tmp/portage/x11-wm/compiz-0.9.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-wm/compiz-0.9.2/temp/environment'.
 * S: '/var/tmp/portage/x11-wm/compiz-0.9.2/work/compiz-core-0.9.2'

>>> Failed to emerge x11-wm/compiz-0.9.2, Log file:

>>>  '/var/tmp/portage/x11-wm/compiz-0.9.2/temp/build.log'

My emerge --info:
Code:
Portage 2.1.10.56 (default/linux/x86/10.0/desktop/kde, gcc-4.5.3, glibc-2.14.1-r3, 3.3.0-gentoo i686)
=================================================================
System uname: Linux-3.3.0-gentoo-i686-Intel-R-_Core-TM-2_CPU_6300_@_1.86GHz-with-gentoo-2.1
Timestamp of tree: Wed, 18 Apr 2012 08:00:01 +0000
ccache version 3.1.7 [disabled]
app-shells/bash:          4.2_p24
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3, 3.2.2-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.9.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.5
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.7
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.3 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo gamerlay-stable stuff seden java-overlay desktop-effects x-portage
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.ussg.iu.edu/pub/linux/gentoo http://lug.mtu.edu/gentoo/ ftp://lug.mtu.edu/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/gamerlay /var/lib/layman/stuff /var/lib/layman/seden /var/lib/layman/java-overlay /var/lib/layman/desktop-effects /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa archive arts baselayout2 bash-completion berkdb bluetooth branding bzip2 cairo ccache cdda cdr cjk cleartype cli consolekit cpudetection cracklib crypt css cups cxx dbus declarative directfb divx dri dts dvb dvd dvdr emboss emerald encode exif exiv2 expat faac fam fat ffmpeg firefox flac fontconfig fortran gdbm gdu gif gimp gimpprint glade glib glibc-omitfp glitz glsa gpm gtk gzip htmlhandbook ibam iconv immqt-bc ipod ipv6 irc java java6 jpeg jpeg2k kdrive kipi lcdfilter lcms ldap libnotify lm_sensors mad mcal mmx mng modules mp3 mp4 mpd mpeg msn mudflap ncurses nfs nls nptlonly nsplugin ntfs ntp nvidia offensive ogg opengl openmp oscar oss pam pango pcre pda pdf phonon pidgin plasma png policykit ppds pppd prime python python3 qt qt-copy qt3 qt3support qt4 readline realmedia reiser4 reiserfs ruby samba scim sdl semantic-desktop session spell sse sse2 ssl startup-notification subversion svg sysfs tcpd theora threads tiff tk truetype udev unicode usb v4l vlm vorbis webkit win32codecs wxwidgets x264 x86 xcb xcomposite xfce xinerama xml xorg xscreensaver xv xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia intel vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Back to top
View user's profile Send private message
Kate Monster
Apprentice
Apprentice


Joined: 13 Jun 2006
Posts: 224
Location: Clarkston, Michigan

PostPosted: Thu Apr 19, 2012 6:39 pm    Post subject: Reply with quote

OK...the plot thickens. Metacity appears to cause the same behavior. I call metacity --replace, and next thing I know I'm staring at the KDM login screen. It throws a fatal IO error, resource temporarily unavailable, but why the heck would that crash X? X doesn't appear to throw any errors, it just closes...
Edit: Dmesg does get filled with this garbage, seemingly unrelated...or is it?
Code:
metacity[6043]: segfault at 8 ip b70c78b2 sp bfc38d60 error 4 in libstartup-notification-1.so.0.0.0[b70c1000
+8000]
HDMI hot plug event: Codec=1 Pin=5 Presence_Detect=1 ELD_Valid=0
HDMI status: Codec=1 Pin=5 Presence_Detect=1 ELD_Valid=0
HDMI hot plug event: Codec=1 Pin=5 Presence_Detect=0 ELD_Valid=1
HDMI status: Codec=1 Pin=5 Presence_Detect=1 ELD_Valid=1
HDMI: detected monitor H233H
        at connection type HDMI
HDMI: available speakers: FL/FR
HDMI: supports coding type LPCM: channels = 2, rates = 32000 44100 48000, bits = 16 20 24
HDMI hot plug event: Codec=1 Pin=5 Presence_Detect=1 ELD_Valid=0
HDMI status: Codec=1 Pin=5 Presence_Detect=0 ELD_Valid=0
HDMI hot plug event: Codec=1 Pin=5 Presence_Detect=1 ELD_Valid=0
HDMI status: Codec=1 Pin=5 Presence_Detect=1 ELD_Valid=0
HDMI hot plug event: Codec=1 Pin=5 Presence_Detect=0 ELD_Valid=1
HDMI status: Codec=1 Pin=5 Presence_Detect=1 ELD_Valid=1
HDMI: detected monitor H233H
        at connection type HDMI
HDMI: available speakers: FL/FR
HDMI: supports coding type LPCM: channels = 2, rates = 32000 44100 48000, bits = 16 20 24
HDMI hot plug event: Codec=1 Pin=5 Presence_Detect=1 ELD_Valid=0
HDMI status: Codec=1 Pin=5 Presence_Detect=0 ELD_Valid=0
HDMI hot plug event: Codec=1 Pin=5 Presence_Detect=1 ELD_Valid=0
HDMI status: Codec=1 Pin=5 Presence_Detect=1 ELD_Valid=0
HDMI hot plug event: Codec=1 Pin=5 Presence_Detect=0 ELD_Valid=1
HDMI status: Codec=1 Pin=5 Presence_Detect=1 ELD_Valid=1
HDMI: detected monitor H233H
        at connection type HDMI
HDMI: available speakers: FL/FR
HDMI: supports coding type LPCM: channels = 2, rates = 32000 44100 48000, bits = 16 20 24
HDMI hot plug event: Codec=1 Pin=5 Presence_Detect=1 ELD_Valid=0
HDMI status: Codec=1 Pin=5 Presence_Detect=0 ELD_Valid=0
HDMI hot plug event: Codec=1 Pin=5 Presence_Detect=1 ELD_Valid=0
HDMI status: Codec=1 Pin=5 Presence_Detect=1 ELD_Valid=0
HDMI hot plug event: Codec=1 Pin=5 Presence_Detect=0 ELD_Valid=1
HDMI status: Codec=1 Pin=5 Presence_Detect=1 ELD_Valid=1
HDMI: detected monitor H233H
        at connection type HDMI
HDMI: available speakers: FL/FR
HDMI: supports coding type LPCM: channels = 2, rates = 32000 44100 48000, bits = 16 20 24
Back to top
View user's profile Send private message
Kate Monster
Apprentice
Apprentice


Joined: 13 Jun 2006
Posts: 224
Location: Clarkston, Michigan

PostPosted: Sat Apr 28, 2012 8:09 pm    Post subject: Reply with quote

bump.....

Nothing, guys? Thinking of jumping ship to Debian or something. As much as I love Portage, I feel like stuff like this happens to me a lot. Could it maybe have to do with the fact that this install is old? Like, 2006 old?
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1167

PostPosted: Sat Apr 28, 2012 9:23 pm    Post subject: Reply with quote

I know of ubuntu as a distribution where compiz really matters ....
_________________
fun2gen2
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2505
Location: UK

PostPosted: Sun Apr 29, 2012 2:15 am    Post subject: Reply with quote

0.8.8 works OK for me on an Intel gpu. Look in Xorg.0.log and dmesg when it crashes, maybe one of them might have useful info.
_________________
runit-init howto | Overlay
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Sun Apr 29, 2012 1:06 pm    Post subject: Reply with quote

Kate Monster

i am using compiz-0.9.5.92.1 :

mybox hedmo # emerge -av compiz compiz-fusion emerald

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R #] x11-wm/compiz-9999::desktop-effects USE="svg -gnome -gtk -kde" 0 kB
[ebuild R #] x11-wm/emerald-0.9.5::hedmo 0 kB
[ebuild R #] x11-wm/compiz-fusion-9999::hedmo USE="emerald unsupported -gnome -kde" 0 kB

Total: 3 packages (3 reinstalls), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] n

Quitting.

mybox hedmo #

and it works quite well.the only thing that i can say that does not work as it should i the skydome picture (you have to refresh it all the time when you start your DE/WM).i have a custom compiz-fusion-9999.ebuild that depends on emerald and a custom emerald-0.9.5.ebuild

regards hedmo
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1167

PostPosted: Sun Apr 29, 2012 2:29 pm    Post subject: Reply with quote

hedmo wrote:
i am using compiz-0.9.5.92.1

Actually Ubuntu has 0.9.7.8 available. There might be a fork on launchpad.net ...
_________________
fun2gen2
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Tue May 01, 2012 6:02 pm    Post subject: Reply with quote

ulenrich wrote:

Actually Ubuntu has 0.9.7.8 available. There might be a fork on launchpad.net ...



yes but compiz-plugins-main-0.9.7.2 wont compile (expo error :x )

regards hedmo
Back to top
View user's profile Send private message
Kate Monster
Apprentice
Apprentice


Joined: 13 Jun 2006
Posts: 224
Location: Clarkston, Michigan

PostPosted: Wed May 02, 2012 11:01 pm    Post subject: Reply with quote

Hey guys! Thanks for the replies!

I'm starting to think nvidia-drivers is at fault here. Like I mentioned, the issue isn't specific to compiz, and /seems/ to be related to compositing in general. Also - I was going to make a seperate post about this, but I've seen some screen glitches as of late. When I play anything with Flash, and I try switching to another desktop/tab, it keeps trying to draw itself on top of whatever I'm looking at. On another desktop, the entire object appears on the desktop, hovering there, but of course I can't click on it. Gonna try and roll back a few versions and see if anything changes.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2643
Location: Slovenia

PostPosted: Wed May 02, 2012 11:26 pm    Post subject: Reply with quote

Kate Monster wrote:
it keeps trying to draw itself on top of whatever I'm looking at. On another desktop, the entire object appears on the desktop, hovering there, but of course I can't click on it.

That's a flash bug, it sets the overlay colorkey to black, so you see flash content on anything that black, whether it's the browser or not. A simple workaround is to turn off overlay:
Code:
export VDPAU_NVIDIA_NO_OVERLAY=1

Though overlays aren't used anyway if a compositor is running.
Back to top
View user's profile Send private message
Kate Monster
Apprentice
Apprentice


Joined: 13 Jun 2006
Posts: 224
Location: Clarkston, Michigan

PostPosted: Sun May 06, 2012 4:46 am    Post subject: Reply with quote

Interesting. It's just so weird, because I've been having a couple video-related bugs outside of Flash. Today Google Maps freaked out, 'cause I was using MapsGL. Some of the text wasn't rendering properly, etc. It's just so weird that I've been having all these video-related errors and they're not caused by my nvidia driver.

Updated it today BTW, from 295.40 to 295.49.
Back to top
View user's profile Send private message
Kate Monster
Apprentice
Apprentice


Joined: 13 Jun 2006
Posts: 224
Location: Clarkston, Michigan

PostPosted: Wed May 16, 2012 8:17 pm    Post subject: Reply with quote

Haha, oh man. Thanks for the help guys, but it turns out I'm just dumb. I was running openbox under GDM(also KDM) and running compiz --replace. When *DM noticed openbox had exited, it immediately killed X. The funny thing is that though I've figured it out, I've become attached to openbox, and will probably keep using it as my WM :P
Back to top
View user's profile Send private message
snorkellingcactus
n00b
n00b


Joined: 24 Dec 2012
Posts: 1

PostPosted: Mon Dec 24, 2012 4:00 pm    Post subject: Reply with quote

Hi, i know that this post is old, but, i have the same problem and i fixed this changing the python symlink with eselect. I post this message to somebody that have the same problem.
The correct python version to set with eselect is 2.7

for example:
Code:

# eselect python list
  [1]   python2.7
  [2]   python3.2 *
  [3]   python3.3
# eselect python set 1
# eselect python list
  [1]   python2.7 *
  [2]   python3.2
  [3]   python3.3


Sorry for my english, bye!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum