Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] help with paludis concerning dev-python/setuptools
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
andi456
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2005
Posts: 123
Location: Germany

PostPosted: Fri Dec 14, 2012 7:30 pm    Post subject: [Solved] help with paludis concerning dev-python/setuptools Reply with quote

Hi everybody,

maybe somebody could tell me, what I should do being confronted with the following lines of output by paludis/cave:
Code:
cave resolve -x dev-python/setuptools
These are the actions I will take, in order:

r   dev-python/setuptools:0::gentoo 0.6.30-r1 to ::installed replacing 0.6.30-r1
    PYTHON_TARGETS: -python2_5 -python2_6 python2_7 -python3_1 python3_2 build_options: symbols=split -optional_tests -trace work=tidyup
    Reasons: target, dev-python/numpy-1.6.2:0::installed

Total: 1 reinstalls

I encountered the following errors:

!   dev-python/python-exec
    Reasons: dev-python/setuptools-0.6.30-r1:0::gentoo
    Unsuitable candidates:
      * dev-python/python-exec-0.1:0::gentoo
        Did not meet dev-python/python-exec[python_targets_python2_5?,python_targets_python2_6?,python_targets_python2_7?,python_targets_python3_1?,python_targets_python3_2?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_1(-),-python_single_target_python3_2(-)], use existing if possible, installing to / from dev-python/setuptools-0.6.30-r1:0::gentoo
            Flag 'python_single_target_python2_7' disabled, assuming disabled if missing
      * dev-python/python-exec-0.1.1:0::gentoo
        Did not meet dev-python/python-exec[python_targets_python2_5?,python_targets_python2_6?,python_targets_python2_7?,python_targets_python3_1?,python_targets_python3_2?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_1(-),-python_single_target_python3_2(-)], use existing if possible, installing to / from dev-python/setuptools-0.6.30-r1:0::gentoo
            Flag 'python_single_target_python2_7' disabled, assuming disabled if missing
      * dev-python/python-exec-0.2:0::gentoo
        Did not meet dev-python/python-exec[python_targets_python2_5?,python_targets_python2_6?,python_targets_python2_7?,python_targets_python3_1?,python_targets_python3_2?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_1(-),-python_single_target_python3_2(-)], use existing if possible, installing to / from dev-python/setuptools-0.6.30-r1:0::gentoo
            Flag 'python_single_target_python2_7' disabled, assuming disabled if missing

Obviously the error has something to do with python_single_target_python2_7. Do I need to set it somewhere? Or what else can I read from the above lines of output?

Regards Andreas


Last edited by andi456 on Sat Dec 15, 2012 1:50 pm; edited 2 times in total
Back to top
View user's profile Send private message
mikkoc
Apprentice
Apprentice


Joined: 24 May 2007
Posts: 231

PostPosted: Sat Dec 15, 2012 9:35 am    Post subject: Reply with quote

Same issue here.
No idea how to fix it.
Back to top
View user's profile Send private message
Eridane
n00b
n00b


Joined: 30 Dec 2007
Posts: 13

PostPosted: Sat Dec 15, 2012 10:09 am    Post subject: Reply with quote

Same here, =sys-apps/paludis-0.82.0.
Back to top
View user's profile Send private message
zwirbeltier
n00b
n00b


Joined: 15 Dec 2012
Posts: 1

PostPosted: Sat Dec 15, 2012 10:39 am    Post subject: Reply with quote

It seems that paludis is interpreting the use-dep "-python_single_target_python2_7(-)" not correctly. As a workaround I have commented out line 138 in eclass/python-r1.eclass
Code:


#optflags+=,${flags_st[@]/%/(-)}

Back to top
View user's profile Send private message
sera
Developer
Developer


Joined: 29 Feb 2008
Posts: 1012
Location: CET

PostPosted: Sat Dec 15, 2012 12:17 pm    Post subject: Reply with quote

I can confirm the issue.

base/make.defaults set PYTHON_SINGLE_TARGET="python2_7", that's were it comes from. Apparently Paludis doesn't intersect USE with IUSE before checking the flag on python-exec as unsetting the useflag works.

Other possible workarounds beside the mentioned one is to add
Code:
*/* PYTHON_SINGLE_TARGET: -*
to your use.conf or simply exclude setuptools from your world update, i.e
Code:
cave resolve -c -W setuptools world
and wait for a Paludis fix.
Back to top
View user's profile Send private message
andi456
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2005
Posts: 123
Location: Germany

PostPosted: Sat Dec 15, 2012 1:49 pm    Post subject: Reply with quote

@zwirbeltier and sera: Thank you for the workarounds.
Back to top
View user's profile Send private message
mgorny
Developer
Developer


Joined: 27 Apr 2007
Posts: 53

PostPosted: Sun Dec 16, 2012 9:44 pm    Post subject: Reply with quote

The relevant code is not really important for users, so I have disabled it temporarily. Therefore, you can drawback your workarounds after next sync.

I have also opened bug #447524 to track the issue. I'll appreciate any help with understanding it and getting it fixed properly.
Back to top
View user's profile Send private message
yoshi314
l33t
l33t


Joined: 30 Dec 2004
Posts: 823
Location: PL

PostPosted: Mon Dec 17, 2012 1:41 pm    Post subject: Reply with quote

sera wrote:
I can confirm the issue.

base/make.defaults set PYTHON_SINGLE_TARGET="python2_7", that's were it comes from. Apparently Paludis doesn't intersect USE with IUSE before checking the flag on python-exec as unsetting the useflag works.

Other possible workarounds beside the mentioned one is to add
Code:
*/* PYTHON_SINGLE_TARGET: -*
to your use.conf or simply exclude setuptools from your world update, i.e
Code:
cave resolve -c -W setuptools world
and wait for a Paludis fix.


i had also to add
Code:
PYTHON_SINGLE_TARGET=-* python2_7
just for systemd.
_________________
~amd64
shrink your /usr/portage with squashfs+aufs
Back to top
View user's profile Send private message
mgorny
Developer
Developer


Joined: 27 Apr 2007
Posts: 53

PostPosted: Wed Dec 19, 2012 9:17 am    Post subject: Reply with quote

Now all python-r1 packages are EAPI=5, therefore there should be no more issues with any package anymore.

Please remove your workarounds, as they may prove painful in the future.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum