Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
net.eth0 - no longer starting up at boot(not loading module)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2094

PostPosted: Mon Dec 17, 2012 8:18 pm    Post subject: net.eth0 - no longer starting up at boot(not loading module) Reply with quote

I upgraded one of my systems to the latest ~amd64, including gentoo-sources-3.7.0 and I noticed the boot process no longer loads the required module (tg3) automatically, thus net.eth0 and therefor sshd won't start. Logging in, `modprobe tg3` gives no warning and then works as expected.

I didn't make any changes regarding module loading, so is this an error in (I guess) openrc or have I missed a change?
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2409
Location: UK

PostPosted: Mon Dec 17, 2012 8:27 pm    Post subject: Reply with quote

Lots of people have been having this problem in the last few weeks (myself included), it seems to be a breakage in udev. For a workaround you can use /etc/conf.d/modules.
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2094

PostPosted: Mon Dec 17, 2012 9:18 pm    Post subject: Reply with quote

Thanks for the heads-up, I'll try that.

For what it's worth, I'm guessing openrc. I had udev masked to <=172 and it failed someday and after portage wanted to install eudev, I switched to that and it still happens(don't know which version that is based on, though).
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1493

PostPosted: Mon Dec 17, 2012 9:29 pm    Post subject: Reply with quote

Try using the kmod flag. I experienced a similar problem with eudev which whet away when I activated this flag.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum