Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PORTAGE]no puedo instalar ekopath(solucionado)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
gerezm
n00b
n00b


Joined: 12 Feb 2012
Posts: 22

PostPosted: Fri Dec 14, 2012 4:06 pm    Post subject: [PORTAGE]no puedo instalar ekopath(solucionado) Reply with quote

Hola. Tengo este problema al instalar ekopath


build.log:

http://pastebin.lugmen.org.ar/7864

emerge --info ekopath:

http://pastebin.lugmen.org.ar/7865


Last edited by gerezm on Sun Dec 16, 2012 12:33 am; edited 3 times in total
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 806

PostPosted: Fri Dec 14, 2012 7:45 pm    Post subject: Reply with quote

Hay un bug abierto sobre el tema y de momento no está solucionado:
https://bugs.gentoo.org/show_bug.cgi?id=444020

Podrías probar a instalar la versión anterior: 4.0.12.1_pre20120430
Back to top
View user's profile Send private message
gerezm
n00b
n00b


Joined: 12 Feb 2012
Posts: 22

PostPosted: Fri Dec 14, 2012 8:59 pm    Post subject: Reply with quote

Gracias @quilosaq por responder, intente con la ekopath-4.0.12.1_pre20120430 y me da el mismo error, supongo que ekopath-4.0.12.1_pre20120308 tambien lo tendra el mismo error. Esperare unos meses.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 806

PostPosted: Fri Dec 14, 2012 10:38 pm    Post subject: Reply with quote

He probado a instalarlo y no me ha dado ningún error. Creo que el problema es que tu sistema usa los paquetes "en pruebas" por tener ~amd64 en ACCEPT_KEYWORDS. En particular mi glibc es 2.14.1-r3 y la tuya 2.16.0.
Back to top
View user's profile Send private message
gerezm
n00b
n00b


Joined: 12 Feb 2012
Posts: 22

PostPosted: Fri Dec 14, 2012 11:19 pm    Post subject: Reply with quote

Es muy extraño pues en make.conf no tengo "amd64"

make.conf :

http://pastebin.lugmen.org.ar/7866
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 806

PostPosted: Fri Dec 14, 2012 11:25 pm    Post subject: Reply with quote

En la línea 9 del último pastebin tienes:
ACCEPT_KEYWORDS="~amd64"

Con eso le dices a portage que puede usar use todos los paquetes "en pruebas".
Back to top
View user's profile Send private message
gerezm
n00b
n00b


Joined: 12 Feb 2012
Posts: 22

PostPosted: Fri Dec 14, 2012 11:50 pm    Post subject: Reply with quote

Entiendo, no se si es grave pues tengo glibc unstable o a prueba, por ahora veo dos alternativas para solucionarlo

1 . eliminar "~amd64" , y hacer emerge -uDN world (quizas tenga que desinstalar muchos programas previamente)

2 . agregar en package.mask ">sys-libs/glibc-2.14.1-r3" y hacer emerge -uDN world


No se cual elegir
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 806

PostPosted: Sat Dec 15, 2012 2:45 pm    Post subject: Reply with quote

Tu opción 1 te va a dejar el sistema "estable" pero la glibc que tendrás será la 2.15-r3 que puede que también sirva aunque no es la que yo tengo. Quizá otra persona pueda confirmar esto. La opción 2 si que cumplirá el objetivo y afectará a un número menor de paquetes.

El problema no es la gran cantidad de paquetes que tendrás que desinstalar e instalar; eso es tiempo y nada más. El problema será cuando se te produzcan bloqueos entre paquetes; requieren solucionarlos manualmente uno a uno.

En cualquier caso añade las opciones -pv a emerge y lánzalo. Te dirá lo que va a hacer.

También podrías sustituir el conjunto world por system por lo que te digo de reducir los paquetes afectados.
Back to top
View user's profile Send private message
gerezm
n00b
n00b


Joined: 12 Feb 2012
Posts: 22

PostPosted: Sun Dec 16, 2012 12:31 am    Post subject: Reply with quote

Bueno elegi la 1. siguiendo estas instrucciones ( http://www.gossamer-threads.com/lists/gentoo/amd64/234332) para burlar el mecanismo de proteccion de la glibc.

No me acuerdo bien los pasos, fue bastante chapucero, desinstale programas que no usaria inmediatamente para hacer facil el downgrade. Luego revdep-rebuild por si habia rotos algunos, seguido desinstalar algunos paquetes conflictivos (equery d poppler; emerge --unmerge epdfview mupdf poppler ... ). Por ultimo hice un chequeo ldd {/bin,/usr/bin,/usr/local/bin,/usr/games/bin}/* >/dev/null por que algunos binarios daban un error al estilo [...] GLIBC_2.16.0 [...] los eliminaba o los reinstalaba. Por ultimo ultimo instalar algunos paquetes que desinstale al principio.

Y pude instalar mi ekopath :D

Saludos y gracias

PD: Y por ultimo ultimo ultimo revdep-rebuild
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum