Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Paquete(s) enmascarado al actualizar.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Amaury221
n00b
n00b


Joined: 12 Dec 2012
Posts: 3
Location: Un lugar de la mancha.

PostPosted: Thu Dec 13, 2012 6:37 am    Post subject: Paquete(s) enmascarado al actualizar. Reply with quote

Hola a todos. Siendo breve trato de actualizar con emerge y me manda el siguiente mensaje:


!!! Problem resolving dependencies for dev-python/argparse:0 from @selected
... done!

!!! The ebuild selected to satisfy "dev-python/argparse:0" has unmet requirements.
- dev-python/argparse-1.2.1-r2::gentoo USE="(multilib)" PYTHON_TARGETS="-jython2_5 -python2_5 -python2_6 -python3_1"

The following REQUIRED_USE flag constraints are unsatisfied:
any-of ( python_targets_python2_5 python_targets_python2_6 python_targets_python3_1 python_targets_jython2_5 )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Logro entender que el conflicto es con argparse pero no se en donde empezar y la verdad es que es algo frustrante por que no logro entender errores similares con otros paquetes :x :x :x :x :x
Agradezco cualquier ayuda o sugerencia. Que pasen un excelente dia.
Back to top
View user's profile Send private message
opotonil
l33t
l33t


Joined: 17 Jun 2005
Posts: 788
Location: 127.0.0.1

PostPosted: Thu Dec 13, 2012 8:49 am    Post subject: Reply with quote

Quote:

The following REQUIRED_USE flag constraints are unsatisfied:
any-of ( python_targets_python2_5 python_targets_python2_6 python_targets_python3_1 python_targets_jython2_5 )


Por lo que entiendo te esta diciendo que necesitas activar alguna de las siguientes USEs "python_targets_python2_5 python_targets_python2_6 python_targets_python3_1 python_targets_jython2_5" en el ebuild "dev-python/argparse:0".

Salu2.
_________________
Localnet
Films Localnet
Back to top
View user's profile Send private message
Amaury221
n00b
n00b


Joined: 12 Dec 2012
Posts: 3
Location: Un lugar de la mancha.

PostPosted: Thu Dec 13, 2012 9:39 am    Post subject: Reply with quote

opotonil wrote:
Quote:

The following REQUIRED_USE flag constraints are unsatisfied:
any-of ( python_targets_python2_5 python_targets_python2_6 python_targets_python3_1 python_targets_jython2_5 )


Por lo que entiendo te esta diciendo que necesitas activar alguna de las siguientes USEs "python_targets_python2_5 python_targets_python2_6 python_targets_python3_1 python_targets_jython2_5" en el ebuild "dev-python/argparse:0".

Salu2.




Estuve googleando un poco y aparentemente hay varios archivos en los que se pueden agregar los parametros USE, uno de ellos el make.conf. entonces agrego como dice ahi?

"USE=python_targets_python2_5 python_targets_python2_6 python_targets_python3_1 python_targets_jython2_5"


o mas bien tocaria como palabras clave??
Use=python jython
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3726

PostPosted: Thu Dec 13, 2012 9:47 am    Post subject: Reply with quote

mira que versiones de python tienes instaladas y en función de eso lo añades al make.conf.
P.ej., yo tengo solo instalado python-2.7.3 :

Code:
qlist -Icv dev-lang/python
dev-lang/python 2.7.3


(qlist viene con el paquete portage-utils, por si lo necesitas).

Asi que en mi make.conf tengo :

Code:
PYTHON_TARGETS="python2_7"


saluetes
Back to top
View user's profile Send private message
Amaury221
n00b
n00b


Joined: 12 Dec 2012
Posts: 3
Location: Un lugar de la mancha.

PostPosted: Thu Dec 13, 2012 4:48 pm    Post subject: Reply with quote

gringo wrote:
mira que versiones de python tienes instaladas y en función de eso lo añades al make.conf.
P.ej., yo tengo solo instalado python-2.7.3 :

Code:
qlist -Icv dev-lang/python
dev-lang/python 2.7.3


(qlist viene con el paquete portage-utils, por si lo necesitas).

Asi que en mi make.conf tengo :

Code:
PYTHON_TARGETS="python2_7"


saluetes




ok ya logre algo con eso. ahora me salen una lista de paquetes con parametros use que debo agregar y quitar.
tambien me salio que debo actualizar el archivo "/usr/portage/profiles/package.mask" el registro es el siguiente:


The following mask changes are necessary to proceed:
#required by dev-util/gdbus-codegen-2.32.4[python_targets_python3_1], required by gnome-base/nautilus-3.4.2, required by app-backup/deja-dup-25.1.1[nautilus], required by @selected, required by @world (argument)
# /etc/portage/package.mask:
# Joost Ruis: Tagged for Sabayon 6
=dev-lang/python-3.1.5-r1
#required by @selected, required by @world (argument)
# /etc/portage/package.mask:
# 2010-11-26 Fabio Erculiani: Keep networkmanager from our overlay
=net-misc/networkmanager-0.9.6.4
#required by x11-libs/xvba-video-0.8.0-r1, required by @selected, required by @world (argument)
# /etc/portage/package.mask:
# Joost Ruis: Masked because on our overlay, prevent pulling in Portage versions
=x11-drivers/ati-drivers-12.11_beta8


Estuve hojeando el archivo package.mask y la pregunta es si debo cambiar algo en los nombres de los paquetes que ahi aparecen o bien usar el --autounmask-keep-masked (algo asi iba) para que me deje seguir.

PD. Muchas gracias compañeros de Gentoo, poco a poco va tomando forma y lo bueno es que ya no es tan frustrante como en un comienzo jajaja.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3726

PostPosted: Fri Dec 14, 2012 11:57 am    Post subject: Reply with quote

por lo que veo estás usando sabayon asi que te sugiero que te dirijas a sus foros para solucionar tus dudas.

saluetes
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum