Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mysql fails to start: errcode 2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
elmar283
Apprentice
Apprentice


Joined: 06 Dec 2004
Posts: 173
Location: Netherlands

PostPosted: Wed Dec 12, 2012 4:01 pm    Post subject: Mysql fails to start: errcode 2 Reply with quote

Mysql failes to start. I don't know why. This is the error on /var/log/mysql/mysqld.err
Code:


121212 16:41:47 [Warning] No argument was provided to --log-bin, and --log-bin-index was not used; so replication may break when this MySQL server acts as a master and has his hostname changed!! Please use '--log-bin=mysqld-bin' to avoid this problem.
121212 16:41:47  InnoDB: Initializing buffer pool, size = 16.0M
121212 16:41:47  InnoDB: Completed initialization of buffer pool
121212 16:41:49  InnoDB: Started; log sequence number 0 141187
/usr/sbin/mysqld: File '' not found (Errcode: 2)
121212 16:41:49 [ERROR] Failed to open log (file '', errno 2)
121212 16:41:49 [ERROR] Could not open log file
121212 16:41:49 [ERROR] Can't init tc log
121212 16:41:49 [ERROR] Aborting

121212 16:41:49  InnoDB: Starting shutdown...
121212 16:41:54  InnoDB: Shutdown completed; log sequence number 0 141187
121212 16:41:54 [Note] /usr/sbin/mysqld: Shutdown complete


I have no idea where to start to find the problem. It does say something about log file ''.
Does anyone know what this might be?

Some config files:
Code:

elmarotter@masterserver / $ cat /etc/mysql/my.cnf
# /etc/mysql/my.cnf: The global mysql configuration file.
# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/files/my.cnf-5.1,v 1.3 2012/02/15 02:07:21 jmbsvicetto Exp $

# The following options will be passed to all MySQL clients
[client]
#password               = your_password
port                  = 3306
socket                  = /var/run/mysqld/mysqld.sock

[mysql]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[mysqladmin]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[mysqlcheck]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[mysqldump]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[mysqlimport]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[mysqlshow]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=utf8

[myisamchk]
character-sets-dir=/usr/share/mysql/charsets

[myisampack]
character-sets-dir=/usr/share/mysql/charsets

# use [safe_mysqld] with mysql-3
[mysqld_safe]
err-log                  = /var/log/mysql/mysql.err

# add a section [mysqld-4.1] or [mysqld-5.0] for specific configurations
[mysqld]
character-set-server      = utf8
user                   = mysql
port                   = 3306
socket                   = /var/run/mysqld/mysqld.sock
pid-file                = /var/run/mysqld/mysqld.pid
log-error                = /var/log/mysql/mysqld.err
basedir                = /usr
datadir                = /var/lib/mysql
skip-external-locking
key_buffer                = 16M
max_allowed_packet          = 1M
table_open_cache          = 64
sort_buffer_size          = 512K
net_buffer_length          = 8K
read_buffer_size          = 256K
read_rnd_buffer_size       = 512K
myisam_sort_buffer_size    = 8M
language                = /usr/share/mysql/english
expire_logs_days = 7

# security:
# using "localhost" in connects uses sockets by default
skip-networking
bind-address            = 127.0.0.1

log-bin
server-id                = 1

# point the following paths to different dedicated disks
tmpdir                   = /tmp/
#log-update             = /path-to-dedicated-directory/hostname

# you need the debug USE flag enabled to use the following directives,
# if needed, uncomment them, start the server and issue
# #tail -f /tmp/mysqld.sql /tmp/mysqld.trace
# this will show you *exactly* what's happening in your server ;)

#log                  = /tmp/mysqld.sql
#gdb
#debug                  = d:t:i:o,/tmp/mysqld.trace
#one-thread

# uncomment the following directives if you are using BDB tables
#bdb_cache_size            = 4M
#bdb_max_lock            = 10000

# the following is the InnoDB configuration
# if you wish to disable innodb instead
# uncomment just the next line
#skip-innodb
#
# the rest of the innodb config follows:
# don't eat too much memory, we're trying to be safe on 64Mb boxes
# you might want to bump this up a bit on boxes with more RAM
innodb_buffer_pool_size = 16M
# this is the default, increase it if you have lots of tables
innodb_additional_mem_pool_size = 2M
#
# i'd like to use /var/lib/mysql/innodb, but that is seen as a database :-(
# and upstream wants things to be under /var/lib/mysql/, so that's the route
# we have to take for the moment
#innodb_data_home_dir      = /var/lib/mysql/
#innodb_log_arch_dir      = /var/lib/mysql/
#innodb_log_group_home_dir   = /var/lib/mysql/
# you may wish to change this size to be more suitable for your system
# the max is there to avoid run-away growth on your machine
innodb_data_file_path = ibdata1:10M:autoextend:max:128M
# we keep this at around 25% of of innodb_buffer_pool_size
# sensible values range from 1MB to (1/innodb_log_files_in_group*innodb_buffer_pool_size)
innodb_log_file_size = 5M
# this is the default, increase it if you have very large transactions going on
innodb_log_buffer_size = 8M
# this is the default and won't hurt you
# you shouldn't need to tweak it
innodb_log_files_in_group=2
# see the innodb config docs, the other options are not always safe
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50
innodb_file_per_table

[mysqldump]
quick
max_allowed_packet          = 16M

[mysql]
# uncomment the next directive if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer                = 20M
sort_buffer_size          = 20M
read_buffer             = 2M
write_buffer             = 2M

[myisamchk]
key_buffer                = 20M
sort_buffer_size          = 20M
read_buffer             = 2M
write_buffer             = 2M

[mysqlhotcopy]
interactive-timeout

set-variable=local-infile=0


Code:
[ebuild   R    ] dev-db/mysql-5.1.66  USE="berkdb community latin1 perl ssl -big-tables -cluster -debug -embedded -extraengine -max-idx-128 -minimal -pbxt -profiling (-selinux) -static {-test} -xtradb" 26,045 kB
Back to top
View user's profile Send private message
elmar283
Apprentice
Apprentice


Joined: 06 Dec 2004
Posts: 173
Location: Netherlands

PostPosted: Thu Dec 13, 2012 3:02 pm    Post subject: Reply with quote

I didn't solve the problem, but was able to start mysql by uncommending the line 'skip-innodb' on '/etc/mysql/my.cnf'.
So it is something with the innodb. I don't know wether or not I need this database type.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum