Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
getting net-tools back
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
mreff555
Apprentice
Apprentice


Joined: 10 Mar 2011
Posts: 207
Location: Philadelphia

PostPosted: Sat Dec 08, 2012 8:41 pm    Post subject: getting net-tools back Reply with quote

So, I did something really dumb last night. I'm not really quite sure how to fix it. I was trying to update all my packages and was having a few conflicts.
one of them was an issue with net-tools and openrc being installed at the same time.
At some point I managed to install them both and there was no noticeable problem, but gentoo didn't seem to like it.

Anyway, I'm not sure what I was thinking, but I thought net-tools was a different package.

To make a long story short I unmerged net-tools. Now I have a couple of problems.

1. no internet connection and no tools that I know of to reestablish one.
2. emerge won't let me reinstall it because of the conflict.
3. Even if everything was back to where it was last night, this still prevents me from upgrading. Is there a combination of software that will work together?

BTW, I can't pastebin because I have no internet connection, but

openrc has baselayout as a dependency
net-tools has wicd as a dependency.


Thanks
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4122
Location: Houston, Republic of Texas

PostPosted: Sat Dec 08, 2012 8:54 pm    Post subject: Reply with quote

As for getting things merged without internet

Code:

emerge -pfv <package>


go to a machine with internet access, grab the files in the URLs above, copy to thumb drive, dump into /usr/portage/distfiles on the broken machine

as for versions that play well together, what was the precise emerge command you run, and is it possible to transcribe at least some of the details of the block?

usually you'll get something like
"net-tools blocked by <openrc-0.9.5
openrc-0.9.6 blocked by <net-tools-0.0.2"

(i made those versions up, but you get the idea)

such a blocker generally means, both must be upgraded at once, e.g. "emerge -av openrc net-tools baselayout wicd"

generally, because well, sans details one can only speak in general terms.
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash


Last edited by cach0rr0 on Sat Dec 08, 2012 8:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 9167

PostPosted: Sat Dec 08, 2012 8:55 pm    Post subject: Reply with quote

You probably still have the source for all the packages locally, so you could try overriding the dependency analyzer to force both to be installed. This is likely to be bad long term, but should let you configure your interfaces and fix the situation properly. If you do not have the sources locally, you can fetch them through a working machine and copy them to $DISTDIR by hand, using a USB stick, external drive, etc.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32439
Location: 56N 3W

PostPosted: Sat Dec 08, 2012 8:59 pm    Post subject: Reply with quote

mreff555,


net-tools-1.60_p20120127084908.ebuild says
Code:
SLOT="0"
IUSE="nls old-output static"

RDEPEND="!<sys-apps/openrc-0.9.9.3"
DEPEND="${RDEPEND}
        app-arch/xz-utils"


There is no dependency on wicd. Maybe the other way round. I don't have wicd installed anyway.

For a get you going, go with Hus advice.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
mreff555
Apprentice
Apprentice


Joined: 10 Mar 2011
Posts: 207
Location: Philadelphia

PostPosted: Sat Dec 08, 2012 9:41 pm    Post subject: Reply with quote

yes Hu's advice sounds reasonable, what is the syntax to override the dependancy analyzer
I can't find it in the man files
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32439
Location: 56N 3W

PostPosted: Sat Dec 08, 2012 9:53 pm    Post subject: Reply with quote

mreff555,

Its in emerge --help
--no-deps, from memory.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
mreff555
Apprentice
Apprentice


Joined: 10 Mar 2011
Posts: 207
Location: Philadelphia

PostPosted: Sat Dec 08, 2012 10:16 pm    Post subject: Reply with quote

Fixed

I tried emerging net-tools and openrc at the same time and the dependancy manager didn't seem to have any problems except that the files weren't there.
I grabbed them from a repository and put them in my /usr/portage/distfiles. emerged and problem solved.
Back to top
View user's profile Send private message
rzaleski81
n00b
n00b


Joined: 05 Jul 2004
Posts: 12

PostPosted: Thu Dec 20, 2012 5:40 pm    Post subject: Upgrade issue Reply with quote

I ran into this same problem doing

Code:
emerge -atv -u system


Smells like a bug. This got those two upgraded though. Thanks.
Back to top
View user's profile Send private message
_______0
Guru
Guru


Joined: 15 Oct 2012
Posts: 521

PostPosted: Sat Dec 22, 2012 9:06 am    Post subject: Reply with quote

I can confirm the net-tools blocking when upgrading to:

Code:
sys-apps/openrc-0.11.8


My guess why for some ppl didn't happen it's because emerge world auto-resolves the blockings, while updating individual packages don't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum