Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge version conflicts with xz-utils and udev
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
snova
n00b
n00b


Joined: 08 Dec 2012
Posts: 5

PostPosted: Sat Dec 08, 2012 6:52 pm    Post subject: emerge version conflicts with xz-utils and udev Reply with quote

Hello,
I have problems to merge some package.

Code:
jini ~ # emerge -p xfce-base/thunar xfce-extra/thunar-archive-plugin xfce-extra/thunar-shares-plugin

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] app-arch/xz-utils-5.0.4-r1 [5.0.4]
[ebuild  N     ] sys-apps/gptfdisk-0.8.4
[ebuild  N     ] dev-util/xfce4-dev-tools-4.10.0
[ebuild     U ~] sys-apps/hwids-20121208.5 [20121119] USE="udev%*"
[ebuild     U ~] dev-lang/spidermonkey-1.8.5-r3 [1.8.5-r1] USE="-minimal%"
[ebuild  N     ] dev-libs/libcdio-0.83  USE="cddb cxx -minimal -static-libs"
[ebuild  N     ] dev-util/gdbus-codegen-2.32.4  PYTHON_TARGETS="python2_7 python3_2 -python2_5 -python2_6 -python3_1"
[ebuild  N     ] sys-block/eject-2.1.5-r2  USE="nls"
[ebuild  N     ] virtual/eject-0
[ebuild  N    ~] sys-apps/kmod-12  USE="lzma tools zlib -debug -doc -static-libs"
[ebuild  N     ] dev-libs/libatasmart-0.19  USE="-static-libs"
[ebuild  N     ] sys-fs/cryptsetup-1.4.3  USE="nls (-selinux) -static -static-libs"
[ebuild  N     ] sys-block/parted-3.1  USE="debug nls readline -device-mapper (-selinux) -static-libs {-test}"
[ebuild  N     ] net-libs/libproxy-0.4.10-r1  USE="mono perl python -gnome -kde -networkmanager -spidermonkey {-test} -webkit"
[ebuild  N     ] net-libs/glib-networking-2.32.3  USE="libproxy ssl -gnome -smartcard {-test}"
[ebuild  N     ] net-libs/libsoup-2.38.1  USE="introspection samba ssl -debug {-test}"
[ebuild     U ~] sys-auth/polkit-0.108 [0.107-r1]
[ebuild  N     ] net-wireless/bluez-4.99  USE="alsa caps consolekit cups readline usb -debug -gstreamer -pcmcia (-selinux) -test-programs"
[ebuild  N     ] dev-libs/openobex-1.5  USE="bluetooth syslog usb -debug -irda"
[ebuild  N     ] app-mobilephone/obex-data-server-0.4.5  USE="gtk imagemagick usb -debug"
[ebuild  N     ] gnome-base/gnome-keyring-2.32.1-r1  USE="pam -debug -doc {-test}"
[ebuild  N     ] gnome-base/libgnome-keyring-2.32.0  USE="-debug -doc {-test}"
[ebuild  N     ] net-libs/libsoup-gnome-2.38.1  USE="introspection -debug"
[ebuild     U ~] sys-fs/udev-196-r1 [171-r9] USE="acl%* kmod%* openrc%* -doc% -static-libs%"
[ebuild  N    ~] sys-fs/udev-init-scripts-17-r1
[ebuild     U ~] virtual/udev-196 [171]
[ebuild  N    ~] sys-fs/udisks-2.0.0  USE="crypt gptfdisk introspection -debug -systemd"
[ebuild  N    ~] gnome-base/gvfs-1.12.3-r1  USE="bluetooth cdda http ios samba udev udisks -afp -archive -avahi -bluray -doc -fuse -gdu -gnome-keyring -gphoto2"
[ebuild  N     ] xfce-base/thunar-1.4.0  USE="dbus exif libnotify pcre startup-notification udev -debug {-test}" XFCE_PLUGINS="trash"
[ebuild  N     ] xfce-extra/thunar-archive-plugin-0.3.0  USE="-debug"
[ebuild  N     ] xfce-extra/thunar-shares-plugin-0.2.0_p20101105  USE="-debug"
[blocks B      ] <sys-fs/udev-186 ("<sys-fs/udev-186" is blocking sys-fs/udev-init-scripts-17-r1)
[blocks B      ] sys-apps/kmod ("sys-apps/kmod" is blocking sys-apps/module-init-tools-3.16-r2)
[blocks B      ] sys-apps/module-init-tools ("sys-apps/module-init-tools" is blocking sys-apps/kmod-12)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

virtual/udev:0

  (virtual/udev-171::gentoo, installed) pulled in by
    =virtual/udev-171 required by (sys-fs/cryptsetup-1.4.3::gentoo, ebuild scheduled for merge)
    (and 12 more with the same problem)

  (virtual/udev-196::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/udev-180 required by (sys-fs/udev-196-r1::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

sys-fs/udev:0

  (sys-fs/udev-196-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-196-r1[acl?,gudev?,hwdb?,introspection?,keymap?,selinux?,static-libs?] required by (virtual/udev-196::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (sys-fs/udev-171-r9::gentoo, installed) pulled in by
    ~sys-fs/udev-171[gudev?,hwdb?,introspection?,keymap?,selinux?] required by (virtual/udev-171::gentoo, installed)
    <sys-fs/udev-185 required by (net-wireless/bluez-4.99::gentoo, ebuild scheduled for merge)

app-arch/xz-utils:0

  (app-arch/xz-utils-5.0.4-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=app-arch/xz-utils-5.0.4-r1 required by (sys-apps/kmod-12::gentoo, ebuild scheduled for merge)

  (app-arch/xz-utils-5.0.4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

jini ~ #


I am searching since some hours on the web for a solution.
Hope some can help.


Last edited by snova on Sat Dec 08, 2012 8:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32302
Location: 56N 3W

PostPosted: Sat Dec 08, 2012 8:41 pm    Post subject: Reply with quote

snova,

Code:
[blocks B ] <sys-fs/udev-186 ("<sys-fs/udev-186" is blocking sys-fs/udev-init-scripts-17-r1)
is solved by updating udev.
Code:
[blocks B ] sys-apps/kmod ("sys-apps/kmod" is blocking sys-apps/module-init-tools-3.16-r2)
[blocks B ] sys-apps/module-init-tools ("sys-apps/module-init-tools" is blocking sys-apps/kmod-12)

is solved by removing sys-apps/module-init-tools and installing sys-apps/kmod.

WARNING:when module-init-tools has been removed and kmod is not yet installed, you will have no way of loading kernel modules, so don't reboot in the middle of that.

As you have a mostly stable system with a few testing packages, it may not be as easy as I make out. You may have to update other things to testing for this to work.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
snova
n00b
n00b


Joined: 08 Dec 2012
Posts: 5

PostPosted: Sun Dec 09, 2012 12:06 am    Post subject: Reply with quote

many thanks NeddySeagoon.
I have removed "sys-apps/module-init-tools" and installed "sys-apps/kmod" without any problems.
I have updated the udev with "emerge virtual/udev" and get version "196-r1".

But if I emerge the thunar package I get my old problem whit udev again ...

Code:

(chroot) livecd ~ # emerge -p xfce-base/thunar xfce-extra/thunar-archive-plugin xfce-extra/thunar-shares-plugin

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD ] sys-fs/udev-171-r9 [196-r1] USE="rule_generator%* -action_modeswitch% -build% -debug% -edd% (-extras) -floppy% {-test%}"
[ebuild  N     ] sys-fs/cryptsetup-1.4.3  USE="nls (-selinux) -static -static-libs"
[ebuild     U ~] sys-auth/polkit-0.108 [0.107-r1]
[ebuild  N    ~] sys-fs/udisks-2.0.0  USE="crypt gptfdisk introspection -debug -systemd"
[ebuild  N     ] net-wireless/bluez-4.99  USE="alsa caps consolekit cups readline usb -debug -gstreamer -pcmcia (-selinux) -test-programs"
[ebuild  N     ] dev-libs/openobex-1.5  USE="bluetooth syslog usb -debug -irda"
[ebuild  N     ] app-mobilephone/obex-data-server-0.4.5  USE="gtk imagemagick usb -debug"
[ebuild  N     ] gnome-base/gnome-keyring-2.32.1-r1  USE="pam -debug -doc {-test}"
[ebuild  N     ] gnome-base/libgnome-keyring-2.32.0  USE="-debug -doc {-test}"
[ebuild  N     ] net-libs/libsoup-gnome-2.38.1  USE="introspection -debug"
[ebuild  N    ~] gnome-base/gvfs-1.12.3-r1  USE="bluetooth cdda http ios samba udev udisks -afp -archive -avahi -bluray -doc -fuse -gdu -gnome-keyring -gphoto2"
[ebuild  N     ] xfce-base/thunar-1.4.0  USE="dbus exif libnotify pcre startup-notification udev -debug {-test}" XFCE_PLUGINS="trash"
[ebuild  N     ] xfce-extra/thunar-archive-plugin-0.3.0  USE="-debug"
[ebuild  N     ] xfce-extra/thunar-shares-plugin-0.2.0_p20101105  USE="-debug"
[blocks B      ] <sys-fs/udev-186 ("<sys-fs/udev-186" is blocking sys-fs/udev-init-scripts-17-r1)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-fs/udev:0

  (sys-fs/udev-196-r1::gentoo, installed) pulled in by
    >=sys-fs/udev-196-r1[acl?,gudev?,hwdb?,introspection?,keymap?,selinux?,static-libs?] required by (virtual/udev-196::gentoo, installed)
    (and 1 more with the same problem)

  (sys-fs/udev-171-r9::gentoo, ebuild scheduled for merge) pulled in by
    <sys-fs/udev-185 required by (net-wireless/bluez-4.99::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

(chroot) livecd ~ #
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32302
Location: 56N 3W

PostPosted: Sun Dec 09, 2012 12:21 am    Post subject: Reply with quote

snova,

Code:
(sys-fs/udev-171-r9::gentoo, ebuild scheduled for merge) pulled in by
    <sys-fs/udev-185 required by (net-wireless/bluez-4.99::gentoo, ebuild scheduled for merge)


udev is being downgraded to satisfy the version dependency in bluez.
Code:
/usr/portage/net-wireless/bluez $ ls
ChangeLog  bluez-4.101-r3.ebuild  bluez-4.98-r2.ebuild  files
Manifest   bluez-4.101-r4.ebuild  bluez-4.99.ebuild     metadata.xml

Maybe a later bluez works with later udev ?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
snova
n00b
n00b


Joined: 08 Dec 2012
Posts: 5

PostPosted: Sun Dec 09, 2012 9:48 am    Post subject: Reply with quote

I have edit my USE-Flag in make.conf and replace the "bluetooth" with "-bluetooth". So this problem isn't any more one.
But to update the udev to 191-r1 was a very bad idea. Since now many emerge commands bring up a problem with udev and my lvm-system doesn't work correctly. Every lvm command bring up failure like
Code:

jini ~ # vgdisplay
vgdisplay: error while loading shared libraries: libudev.so.0: cannot open shared object file: No such file or directory
jini ~ #

A recompile of lvm2 will bring the failure with the udev.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32302
Location: 56N 3W

PostPosted: Sun Dec 09, 2012 1:33 pm    Post subject: Reply with quote

snova,

I use all ~arch with raid5 and lvm2 and it works for me. Unfortunately, my raid has just started on 3 out of 4 drives so I'm on SystemRescueCD while it rebuilds.
My initrd thought the raid was not clean, so it refused to run it in degraded mode.
I'll post more info of my setup in about 5 hours, once I can boot normally.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1391
Location: germany

PostPosted: Sun Dec 09, 2012 5:34 pm    Post subject: Reply with quote

snova wrote:
I have edit my USE-Flag in make.conf and replace the "bluetooth" with "-bluetooth". So this problem isn't any more one.
But to update the udev to 191-r1 was a very bad idea. Since now many emerge commands bring up a problem with udev and my lvm-system doesn't work correctly. Every lvm command bring up failure like
Code:

jini ~ # vgdisplay
vgdisplay: error while loading shared libraries: libudev.so.0: cannot open shared object file: No such file or directory
jini ~ #

A recompile of lvm2 will bring the failure with the udev.


This should be solved by running
Code:
revdep-rebuild

If not you probably need to update sys-fs/lvm2 to a more recent version.
_________________
The manual said "Requires Windows7 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)
Back to top
View user's profile Send private message
snova
n00b
n00b


Joined: 08 Dec 2012
Posts: 5

PostPosted: Sun Dec 09, 2012 6:12 pm    Post subject: Reply with quote

Only more errors on emerge...

Code:
jini ~ # revdep-rebuild
 * Configuring search environment for revdep-rebuild
/usr/bin/revdep-rebuild: Zeile 553: /dev/fd/62: Datei oder Verzeichnis nicht gefunden

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
 *   broken /bin/lsblk (requires libudev.so.0)
[ 2% ]  *   broken /lib/libdevmapper.so.1.02 (requires libudev.so.0)
 *   broken /lib/liblvm2app.so.2.2 (requires libudev.so.0)
 *   broken /lib/liblvm2cmd.so.2.02 (requires libudev.so.0)
[ 5% ]  *   broken /sbin/dmsetup (requires libudev.so.0)
 *   broken /sbin/lvm (requires libudev.so.0)
[ 7% ]  *   broken /usr/bin/Xorg (requires libudev.so.0)
[ 9% ]  *   broken /usr/bin/canberra-boot (requires libudev.so.0)
[ 44% ]  *   broken /usr/lib/egl/egl_gallium.so (requires libudev.so.0)
 *   broken /usr/lib/firefox/components/libbrowsercomps.so (requires libmozalloc.so
libxpcom.so)
 *   broken /usr/lib/firefox/components/libdbusservice.so (requires libmozalloc.so
libxpcom.so)
 *   broken /usr/lib/firefox/components/libmozgnome.so (requires libmozalloc.so
libxpcom.so)
 *   broken /usr/lib/firefox/libxpcom.so (requires libxul.so)
 *   broken /usr/lib/firefox/libxul.so (requires libmozalloc.so
libmozsqlite3.so)
 *   broken /usr/lib/firefox/plugin-container (requires libmozalloc.so
libxul.so)
[ 55% ]  *   broken /usr/lib/libatasmart.so.4.0.5 (requires libudev.so.1)
[ 73% ]  *   broken /usr/lib/opengl/xorg-x11/lib/libEGL.so.1.0.0 (requires libudev.so.0)
[ 78% ]  *   broken /usr/lib/pulse-1.1/modules/libalsa-util.so (requires libudev.so.0)
 *   broken /usr/lib/pulse-1.1/modules/module-alsa-card.so (requires libudev.so.0)
 *   broken /usr/lib/pulse-1.1/modules/module-alsa-sink.so (requires libudev.so.0)
 *   broken /usr/lib/pulse-1.1/modules/module-alsa-source.so (requires libudev.so.0)
[ 79% ]  *   broken /usr/lib/pulse-1.1/modules/module-udev-detect.so (requires libudev.so.0)
[ 87% ]  *   broken /usr/lib/thunderbird/components/libdbusservice.so (requires libmozalloc.so
libxpcom.so)
 *   broken /usr/lib/thunderbird/components/libmozgnome.so (requires libmozalloc.so
libxpcom.so)
 *   broken /usr/lib/thunderbird/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/platform/Linux_x86-gcc3/components/libenigmime-x86-gcc3.so (requires libmozalloc.so
libxpcom.so)
 *   broken /usr/lib/thunderbird/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/platform/Linux_x86-gcc3/components/libipc-x86-gcc3.so (requires libmozalloc.so
libxpcom.so)
 *   broken /usr/lib/thunderbird/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/libcalbasecomps.so (requires libmozalloc.so
libxpcom.so
libxul.so)
 *   broken /usr/lib/thunderbird/libxpcom.so (requires libxul.so)
 *   broken /usr/lib/thunderbird/libxul.so (requires libldap60.so
libmozalloc.so
libmozsqlite3.so
libprldap60.so)
 *   broken /usr/lib/thunderbird/plugin-container (requires libmozalloc.so
libxul.so)
[ 91% ]  *   broken /usr/lib/vlc/plugins/services_discovery/libudev_plugin.so (requires libudev.so.0)
[ 94% ]  *   broken /usr/lib/xorg/modules/drivers/intel_drv.so (requires libudev.so.0)
 *   broken /usr/lib/xorg/modules/drivers/nouveau_drv.so (requires libudev.so.0)
 *   broken /usr/lib/xorg/modules/drivers/radeon_drv.so (requires libudev.so.0)
[ 95% ]  *   broken /usr/lib/xorg/modules/input/evdev_drv.so (requires libudev.so.0)
[ 97% ]  *   broken /usr/libexec/pulse/proximity-helper (requires libbluetooth.so.3)
 *   broken /usr/libexec/udev-acl (requires libudev.so.0)
 *   broken /usr/libexec/upowerd (requires libgudev-1.0.so.0)
[ 100% ]                 
/usr/bin/revdep-rebuild: Zeile 716: /dev/fd/62: Datei oder Verzeichnis nicht gefunden
 * Generated new 3_broken.rr
 * Assigning files to packages
 *   /bin/lsblk -> sys-apps/util-linux
 *   /lib/libdevmapper.so.1.02 -> sys-fs/lvm2
 *   /lib/liblvm2app.so.2.2 -> sys-fs/lvm2
 *   /lib/liblvm2cmd.so.2.02 -> sys-fs/lvm2
 *   /sbin/dmsetup -> sys-fs/lvm2
 *   /sbin/lvm -> sys-fs/lvm2
 *   /usr/bin/Xorg -> x11-base/xorg-server
 *   /usr/bin/canberra-boot -> media-libs/libcanberra
 *   /usr/lib/egl/egl_gallium.so -> media-libs/mesa
 *   /usr/lib/firefox/components/libbrowsercomps.so -> www-client/firefox
 *   /usr/lib/firefox/components/libdbusservice.so -> www-client/firefox
 *   /usr/lib/firefox/components/libmozgnome.so -> www-client/firefox
 *   /usr/lib/firefox/libxpcom.so -> www-client/firefox
 *   /usr/lib/firefox/libxul.so -> www-client/firefox
 *   /usr/lib/firefox/plugin-container -> www-client/firefox
 *   /usr/lib/libatasmart.so.4.0.5 -> dev-libs/libatasmart
 *   /usr/lib/opengl/xorg-x11/lib/libEGL.so.1.0.0 -> media-libs/mesa
 *   /usr/lib/pulse-1.1/modules/libalsa-util.so -> media-sound/pulseaudio
 *   /usr/lib/pulse-1.1/modules/module-alsa-card.so -> media-sound/pulseaudio
 *   /usr/lib/pulse-1.1/modules/module-alsa-sink.so -> media-sound/pulseaudio
 *   /usr/lib/pulse-1.1/modules/module-alsa-source.so -> media-sound/pulseaudio
 *   /usr/lib/pulse-1.1/modules/module-udev-detect.so -> media-sound/pulseaudio
 *   /usr/lib/thunderbird/components/libdbusservice.so -> mail-client/thunderbird
 *   /usr/lib/thunderbird/components/libmozgnome.so -> mail-client/thunderbird
 *   /usr/lib/thunderbird/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/platform/Linux_x86-gcc3/components/libenigmime-x86-gcc3.so -> mail-client/thunderbird
 *   /usr/lib/thunderbird/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/platform/Linux_x86-gcc3/components/libipc-x86-gcc3.so -> mail-client/thunderbird
 *   /usr/lib/thunderbird/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/libcalbasecomps.so -> mail-client/thunderbird
 *   /usr/lib/thunderbird/libxpcom.so -> mail-client/thunderbird
 *   /usr/lib/thunderbird/libxul.so -> mail-client/thunderbird
 *   /usr/lib/thunderbird/plugin-container -> mail-client/thunderbird
 *   /usr/lib/vlc/plugins/services_discovery/libudev_plugin.so -> media-video/vlc
 *   /usr/lib/xorg/modules/drivers/intel_drv.so -> x11-drivers/xf86-video-intel
 *   /usr/lib/xorg/modules/drivers/nouveau_drv.so -> x11-drivers/xf86-video-nouveau
 *   /usr/lib/xorg/modules/drivers/radeon_drv.so -> x11-drivers/xf86-video-ati
 *   /usr/lib/xorg/modules/input/evdev_drv.so -> x11-drivers/xf86-input-evdev
 *   /usr/libexec/pulse/proximity-helper -> media-sound/pulseaudio
 *   /usr/libexec/udev-acl -> sys-auth/consolekit
 *   /usr/libexec/upowerd -> sys-power/upower
 * Generated new 4_raw.rr and 4_owners.rr
 * Cleaning list of packages to rebuild
 * Generated new 4_pkgs.rr
 * Assigning packages to ebuilds
 * Generated new 4_ebuilds.rr
 * Evaluating package order
 * Generated new 5_order.rr
 * All prepared. Starting rebuild
emerge --complete-graph=y --oneshot   dev-libs/libatasmart:0 mail-client/thunderbird:0 media-libs/libcanberra:0 media-libs/mesa:0 media-sound/pulseaudio:0 media-video/vlc:0 sys-apps/util-linux:0 sys-auth/consolekit:0 sys-fs/lvm2:0 sys-power/upower:0 www-client/firefox:0 x11-base/xorg-server:0 x11-drivers/xf86-input-evdev:0 x11-drivers/xf86-video-ati:0 x11-drivers/xf86-video-intel:0 x11-drivers/xf86-video-nouveau:0
..........
Calculating dependencies... done!
[ebuild  N     ] media-libs/webrtc-audio-processing-0.1  USE="-static-libs"
[ebuild   R    ] media-libs/mesa-9.0
[ebuild   R    ] www-client/firefox-10.0.11
[ebuild   R    ] mail-client/thunderbird-10.0.11
[ebuild   R    ] sys-apps/util-linux-2.21.2
[ebuild  N    ~] sys-fs/udev-196-r1  USE="acl gudev hwdb kmod openrc -doc -introspection -keymap (-selinux) -static-libs"
[ebuild   R    ] sys-auth/consolekit-0.4.5_p20120320-r1
[ebuild   R    ] x11-base/xorg-server-1.13.0-r1
[ebuild   R    ] dev-libs/libatasmart-0.19
[ebuild   R    ] sys-fs/lvm2-2.02.88
[ebuild   R    ] sys-power/upower-0.9.18
[ebuild   R    ] x11-drivers/xf86-input-evdev-2.7.3
[ebuild   R    ] x11-drivers/xf86-video-ati-7.0.0
[ebuild   R    ] x11-drivers/xf86-video-intel-2.20.13
[ebuild   R    ] x11-drivers/xf86-video-nouveau-1.0.4
[ebuild     U  ] media-sound/pulseaudio-2.1-r1 [1.1-r1] USE="gtk%* webrtc-aec%* -bluetooth* (-systemd) -xen%"
[ebuild  N     ] media-plugins/alsa-plugins-1.0.25-r1  USE="ffmpeg jack pulseaudio speex -debug -libsamplerate"
[ebuild   R    ] media-libs/libcanberra-0.29
[ebuild   R    ] media-video/vlc-2.0.3
[blocks B      ] <sys-kernel/genkernel-3.4.25 ("<sys-kernel/genkernel-3.4.25" is blocking sys-fs/udev-196-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-196-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-160 required by (media-libs/libcanberra-0.29::gentoo, ebuild scheduled for merge)
    >=sys-fs/udev-142 required by (media-video/vlc-2.0.3::gentoo, ebuild scheduled for merge)
    >=sys-fs/udev-187 required by (sys-fs/udev-init-scripts-17-r1::gentoo, installed)
    >=sys-fs/udev-196-r1[acl,gudev,hwdb] required by (virtual/udev-196::gentoo, installed)

  (sys-kernel/genkernel-3.4.24_p2::gentoo, installed) pulled in by
    sys-kernel/genkernel required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

 * revdep-rebuild failed to emerge all packages.
 * you have the following choices:
 * - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
 * - Use /etc/portage/package.keywords to unmask a newer version of the package.
 *   (and remove 5_order.rr to be evaluated again)
 * - Modify the above emerge command and run it manually.
 * - Compile or unmerge unsatisfied packages manually,
 *   remove temporary files, and try again.
 *   (you can edit package/ebuild list first)
 * To remove temporary files, please run:
 * rm /var/cache/revdep-rebuild/*.rr
jini ~ # emerge lvm2
Calculating dependencies... done!
[ebuild   R    ] sys-fs/lvm2-2.02.88
[ebuild  N    ~] sys-fs/udev-196-r1  USE="acl gudev hwdb kmod openrc -doc -introspection -keymap (-selinux) -static-libs"
[blocks B      ] <sys-kernel/genkernel-3.4.25 ("<sys-kernel/genkernel-3.4.25" is blocking sys-fs/udev-196-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-196-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-196-r1[acl,gudev,hwdb] required by (virtual/udev-196::gentoo, installed)

  (sys-kernel/genkernel-3.4.24_p2::gentoo, installed) pulled in by
    sys-kernel/genkernel required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

jini ~ #
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5652

PostPosted: Sun Dec 09, 2012 10:23 pm    Post subject: Reply with quote

This output just says you need to keyword a more recent genkernel.
Back to top
View user's profile Send private message
snova
n00b
n00b


Joined: 08 Dec 2012
Posts: 5

PostPosted: Sun Dec 16, 2012 6:17 pm    Post subject: Reply with quote

VoidMage wrote:
This output just says you need to keyword a more recent genkernel.


OK, I have add it to
Code:
jini ~ # cat /etc/portage/package.accept_keywords
=sys-fs/udev-196-r1 ~x86
>sys-kernel/genkernel-3.4.24_p2 ~x86
jini ~ #


After that I could emerge genkernel to the version 3.4.45
But if I use the revdep-rebuild I get the same problem again...

Code:
jini ~ # revdep-rebuild
 * Configuring search environment for revdep-rebuild
/usr/bin/revdep-rebuild: Zeile 553: /dev/fd/62: Datei oder Verzeichnis nicht gefunden

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Found existing 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Found existing 2_ldpath.rr.
 * Checking dynamic linking consistency
 * Found existing 3_broken.rr.
 * Assigning files to packages
 * Found existing 4_raw.rr
 * Cleaning list of packages to rebuild
 * Found existing 4_pkgs.rr
 * Assigning packages to ebuilds
 * Found existing 4_ebuilds.rr
 * Evaluating package order
 * Found existing 5_order.rr
 * Generated new 5_order.rr
 * All prepared. Starting rebuild
emerge --complete-graph=y --oneshot   dev-libs/libatasmart:0 mail-client/thunderbird:0 media-libs/libcanberra:0 media-libs/mesa:0 media-sound/pulseaudio:0 media-video/vlc:0 sys-apps/util-linux:0 sys-auth/consolekit:0 sys-fs/lvm2:0 sys-power/upower:0 www-client/firefox:0 x11-base/xorg-server:0 x11-drivers/xf86-input-evdev:0 x11-drivers/xf86-video-ati:0 x11-drivers/xf86-video-intel:0 x11-drivers/xf86-video-nouveau:0
..........
Calculating dependencies... done!
[ebuild  N     ] media-libs/webrtc-audio-processing-0.1  USE="-static-libs"
[ebuild   R    ] media-libs/mesa-9.0
[ebuild   R    ] www-client/firefox-10.0.11
[ebuild   R    ] mail-client/thunderbird-10.0.11
[ebuild   R    ] sys-apps/util-linux-2.21.2
[ebuild  N     ] sys-fs/eudev-0  USE="gudev hwdb rule_generator -action_modeswitch -build -debug -edd -extras -floppy -introspection -keymap (-selinux) {-test}"
[ebuild     UD ] virtual/udev-171 [196]
[ebuild   R    ] sys-fs/lvm2-2.02.88
[ebuild  N    ~] sys-fs/udev-196-r1  USE="acl gudev hwdb kmod openrc -doc -introspection -keymap (-selinux) -static-libs"
[ebuild   R    ] sys-auth/consolekit-0.4.5_p20120320-r1
[ebuild   R    ] x11-base/xorg-server-1.13.0-r1
[ebuild   R    ] dev-libs/libatasmart-0.19
[ebuild   R    ] sys-power/upower-0.9.18
[ebuild   R    ] x11-drivers/xf86-input-evdev-2.7.3
[ebuild   R    ] x11-drivers/xf86-video-ati-7.0.0
[ebuild   R    ] x11-drivers/xf86-video-intel-2.20.13
[ebuild   R    ] x11-drivers/xf86-video-nouveau-1.0.4
[ebuild     U  ] media-sound/pulseaudio-2.1-r1 [1.1-r1] USE="gtk%* webrtc-aec%* -bluetooth* (-systemd) -xen%"
[ebuild  N     ] media-plugins/alsa-plugins-1.0.25-r1  USE="ffmpeg jack pulseaudio speex -debug -libsamplerate"
[ebuild   R    ] media-libs/libcanberra-0.29
[ebuild   R    ] media-video/vlc-2.0.3
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-fs/eudev-0)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

virtual/udev:0

  (virtual/udev-171::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/udev-171 required by (sys-fs/eudev-0::gentoo, ebuild scheduled for merge)
    <virtual/udev-196 required by (sys-fs/lvm2-2.02.88::gentoo, ebuild scheduled for merge)

  (virtual/udev-196::gentoo, installed) pulled in by
    >=virtual/udev-180 required by (sys-fs/udev-196-r1::gentoo, ebuild scheduled for merge)
    =virtual/udev-196 required by (dev-libs/libatasmart-0.19::gentoo, ebuild scheduled for merge)
    (and 11 more with the same problems)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

 * revdep-rebuild failed to emerge all packages.
 * you have the following choices:
 * - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
 * - Use /etc/portage/package.keywords to unmask a newer version of the package.
 *   (and remove 5_order.rr to be evaluated again)
 * - Modify the above emerge command and run it manually.
 * - Compile or unmerge unsatisfied packages manually,
 *   remove temporary files, and try again.
 *   (you can edit package/ebuild list first)
 * To remove temporary files, please run:
 * rm /var/cache/revdep-rebuild/*.rr
jini ~ #
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum