Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wine no compila con opencl activado{solucionado}
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 388
Location: Sota algun pi de l'empordà

PostPosted: Sat Dec 08, 2012 10:57 am    Post subject: wine no compila con opencl activado{solucionado} Reply with quote

Quote:
The specific snippet of code:
* [[ x$(eselect opencl show) = "xintel" ]] && die "Cannot build wine[opencl,win32]: intel-ocl-sdk is 64-bit only";


¿ es un problema o limitación temporal?


saludos, ad1
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits


Last edited by papu on Thu Dec 13, 2012 1:48 am; edited 2 times in total
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 825

PostPosted: Sat Dec 08, 2012 8:17 pm    Post subject: Reply with quote

No es temporal ni está en manos de Gentoo el cambiarlo. En linux hay que tener una distribución de 64 bits para poder utilizarlo.
El fabricante del software (Intel) dice:
Quote:
Supported Operating Systems

Intel® SDK for OpenCL* Applications 2012 supports the following operating systems:

Microsoft Windows 7* (32-bit version)
Microsoft Windows 7* (64-bit version)
Microsoft Windows 7* Service Pack 1 (32-bit version)
Microsoft Windows 7* Service Pack 1 (64-bit version)
Microsoft Windows Vista* Service Pack 2 (32-bit version)
Microsoft Windows Vista* Service Pack 2 (64-bit version)
Microsoft Windows Server 2008 R2
Novell* SUSE* Linux Enterprise Server 11 Service Pack 1 (64-bit version)
Red Hat* Enterprise Linux 6.1 (64-bit version)

http://software.intel.com/en-us/articles/opencl-release-notes/#2
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 388
Location: Sota algun pi de l'empordà

PostPosted: Sat Dec 08, 2012 11:41 pm    Post subject: Reply with quote

quilosaq wrote:
No es temporal ni está en manos de Gentoo el cambiarlo. En linux hay que tener una distribución de 64 bits para poder utilizarlo.
El fabricante del software (Intel) dice:
Quote:
Supported Operating Systems

Intel® SDK for OpenCL* Applications 2012 supports the following operating systems:

Microsoft Windows 7* (32-bit version)
Microsoft Windows 7* (64-bit version)
Microsoft Windows 7* Service Pack 1 (32-bit version)
Microsoft Windows 7* Service Pack 1 (64-bit version)
Microsoft Windows Vista* Service Pack 2 (32-bit version)
Microsoft Windows Vista* Service Pack 2 (64-bit version)
Microsoft Windows Server 2008 R2
Novell* SUSE* Linux Enterprise Server 11 Service Pack 1 (64-bit version)
Red Hat* Enterprise Linux 6.1 (64-bit version)

http://software.intel.com/en-us/articles/opencl-release-notes/#2


si precisamente yo uso gentoo64, lo que el wine pide la version 32bits del opencl de intel , y bueno tampoco detecta el opencl de mi grafica ati.


en fin da igual, era curiosidad
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits
Back to top
View user's profile Send private message
cohone
Tux's lil' helper
Tux's lil' helper


Joined: 27 Mar 2006
Posts: 113

PostPosted: Mon Dec 10, 2012 11:16 am    Post subject: Reply with quote

papu wrote:
quilosaq wrote:
No es temporal ni está en manos de Gentoo el cambiarlo. En linux hay que tener una distribución de 64 bits para poder utilizarlo.
El fabricante del software (Intel) dice:
Quote:
Supported Operating Systems

Intel® SDK for OpenCL* Applications 2012 supports the following operating systems:

Microsoft Windows 7* (32-bit version)
Microsoft Windows 7* (64-bit version)
Microsoft Windows 7* Service Pack 1 (32-bit version)
Microsoft Windows 7* Service Pack 1 (64-bit version)
Microsoft Windows Vista* Service Pack 2 (32-bit version)
Microsoft Windows Vista* Service Pack 2 (64-bit version)
Microsoft Windows Server 2008 R2
Novell* SUSE* Linux Enterprise Server 11 Service Pack 1 (64-bit version)
Red Hat* Enterprise Linux 6.1 (64-bit version)

http://software.intel.com/en-us/articles/opencl-release-notes/#2


si precisamente yo uso gentoo64, lo que el wine pide la version 32bits del opencl de intel , y bueno tampoco detecta el opencl de mi grafica ati.


en fin da igual, era curiosidad


Supongo que tienes configuradas dos tarjetas, una intel y una ati, y que es la intel la que tienes configurada con eselect opencl (por eso no te detectará el de la ati)

y por el error, parece indicar que no puedes compilarlo con las dos use a la vez, la win32 y la opencl, así que o pruebas con eselect opencl set amd o quitas la use win32, con lo que no podrías ejecutar aplicaciones de 32bits en wine, supongo....

yo la última vez que probé a compilar wine con la use opencl y una ati, wine me tiraba errores al ejecutar aplicaciones.
Y ahora, por probar lo he compilado, y compilar copila sin errores. No puedo probarlo porque estoy en remoto.

Un Saludo
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 388
Location: Sota algun pi de l'empordà

PostPosted: Mon Dec 10, 2012 1:35 pm    Post subject: Reply with quote

editado:

he vuelto poner el driver oficial de ati despues de practicamente 2 años y curiosamente me ha funcionado a la primera, a falta de hacer prubas de rendimiento que supongo, logicamente tendrá mejor soporte opengl que el libre, o eso espero, y a parte de tener varias limitaciones como el kms tener que volver a usar el xorg.conf..., me ha aparecido finalmente el opencl de ati y he podido compilar el wine con esa opción, ya que amd si ofrece soporte 32 i 64 bits.
http://i.minus.com/iI9gxGJPNcIyL.png

Quote:
Ordinador linux # eselect opencl list
Available OpenCL implementations:
[1] amd *
[2] intel


Asi que arreglada la cosa era una cuestión de soporte y drivers graficos, los problemas de siempre y cronicos que matan al linux.

Es un autentico hito que pueda usar a la primera estos drivers oficiales antes era una verdadera tortura, antes siempre daba por culo con que no se podía instalar porque siempre pedia una version xorg muy inferior a la actual... a ver si es verdad y al final van sacando algo "potable" :)

saludos, ad1
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum