Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
coreutils-8.20 failed [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
symon1980
n00b
n00b


Joined: 11 Jul 2010
Posts: 17

PostPosted: Sat Dec 08, 2012 6:54 am    Post subject: coreutils-8.20 failed [SOLVED] Reply with quote

help2man: can't get '--help' info from man/arch.td/arch
make[2]: *** [man/arch.1] Error 127
make[2]: *** Waiting for unfinished jobs....
help2man: can't get '--help' info from man/uname.td/uname
make[2]: *** [man/uname.1] Error 127
make[2]: Leaving directory `/var/tmp/portage/sys-apps/coreutils-8.20/work/coreutils-8.20'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/sys-apps/coreutils-8.20/work/coreutils-8.20'
make: *** [all] Error 2
emake failed
* ERROR: sys-apps/coreutils-8.20 failed (compile phase):
* emake failed
*
* Call stack:
* ebuild.sh, line 93: Called src_compile
* environment, line 2394: Called __eapi2_src_compile
* phase-helpers.sh, line 612: Called die
* The specific snippet of code:
* emake || die "emake failed"




After performing an emerge --update --ask world

Any ideas?


Last edited by symon1980 on Sat Dec 08, 2012 6:11 pm; edited 3 times in total
Back to top
View user's profile Send private message
Pilsner
Tux's lil' helper
Tux's lil' helper


Joined: 14 Mar 2008
Posts: 83

PostPosted: Sat Dec 08, 2012 7:58 am    Post subject: Reply with quote

Same error here:
Code:
Linux gent 3.5.7-gentoo #1 Mon Oct 22 11:33:30 MSK 2012 x86_64 Intel(R) Core(TM) i5 CPU M 540 @ 2.53GHz GenuineIntel GNU/Linux
Back to top
View user's profile Send private message
mhanft
n00b
n00b


Joined: 31 Oct 2011
Posts: 9
Location: Nürnberg

PostPosted: Sat Dec 08, 2012 8:45 am    Post subject: Reply with quote

Same error here on both of my Gentoo computers:
Code:
Linux n 3.5.7-gentoo #1 SMP Sun Nov 4 17:16:04 CET 2012 i686 Intel(R) Xeon(R) CPU X5690 @ 3.47GHz GenuineIntel GNU/Linux
Linux fileserver 3.5.7-gentoo #2 SMP PREEMPT Sun Nov 4 17:40:42 CET 2012 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz GenuineIntel GNU/Linux
Back to top
View user's profile Send private message
Pilsner
Tux's lil' helper
Tux's lil' helper


Joined: 14 Mar 2008
Posts: 83

PostPosted: Sat Dec 08, 2012 8:55 am    Post subject: Reply with quote

Found in bugzilla https://bugs.gentoo.org/show_bug.cgi?id=446438, compiles ok with MAKEOPTS="-j1".
Back to top
View user's profile Send private message
Rhywek
n00b
n00b


Joined: 02 Jan 2005
Posts: 40

PostPosted: Sat Dec 08, 2012 11:03 am    Post subject: Reply with quote

Wouldn't it be a good idea if some ebuilds would themselves know that they need MAKEOPTS="-j1"?

I'm running into this issue often with various packages - they compile only with MAKEOPTS="-j1". Therefore I just have it in my make.conf, which is far from ideal, because other packages that can use MAKEOPTS="-j9" compile much slower than they could. I know I could only set MAKEOPTS="-j1" sometimes when something goes wrong, but I don't have time for getting compile problems, researching them, and fixing them manually.

Just like ebuilds can filter compile flags, couldn't they also filter make flags?
Back to top
View user's profile Send private message
mhanft
n00b
n00b


Joined: 31 Oct 2011
Posts: 9
Location: Nürnberg

PostPosted: Sat Dec 08, 2012 11:12 am    Post subject: Reply with quote

Just for the records: "-j1" does work on both my Gentoo computers. Didn't know that this seems to be a common workaround...

Thank you for the "-j1" pointer :D
Back to top
View user's profile Send private message
symon1980
n00b
n00b


Joined: 11 Jul 2010
Posts: 17

PostPosted: Sat Dec 08, 2012 1:32 pm    Post subject: Reply with quote

arrghhhh

I don't want to have to configure my settings to "-j1"

any other workarounds?
Back to top
View user's profile Send private message
vokiel
n00b
n00b


Joined: 01 Oct 2004
Posts: 37

PostPosted: Sat Dec 08, 2012 3:58 pm    Post subject: Reply with quote

symon1980 wrote:
arrghhhh

I don't want to have to configure my settings to "-j1"

any other workarounds?


You don't have to just do:

Code:

MAKEOPTS="-j1" emerge sys-apps/coreutils


on the command line
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8904

PostPosted: Sat Dec 08, 2012 5:25 pm    Post subject: Reply with quote

Rhywek wrote:
Wouldn't it be a good idea if some ebuilds would themselves know that they need MAKEOPTS="-j1"?
Yes, but it is a better idea if someone fixes the build system to work properly without requiring -j1. Many ebuilds already do force non-parallel builds. Search for emake -j1 (correct way to disable parallel) or \<make\> (wrong way to disable parallel) in the tree.
Back to top
View user's profile Send private message
symon1980
n00b
n00b


Joined: 11 Jul 2010
Posts: 17

PostPosted: Sat Dec 08, 2012 5:55 pm    Post subject: Reply with quote

vokiel wrote:
symon1980 wrote:
arrghhhh

I don't want to have to configure my settings to "-j1"

any other workarounds?


You don't have to just do:

Code:

MAKEOPTS="-j1" emerge sys-apps/coreutils


on the command line




I thought arghhh screw it... i'll try your suggestion "MAKEOPTS="-j1" emerge sys-apps/coreutils"
then started a world update and all seems ok "so far"
I'm up for a hell of an update with Kde 4.8.4 though... this may take a few hours.... i'm going to bed. LoL

will post back
Back to top
View user's profile Send private message
Robol
n00b
n00b


Joined: 10 Aug 2012
Posts: 1

PostPosted: Sat Dec 08, 2012 5:58 pm    Post subject: Reply with quote

vokiel wrote:

You don't have to just do:
Code:

MAKEOPTS="-j1" emerge sys-apps/coreutils



Thank you. It works :)
Back to top
View user's profile Send private message
Usermind42
n00b
n00b


Joined: 05 Dec 2012
Posts: 19

PostPosted: Sat Dec 08, 2012 11:44 pm    Post subject: Reply with quote

Thank you Pilsner.
_________________
Make ur own free penguin baby with Gentoo(DEBLOB!) =]
cflags accuracy =]
accept_keywords='x86'
accept_license='-* @FREE'
Back to top
View user's profile Send private message
symon1980
n00b
n00b


Joined: 11 Jul 2010
Posts: 17

PostPosted: Sun Dec 09, 2012 12:34 am    Post subject: Reply with quote

Yep that did the trick.... Thanx.

I only wonder if this will cause any future stability/speed issues....
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4241

PostPosted: Sun Dec 09, 2012 12:40 am    Post subject: Reply with quote

Read the bug report, you'll see it was little trick for man pages, i'm quiet sure no instabilities will comes from dropping a manpages patch that wasn't working :)
Back to top
View user's profile Send private message
To
Veteran
Veteran


Joined: 12 Apr 2003
Posts: 1145
Location: Coimbra, Portugal

PostPosted: Sun Dec 09, 2012 8:36 am    Post subject: Reply with quote

There's nothing similar to package.use for this?
_________________

------------------------------------------------
Linux Gandalf 3.2.35-grsec
Gentoo Base System version 2.2
------------------------------------------------
Back to top
View user's profile Send private message
motosauro
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2005
Posts: 83
Location: Verona, Italy

PostPosted: Sun Dec 09, 2012 8:43 am    Post subject: Reply with quote

Same problem and same solution here
thx

Edit: bugzilla's last entry says that it's been fixed in the portage tree, I didn't check though
_________________
Per aspera ad astra
Back to top
View user's profile Send private message
BobWya
n00b
n00b


Joined: 12 Aug 2012
Posts: 38
Location: Cambridge,UK

PostPosted: Mon Dec 10, 2012 8:23 pm    Post subject: Reply with quote

Hi all,

Thanks for the handy work around!! Very timely!!

Having been put on to potential benefits of LTO (from an on-line blog) and how to switch off LTO for specific packages that don't support link time optimisation - when using gcc 4.7.x...

It's much easier to create a file:
Code:
/etc/portage/env/make-j1.conf

Code:
MAKEOPTS="-j1"


Then you can specify packages that require single threaded making in the standard portage environment file:
Code:
/etc/portage/package.env

Code:
sys-apps/coreutils make-j1.conf


From the portage man page:
Code:
...
                    package.env
                     Per-package environment variable settings. Entries refer to environment files that are placed in the /etc/portage/env/ directory and have the same format as
                     make.conf(5).

                     Format:
                     - comment lines begin with # (no inline comments)
                     - one DEPEND atom per line followed by name(s) of environment file(s)

                     Example:
                     # use environment variables from /etc/portage/env/glibc.conf for the glibc package
                     sys-libs/glibc glibc.conf
...


Anyone know what other packages need single threaded making? I've got some packages that are reverted to no-LTO - but could this be due to needing single-threading??

Thanks
Bob
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum