Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] soundcard missing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Tue Jan 01, 2013 6:22 pm    Post subject: [solved] soundcard missing Reply with quote

Hi,
I have a 3.7.1 Kernel with

Code:
CONFIG_SND_HDA_INTEL=m
CONFIG_SND_HDA_PREALLOC_SIZE=64
CONFIG_SND_HDA_HWDEP=y
CONFIG_SND_HDA_RECONFIG=y
# CONFIG_SND_HDA_INPUT_BEEP is not set
CONFIG_SND_HDA_INPUT_JACK=y
CONFIG_SND_HDA_PATCH_LOADER=y
CONFIG_SND_HDA_CODEC_REALTEK=y
CONFIG_SND_HDA_CODEC_ANALOG=y
CONFIG_SND_HDA_CODEC_SIGMATEL=y
CONFIG_SND_HDA_CODEC_VIA=y
CONFIG_SND_HDA_CODEC_HDMI=y
CONFIG_SND_HDA_CODEC_CIRRUS=y
CONFIG_SND_HDA_CODEC_CONEXANT=y
CONFIG_SND_HDA_CODEC_CA0110=y
CONFIG_SND_HDA_CODEC_CA0132=y
CONFIG_SND_HDA_CODEC_CMEDIA=y
CONFIG_SND_HDA_CODEC_SI3054=y
CONFIG_SND_HDA_GENERIC=y
CONFIG_SND_HDA_POWER_SAVE_DEFAULT=0
CONFIG_SENSORS_HDAPS=m


Code:
dmesg | grep hda
[    2.965117] snd_hda_intel: Unknown symbol vga_switcheroo_get_client_state (err 0)
[    2.965405] snd_hda_intel: Unknown symbol vga_switcheroo_unregister_client (err 0)
[    2.965428] snd_hda_intel: Unknown symbol vga_switcheroo_register_audio_client (err 0)
[    3.266375] snd_hda_intel: Unknown symbol vga_switcheroo_get_client_state (err 0)
[    3.266744] snd_hda_intel: Unknown symbol vga_switcheroo_unregister_client (err 0)
[    3.266770] snd_hda_intel: Unknown symbol vga_switcheroo_register_audio_client (err 0)
[    3.285607] snd_hda_intel: Unknown symbol vga_switcheroo_get_client_state (err 0)
[    3.285723] snd_hda_intel: Unknown symbol vga_switcheroo_unregister_client (err 0)
[    3.285731] snd_hda_intel: Unknown symbol vga_switcheroo_register_audio_client (err 0)


Booted in a currently updated install does not show the onboard sound (and the hdmi) in alsamixer or Gnome 3.4

Booted in an old install, sound is there. I'm really lost, I have no idea what's going on...

EDIT: I forgot:
Code:
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA)


Rüdiger


Last edited by Wallsandfences on Tue Jan 01, 2013 9:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31844
Location: 56N 3W

PostPosted: Tue Jan 01, 2013 6:43 pm    Post subject: Reply with quote

Wallsandfences,

Code:
2.965117] snd_hda_intel: Unknown symbol vga_switcheroo_get_client_state (err 0)
says that your kernel is missing an option.
From the name, its something to do with video card switching.

That further suggests that the kernel, or the snd_hda_intel module were compiled at different times with different .config files.

I suggest that you leave the kernel settings as they are and rebuild the kernel commencing with
Code:
make clean
so there are no left over .o files for make to reuse.
This can be finger trouble on your part but the kernel build system isn't perfect either.
Reinstall the kernel, its modules and reboot. This will get you a self consistent set of parts for the kernel. We can move on from there.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Tue Jan 01, 2013 9:31 pm    Post subject: Reply with quote

Hi,
I rebuild the kernel as suggested and the audio drivers are back again! Great!

And now for something not so very different...

(see next http://forums.gentoo.org/viewtopic-t-946616.html)

Rüdiger
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum