Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]openvpn startup problem via /etc/init.d/openvpn.foo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
yee
n00b
n00b


Joined: 16 Sep 2004
Posts: 31

PostPosted: Wed Dec 05, 2012 2:28 am    Post subject: [SOLVED]openvpn startup problem via /etc/init.d/openvpn.foo Reply with quote

I have a working configuration file /etc/openvpn/foo.conf

If I start the vpn with openvpn foo.conf (from the /etc/openvpn directory), the vpn starts up and the routing table is set correctly. All is well.

I also have /etc/init.d/openvpn.foo which is a sym-link to /etc/init.d/openvpn

If I try to start the service /etc/init.d/openvpn.foo start, the vpn does NOT start. It would appear that the routing table is set correctly but the vpn connection itself never starts. The error message is

WARNING: openvpn.foo has started, but is inactive

What am I doing wrong? Unfortunately, the documentation for this is rather sparse.

Thanks.
Conway Yee

Solution:
The error message is spurious! When starting up via "openvpn foo.conf", the script take a bit of time to complete.

Starting via /etc/init.d/openvpn.foo is almost instantaneous. If an attempt is made to access the vpn immediately, it fails. If a bit of time is given to complete the connection, the vpn works as advertised.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum