Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to upgrade kde 4.8.5 to 4.9.3 dependency hell
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
cmprior
n00b
n00b


Joined: 03 Sep 2011
Posts: 15

PostPosted: Fri Dec 07, 2012 9:45 pm    Post subject: Unable to upgrade kde 4.8.5 to 4.9.3 dependency hell Reply with quote

I am trying to emerge --update --deep world and have several failures.

These are the packages that would be merged, in order:

Calculating dependencies .... done!
[ebuild U ] net-misc/dhcpcd-5.6.4 [5.6.2]
[ebuild U ] sys-apps/net-tools-1.60_p20120127084908 [1.60_p20110409135728] USE="-old-output%"
[ebuild U ~] app-emulation/emul-linux-x86-baselibs-20121202 [20121028]
[ebuild U ~] app-emulation/emul-linux-x86-db-20121202 [20121028]
[ebuild U ] kde-base/kde-env-4.9.3 [4.8.5]
[ebuild U ] net-fs/nfs-utils-1.2.6 [1.2.3-r1] USE="-nfsdcld% -nfsidmap% -nfsv41% (-selinux)"
[ebuild U ] sys-apps/coreutils-8.20 [8.16]
[ebuild U ] kde-base/oxygen-icons-4.9.3 [4.8.5]
[ebuild U ~] app-emulation/emul-linux-x86-xlibs-20121202 [20121028]
[ebuild U ~] app-emulation/emul-linux-x86-opengl-20121202-r1 [20121028]
[ebuild U ~] app-emulation/emul-linux-x86-medialibs-20121202 [20121028]
[ebuild U ~] app-emulation/emul-linux-x86-soundlibs-20121202 [20121028]
[ebuild U ~] app-emulation/emul-linux-x86-qtlibs-20121202 [20121028] USE="-gtkstyle%"
[ebuild U ~] net-im/skype-4.1.0.20 [4.0.0.8-r1] USE="(-selinux)"
[ebuild U ~] net-print/cups-bjnp-1.1 [1.0]
[ebuild U ~] www-client/firefox-bin-17.0 [16.0.2]
[ebuild U ] dev-libs/soprano-2.8.0 [2.7.6]
[ebuild U ] app-office/scribus-1.4.1-r1 [1.4.0-r2]
[ebuild U ] app-office/akonadi-server-1.8.1 [1.8.0]
[ebuild U ~] app-admin/webmin-1.610 [1.590]
[ebuild U ] sys-apps/man-pages-3.43 [3.42]
[ebuild U ] sys-fs/udev-171-r9 [171-r8] USE="introspection*"
[ebuild N ] virtual/udev-171 USE="acl gudev hwdb introspection keymap (-selinux) -static-libs"
[ebuild U ~] www-client/google-chrome-23.0.1271.95_p169798 [23.0.1271.64_p165188]
[ebuild U ] kde-base/kdelibs-4.9.3 [4.8.5] USE="(-udisks2)"
[ebuild U ] kde-base/katepart-4.9.3 [4.8.5]
[ebuild U ] kde-base/kfmclient-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdesu-4.9.3 [4.8.5]
[ebuild U ] kde-base/khelpcenter-4.9.3 [4.8.5]
[ebuild U ] kde-base/libkdegames-4.9.3 [4.8.5-r1] USE="-openal%"
[ebuild U ] kde-base/kdepimlibs-4.9.3 [4.8.5]
[ebuild U ] kde-base/libkworkspace-4.9.3 [4.8.5]
[ebuild U ] kde-base/libkonq-4.9.3 [4.8.5]
[ebuild U ] kde-base/libkdeedu-4.9.3 [4.8.5]
[ebuild U ] kde-base/kephal-4.9.3 [4.8.5]
[ebuild U ] kde-base/knotify-4.9.3 [4.8.5]
[ebuild U ] kde-base/kactivities-4.9.3 [4.8.5]
[ebuild U ] kde-base/kcheckpass-4.9.3 [4.8.5]
[ebuild U ] kde-base/ksysguard-4.9.3 [4.8.5]
[ebuild U ] kde-base/libkexiv2-4.9.3 [4.8.5]
[ebuild U ] kde-base/kde-l10n-4.9.3 [4.8.5] LINGUAS="-hi%"
[ebuild U ] kde-base/libkcompactdisc-4.9.3 [4.8.5]
[ebuild U ] kde-base/khotkeys-4.9.3 [4.8.5]
[ebuild U ] kde-base/kde-wallpapers-4.9.3 [4.8.5]
[ebuild U ] kde-base/kfind-4.9.3 [4.8.5]
[ebuild U ] kde-base/libplasmagenericshell-4.9.3 [4.8.5]
[ebuild U ] kde-base/libtaskmanager-4.9.3 [4.8.5]
[ebuild U ] kde-base/liboxygenstyle-4.9.3 [4.8.5]
[ebuild U ] kde-base/kwin-4.9.3 [4.8.5]
[ebuild U ] kde-base/ksplash-4.9.3 [4.8.5-r1]
[ebuild U ] kde-base/kscreensaver-4.9.3 [4.8.5]
[ebuild U ] kde-base/kcminit-4.9.3 [4.8.5]
[ebuild U ] kde-base/kcmshell-4.9.3 [4.8.5]
[ebuild U ] kde-base/libkipi-4.9.3 [4.8.5]
[ebuild U ] kde-base/libkmahjongg-4.9.3 [4.8.5]
[ebuild U ] kde-base/phonon-kde-4.9.3 [4.8.5]
[ebuild U ] kde-base/kstartupconfig-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdepasswd-4.9.3 [4.8.5]
[ebuild U ] kde-base/dolphin-4.9.3 [4.8.5]
[ebuild U ] kde-base/plasma-apps-4.9.3 [4.8.5]
[ebuild U ] kde-base/keditbookmarks-4.9.3 [4.8.5]
[ebuild U ] kde-base/libplasmaclock-4.9.3 [4.8.5]
[ebuild U ] kde-base/systemsettings-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdialog-4.9.3 [4.8.5]
[ebuild U ] kde-base/svgpart-4.9.3 [4.8.5]
[ebuild U ] kde-base/konqueror-4.9.3-r1 [4.8.5]
[ebuild U ] kde-base/solid-runtime-4.9.3 [4.8.5]
[ebuild U ] kde-base/solid-4.9.3 [4.8.5]
[ebuild U ] kde-base/ksmserver-4.9.3 [4.8.5]
[ebuild U ] kde-base/krunner-4.9.3 [4.8.5]
[ebuild U ] kde-base/kwallet-4.9.3 [4.8.5]
[ebuild U ] kde-base/ktimezoned-4.9.3 [4.8.5]
[ebuild U ] kde-base/plasma-runtime-4.9.3 [4.8.5]
[ebuild U ] kde-base/plasma-workspace-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdnssd-4.9.3 [4.8.5]
[ebuild U ] kde-base/analitza-4.9.3 [4.8.5]
[ebuild U ] kde-base/pykde4-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdeartwork-wallpapers-4.9.3 [4.8.5]
[ebuild U ] kde-base/libkdcraw-4.9.3 [4.8.5]
[ebuild U ] kde-base/okular-4.9.3 [4.8.5-r2]
[ebuild U ] kde-base/kate-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdeplasma-addons-4.9.3 [4.8.5] USE="-json% -oauth%"
[ebuild U ] kde-base/mplayerthumbs-4.9.3 [4.8.5]
[ebuild U ] kde-base/juk-4.9.3 [4.8.5]
[ebuild U ] kde-base/kmix-4.9.3 [4.8.5] USE="-canberra%"
[ebuild U ] kde-base/kstyles-4.9.3 [4.8.5]
[ebuild U ] kde-base/kinfocenter-4.9.3 [4.8.5]
[ebuild U ] kde-base/freespacenotifier-4.9.3 [4.8.5]
[ebuild U ] kde-base/powerdevil-4.9.3 [4.8.5]
[ebuild U ] kde-base/ksystraycmd-4.9.3 [4.8.5]
[ebuild U ] kde-base/klipper-4.9.3 [4.8.5]
[ebuild N ] kde-base/kde-base-artwork-4.9.3 USE="(-aqua)"
[ebuild U ] kde-base/kwrite-4.9.3 [4.8.5]
[ebuild U ] kde-base/qguiplatformplugin_kde-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdebase-cursors-4.9.3 [4.8.5]
[ebuild U ] kde-base/nsplugins-4.9.3 [4.8.5]
[ebuild U ] kde-base/konsole-4.9.3 [4.8.5] USE="{-test%}"
[ebuild U ] kde-base/kwrited-4.9.3 [4.8.5]
[ebuild U ] kde-base/kmenuedit-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdm-4.9.3 [4.8.5]
[ebuild U ] kde-base/konq-plugins-4.9.3 [4.8.5]
[ebuild U ] kde-base/kreadconfig-4.9.3 [4.8.5]
[ebuild U ] kde-base/kuiserver-4.9.3 [4.8.5]
[ebuild U ] kde-base/kfile-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdebase-menu-4.9.3 [4.8.5]
[ebuild U ] kde-base/ktraderclient-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdebugdialog-4.9.3 [4.8.5]
[ebuild U ] kde-base/drkonqi-4.9.3 [4.8.5]
[ebuild U ] kde-base/renamedlg-plugins-4.9.3 [4.8.5]
[ebuild U ] kde-base/kioclient-4.9.3 [4.8.5]
[ebuild U ] kde-base/kiconfinder-4.9.3 [4.8.5]
[ebuild U ] kde-base/keditfiletype-4.9.3 [4.8.5]
[ebuild U ] kde-base/attica-4.9.3 [4.8.5]
[ebuild U ] kde-base/knetattach-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdontchangethehostname-4.9.3 [4.8.5]
[ebuild U ] kde-base/kpasswdserver-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdebase-menu-icons-4.9.3 [4.8.5]
[ebuild U ] kde-base/kwalletd-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdebase-kioslaves-4.9.3 [4.8.5]
[ebuild U ] kde-base/kglobalaccel-4.9.3 [4.8.5]
[ebuild U ] kde-base/knewstuff-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdebase-data-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdebase-desktoptheme-4.9.3 [4.8.5]
[ebuild U ] kde-base/kcontrol-4.9.3 [4.8.5]
[ebuild U ] kde-base/kquitapp-4.9.3 [4.8.5]
[ebuild U ] kde-base/kmimetypefinder-4.9.3 [4.8.5]
[ebuild U ] kde-base/kurifilter-plugins-4.9.3 [4.8.5]
[ebuild U ] kde-base/kstart-4.9.3 [4.8.5]
[ebuild U ] kde-base/kbruch-4.9.3 [4.8.5]
[ebuild U ] kde-base/kwordquiz-4.9.3 [4.8.5]
[ebuild U ] kde-base/kalgebra-4.9.3 [4.8.5]
[ebuild U ] kde-base/khangman-4.9.3 [4.8.5]
[ebuild N ] kde-base/pairs-4.9.3 USE="(-aqua) -debug"
[ebuild U ] kde-base/kstars-4.9.3 [4.8.5]
[ebuild U ] kde-base/ktouch-4.9.3 [4.8.5]
[ebuild U ] kde-base/parley-4.9.3 [4.8.5]
[ebuild U ] kde-base/kalzium-4.9.3 [4.8.5]
[ebuild U ] kde-base/kmplot-4.9.3 [4.8.5]
[ebuild U ] kde-base/kgeography-4.9.3 [4.8.5]
[ebuild U ] kde-base/kig-4.9.3 [4.8.5] USE="-scripting%"
[ebuild U ] kde-base/marble-4.9.3 [4.8.5] USE="-shapefile%"
[ebuild U ] kde-base/kturtle-4.9.3 [4.8.5]
[ebuild U ] kde-base/blinken-4.9.3 [4.8.5]
[ebuild U ] kde-base/step-4.9.3 [4.8.5]
[ebuild U ] kde-base/rocs-4.9.3 [4.8.5]
[ebuild U ] kde-base/kiten-4.9.3 [4.8.5]
[ebuild U ] kde-base/kanagram-4.9.3 [4.8.5]
[ebuild U ] kde-base/cantor-4.9.3 [4.8.5]
[ebuild U ] kde-base/klettres-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdeedu-meta-4.9.3 [4.8.5]
[ebuild U ] kde-base/kteatime-4.9.3 [4.8.5]
[ebuild U ] kde-base/ktux-4.9.3 [4.8.5]
[ebuild U ] kde-base/amor-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdetoys-meta-4.9.3 [4.8.5]
[ebuild U ] kde-base/superkaramba-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdf-4.9.3 [4.8.5]
[ebuild U ] kde-base/kcalc-4.9.3 [4.8.5]
[ebuild U ] kde-base/ktimer-4.9.3 [4.8.5]
[ebuild U ] kde-base/sweeper-4.9.3 [4.8.5]
[ebuild U ] kde-base/ark-4.9.3 [4.8.5]
[ebuild U ] kde-base/filelight-4.9.3 [4.8.5]
[ebuild U ] kde-base/kcharselect-4.9.3 [4.8.5]
[ebuild U ] kde-base/kgpg-4.9.3 [4.8.5]
[ebuild U ] kde-base/printer-applet-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdeutils-meta-4.9.3 [4.8.5] USE="-lirc%"
[ebuild U ] kde-base/kdeartwork-sounds-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdeartwork-desktopthemes-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdeartwork-weatherwallpapers-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdeartwork-emoticons-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdeartwork-styles-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdeartwork-kscreensaver-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdeartwork-colorschemes-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdeartwork-iconthemes-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdeartwork-meta-4.9.3 [4.8.5]
[ebuild U ] kde-base/krfb-4.9.3 [4.8.5] USE="-telepathy%"
[ebuild U ] kde-base/krdc-4.9.3 [4.8.5] USE="-telepathy%"
[ebuild U ] kde-base/kdenetwork-filesharing-4.9.3 [4.8.5]
[ebuild U ] kde-base/kget-4.9.3 [4.8.5]
[ebuild U ] kde-base/kopete-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdenetwork-meta-4.9.3 [4.8.5]
[ebuild U ] kde-base/kcron-4.9.3 [4.8.5]
[ebuild U ] kde-base/system-config-printer-kde-4.9.3 [4.8.5]
[ebuild U ] kde-base/kuser-4.9.3 [4.8.5]
[ebuild U ] kde-base/ksystemlog-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdeadmin-meta-4.9.3 [4.8.5]
[ebuild U ] kde-base/kcolorchooser-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdegraphics-strigi-analyzer-4.9.3 [4.8.5]
[ebuild U ] kde-base/kolourpaint-4.9.3 [4.8.5]
[ebuild U ] kde-base/kamera-4.9.3 [4.8.5]
[ebuild U ] kde-base/kgamma-4.9.3 [4.8.5]
[ebuild U ] kde-base/kruler-4.9.3 [4.8.5]
[ebuild U ] kde-base/thumbnailers-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdegraphics-mobipocket-4.9.3 [4.8.5]
[ebuild U ] kde-base/ksnapshot-4.9.3 [4.8.5]
[ebuild U ] kde-base/gwenview-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdegraphics-meta-4.9.3 [4.8.5]
[ebuild U ] kde-base/kmines-4.9.3 [4.8.5]
[ebuild U ] kde-base/kigo-4.9.3 [4.8.5]
[ebuild U ] kde-base/ksudoku-4.9.3 [4.8.5] USE="opengl%*"
[ebuild U ] kde-base/klines-4.9.3 [4.8.5]
[ebuild U ] kde-base/konquest-4.9.3 [4.8.5]
[ebuild U ] kde-base/kspaceduel-4.9.3 [4.8.5]
[ebuild U ] kde-base/kollision-4.9.3 [4.8.5]
[ebuild U ] kde-base/palapeli-4.9.3 [4.8.5]
[ebuild U ] kde-base/kpat-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdiamond-4.9.3 [4.8.5]
[ebuild U ] kde-base/kblackbox-4.9.3 [4.8.5]
[ebuild U ] kde-base/ktuberling-4.9.3 [4.8.5]
[ebuild U ] kde-base/ksirk-4.9.3 [4.8.5]
[ebuild U ] kde-base/kshisen-4.9.3 [4.8.5]
[ebuild U ] kde-base/kbreakout-4.9.3 [4.8.5]
[ebuild U ] kde-base/kjumpingcube-4.9.3 [4.8.5]
[ebuild U ] kde-base/kbounce-4.9.3 [4.8.5]
[ebuild U ] kde-base/granatier-4.9.3 [4.8.5]
[ebuild U ] kde-base/katomic-4.9.3 [4.8.5]
[ebuild U ] kde-base/ksquares-4.9.3 [4.8.5]
[ebuild U ] kde-base/kmahjongg-4.9.3 [4.8.5]
[ebuild U ] kde-base/kfourinline-4.9.3 [4.8.5]
[ebuild U ] kde-base/killbots-4.9.3 [4.8.5]
[ebuild U ] kde-base/klickety-4.9.3 [4.8.5]
[ebuild U ] kde-base/kiriki-4.9.3 [4.8.5]
[ebuild U ] kde-base/kgoldrunner-4.9.3 [4.8.5]
[ebuild U ] kde-base/bovo-4.9.3 [4.8.5]
[ebuild U ] kde-base/kreversi-4.9.3 [4.8.5]
[ebuild U ] kde-base/bomber-4.9.3 [4.8.5]
[ebuild U ] kde-base/knetwalk-4.9.3 [4.8.5]
[ebuild U ] kde-base/lskat-4.9.3 [4.8.5]
[ebuild U ] kde-base/kolf-4.9.3 [4.8.5]
[ebuild U ] kde-base/kblocks-4.9.3 [4.8.5]
[ebuild U ] kde-base/kubrick-4.9.3 [4.8.5]
[ebuild U ] kde-base/kapman-4.9.3 [4.8.5]
[ebuild N ] kde-base/nepomuk-core-4.9.3 USE="(-aqua) -debug"
[ebuild U ] kde-base/nepomuk-4.9.3 [4.8.5]
[blocks b ] <kde-base/nepomuk-4.8.80:4 ("<kde-base/nepomuk-4.8.80:4" is blocking kde-base/nepomuk-core-4.9.3)
[ebuild U ] kde-base/kdebase-runtime-meta-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdebase-startkde-4.9.3 [4.8.5]
[ebuild U ] kde-base/kdebase-meta-4.9.3 [4.8.5]
[ebuild N ] kde-base/dragon-4.9.3 USE="handbook (-aqua) -debug -xine"
[uninstall ] kde-base/dragonplayer-4.8.5
[blocks b ] kde-base/dragonplayer:4 ("kde-base/dragonplayer:4" is blocking kde-base/dragon-4.9.3)
[ebuild N ] kde-base/knavalbattle-4.9.3 USE="handbook (-aqua) -debug"
[uninstall ] kde-base/kbattleship-4.8.5
[blocks b ] kde-base/kbattleship:4 ("kde-base/kbattleship:4" is blocking kde-base/knavalbattle-4.9.3)
[ebuild N ] kde-base/ksnakeduel-4.9.3 USE="handbook (-aqua) -debug (-selinux)"
[uninstall ] kde-base/ktron-4.8.5
[blocks b ] kde-base/ktron:4 ("kde-base/ktron:4" is blocking kde-base/ksnakeduel-4.9.3)
[ebuild U ] kde-base/kdegames-meta-4.9.3 [4.8.5]
[ebuild U ] kde-base/libkcddb-4.9.3 [4.8.5]
[ebuild U ] kde-base/kscd-4.9.3 [4.8.5]
[blocks b ] <kde-base/kscd-4.8.50:4 ("<kde-base/kscd-4.8.50:4" is blocking kde-base/libkcddb-4.9.3)
[ebuild N ] kde-base/audiocd-kio-4.9.3 USE="encode flac handbook vorbis (-aqua) -debug"
[uninstall ] kde-base/kdemultimedia-kioslaves-4.8.5
[blocks b ] kde-base/kdemultimedia-kioslaves:4 ("kde-base/kdemultimedia-kioslaves:4" is blocking kde-base/audiocd-kio-4.9.3, kde-base/libkcddb-4.9.3)
[ebuild U ] kde-base/kdemultimedia-meta-4.9.3 [4.8.5]
[ebuild U ] kde-base/kde-meta-4.9.3 [4.8.5]
[blocks B ] <sys-apps/openrc-0.9.9.3 ("<sys-apps/openrc-0.9.9.3" is blocking sys-apps/net-tools-1.60_p20120127084908)


I see kde updates being blocked by other kde items required for older versions. Not sure how to deal with these.
Also, I do not understand why the openrc item is appearing.
If anyone can give me some pointers to free this blockage, it would be most welcome.

Thanks for any help
Back to top
View user's profile Send private message
Xenoist
n00b
n00b


Joined: 21 Aug 2002
Posts: 23
Location: EU/DE/NRW/NEUSS

PostPosted: Fri Dec 07, 2012 9:53 pm    Post subject: Reply with quote

This happens even with 4.9.3 to 4.9.4.

My solution is:

qlist -ICv qt| xargs emerge -C

emerge -uvDN system && emerge -uvDN world


If some packages from KDE dropps errors or installs an old QT Version they are mostly gone or combined so they must be uninstalled.

This is a really silly work but bust be done sometimes.

Hope this helps you.

my openrc is sys-apps/openrc-0.11.8 and sys-apps/net-tools-1.60_p20120127084908.
_________________
Once live is to short to learn all, but keep trying it.

"emerge the world" every day!

Linux Registered User #413022
Back to top
View user's profile Send private message
cmprior
n00b
n00b


Joined: 03 Sep 2011
Posts: 15

PostPosted: Fri Dec 07, 2012 10:09 pm    Post subject: May be solved Reply with quote

Looks like I did not specify 'deep'

Must check myself more thoroughly

Updates now in progress

Sorry to disturb and thanks for looking
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum