Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem when switching to HDMI audio
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
CyberMuz
n00b
n00b


Joined: 03 Jan 2012
Posts: 23

PostPosted: Sun Dec 02, 2012 10:46 pm    Post subject: Problem when switching to HDMI audio Reply with quote

Hi!

I'm having problems with HDMI sound on my system (Lenovo SL500 laptop, Nvidia graphics). When I plug the HDMI cable I'm not able to switch the sound so that it goes only to TV and not to the speakers. If in Pavucontrol or Multimedia>Phonon I select Profile "Digital stereo (HDMI) output" I end up with the sound going to both the TV and the laptop speakers which is very annoying. The only workaround I have found is to open alsamixer in console and turn the Master volume all the way down. This mutes the speakers on laptop and sound goes only to HDMI.
I have no idea how to fix this problem. :-/
Back to top
View user's profile Send private message
Fitzcarraldo
Guru
Guru


Joined: 30 Aug 2008
Posts: 556
Location: United Kingdom

PostPosted: Mon Dec 03, 2012 12:28 am    Post subject: Reply with quote

When I launch PulseAudio Volume Control (media-sound/pavucontrol) I see two Profiles on the Configuration tab: 'HDMI Audio' and 'Built-in Audio'. After I have selected 'Digital Stereo (HDMI) Output' as the Profile for 'HDMI Audio' I select 'Off' for the Profile of 'Built-in Audio', and then sound only comes out of the TV. Does that not happen in your case?

Do you have PulseAudio Preferences (media-sound/paprefs) installed? If you do, when you launch it do you have 'Add virtual output device for simultaneous output on all local sound cards' ticked on the 'Simultaneous Output' tab? If you do, you could untick that to see what happens.
_________________
Fitzcarraldo's blog
Back to top
View user's profile Send private message
anyc
Tux's lil' helper
Tux's lil' helper


Joined: 31 May 2004
Posts: 119

PostPosted: Mon May 27, 2013 3:04 pm    Post subject: Reply with quote

As PA remembers the sinks for streams, maybe your sound is always directed to the combined sink as Fitzcarraldo already suspected. You don't necessarily have to deactivate this. Instead you can also choose the HDMI sink in the mixer for the stream or you can use a daemon like http://github.com/anyc/mplugd that changes the output automatically if you plug in a TV.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum