Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] kde and qt overlays - howto use?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1136

PostPosted: Sun Dec 02, 2012 3:48 pm    Post subject: [solved] kde and qt overlays - howto use? Reply with quote

I want to test recent versions of
qt-4.8.4
kde-4.9.4

But adding the two overlays qt and kde just gives me - when issued "emerge -auvDN world"
[code]Calculating dependencies ........ done!
[ebuild U ] dev-python/sip-4.14.2_pre20121115:0/9::qt [4.14.1:0/9::gentoo] USE="-debug -doc" 710 kB
[ebuild U ] kde-base/kdebase-pam-9::kde [7::gentoo] 0 kB
[ebuild U ] sys-auth/pambase-20120417-r2::kde [20120417-r1::gentoo] USE="minimal mktemp sha512 systemd (-consolekit) -cracklib -debug -gnome-keyring -pam_krb5 -pam_ssh -passwdqc (-selinux)" 4 kB
[ebuild U ] media-libs/qimageblitz-0.0.6-r1::kde [0.0.6::gentoo] USE="mmx sse sse2 -3dnow (-altivec) -debug" 57 kB
[ebuild U ] app-office/akonadi-server-1.8.80::kde [1.8.1::gentoo] USE="mysql sqlite -postgres {-test}" 0 kB
[ebuild U ] dev-python/PyQt4-4.9.6_pre20121123::qt [4.9.5::gentoo] USE="X assistant dbus declarative kde multimedia opengl phonon sql svg webkit xmlpatterns -debug -doc -examples" 9,762
[/code]
... packages I am not targeting for testing in the first place ...
_________________
fun2gen2


Last edited by ulenrich on Sun Dec 02, 2012 5:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5250

PostPosted: Sun Dec 02, 2012 3:54 pm    Post subject: Reply with quote

Looks like normal dependencies to me. If you update a package, the ebuild will pull in whatever updates are also necessary. There's no way around it.

And/or: if you're on ~arch and you install an overlay with higher version numbers of existing packages, those will get pulled in. Again, that's to be expected.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2444
Location: Austria

PostPosted: Sun Dec 02, 2012 4:02 pm    Post subject: Reply with quote

This is all perfectly fine. Be aware that kde-4.9.4 tarball will only be officially released in two days.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1136

PostPosted: Sun Dec 02, 2012 4:13 pm    Post subject: Reply with quote

I am using ~amd64

@audiodef, ok these should update, but there are no others - all qt and kde atoms I am interested in are masked

@genstorm, ok I can wait these two days. Will it be available using newer qt libs also?

But if overlays shall help Gentoo maintainers by letting ordinary users test easily - this is the hard way. Shouldn't there be an additional kdetest overlay for easy testing purpose?
_________________
fun2gen2
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2444
Location: Austria

PostPosted: Sun Dec 02, 2012 4:27 pm    Post subject: Reply with quote

The purpose of the overlays is not to provide easy non-masked packages for testing. For kde overlay you will usually find package.unmask and package.keywords files inside the Documentation directory to which you can link from inside your /etc/portage/package.{keywords,unmask} dirs.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1136

PostPosted: Sun Dec 02, 2012 5:46 pm    Post subject: Reply with quote

genstorm wrote:
package.unmask and package.keywords files inside the Documentation directory to which you can link
Thank you.
I had blind eyes today ....
_________________
fun2gen2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum