Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] How can I install chromium (conflict) ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
augustin2
Apprentice
Apprentice


Joined: 16 Mar 2012
Posts: 177
Location: France

PostPosted: Sun Dec 02, 2012 1:16 pm    Post subject: [solved] How can I install chromium (conflict) ? Reply with quote

Hi,
here is a short story of my attempt to install chromiun. I am new to Gentoo and I had chromium installed some days ago before I reinstalled from scratch.

Is it possible to have chromium installed in such a case ?

Code:

new-host jaaf # emerge -p chromium

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/ppl-0.11.2-r1  USE="-doc -lpsol -pch -static-libs {-test} -watchdog"
[ebuild  N     ] media-libs/libwebp-0.2.1  USE="-experimental -static-libs"
[ebuild  N     ] media-libs/speex-1.2_rc1  USE="ogg sse -static-libs"
[ebuild  N     ] dev-libs/cloog-ppl-0.15.10  USE="-static-libs"
[ebuild   R    ] dev-libs/libxml2-2.8.0-r3  USE="icu*"
[ebuild  N     ] dev-lang/v8-3.13.7.5
[ebuild  N     ] dev-python/simplejson-2.6.2
[ebuild  N     ] dev-lang/nacl-toolchain-newlib-0_p9093
[ebuild  N     ] dev-python/ply-3.4  USE="-examples"
[ebuild  N     ] www-client/chromium-23.0.1271.95  USE="cups -bindist -custom-cflags -gnome -gnome-keyring -kerberos (-pulseaudio) (-selinux) (-tcmalloc) {-test}" LINGUAS="fr -am -ar -bg -bn -ca -cs -da -de -el -en_GB -es -es_LA -et -fa -fi -fil -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh_CN -zh_TW"

The following USE changes are necessary to proceed:
#required by www-client/chromium-23.0.1271.95, required by chromium (argument)
=dev-libs/libxml2-2.8.0-r3 icu


Code:

                                                                                                                                                                                                   
new-host jaaf # echo "=dev-libs/libxml2-2.8.0-r3 icu" >> /etc/portage/package.use


Code:

new-host jaaf # emerge -p chromium
                                                                                                                                                                                                   
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/ppl-0.11.2-r1  USE="-doc -lpsol -pch -static-libs {-test} -watchdog"
[ebuild  N     ] media-libs/libwebp-0.2.1  USE="-experimental -static-libs"
[ebuild  N     ] media-libs/speex-1.2_rc1  USE="ogg sse -static-libs"
[ebuild  N     ] dev-libs/cloog-ppl-0.15.10  USE="-static-libs"
[ebuild     UD ] dev-libs/libxml2-2.8.0-r2 [2.8.0-r3] USE="icu*"
[ebuild  N     ] dev-lang/v8-3.13.7.5
[ebuild  N     ] dev-python/simplejson-2.6.2
[ebuild  N     ] dev-lang/nacl-toolchain-newlib-0_p9093
[ebuild  N     ] dev-python/ply-3.4  USE="-examples"
[ebuild  N     ] www-client/chromium-23.0.1271.95  USE="cups -bindist -custom-cflags -gnome -gnome-keyring -kerberos (-pulseaudio) (-selinux) (-tcmalloc) {-test}" LINGUAS="fr -am -ar -bg -bn -ca -cs -da -de -el -en_GB -es -es_LA -et -fa -fi -fil -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh_CN -zh_TW"

WARNING: One or more updates have been skipped due to a dependency conflict:

dev-libs/libxml2:2

  (dev-libs/libxml2-2.8.0-r3::gentoo, ebuild scheduled for merge) conflicts with
    dev-libs/libxml2:2[-icu] required by (x11-libs/qt-webkit-4.8.2::gentoo, installed)


The following USE changes are necessary to proceed:
#required by www-client/chromium-23.0.1271.95, required by chromium (argument)
=dev-libs/libxml2-2.8.0-r2 icu


Code:

new-host jaaf # echo "=dev-libs/libxml2-2.8.0-r2 icu" >> /etc/portage/package.use

Code:

new-host jaaf # emerge -p chromium

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/ppl-0.11.2-r1  USE="-doc -lpsol -pch -static-libs {-test} -watchdog"
[ebuild  N     ] media-libs/libwebp-0.2.1  USE="-experimental -static-libs"
[ebuild  N     ] media-libs/speex-1.2_rc1  USE="ogg sse -static-libs"
[ebuild  N     ] dev-libs/cloog-ppl-0.15.10  USE="-static-libs"
[ebuild     U #] dev-libs/libxml2-2.9.0 [2.8.0-r3] USE="icu*"
[ebuild  N     ] dev-lang/v8-3.13.7.5
[ebuild  N     ] dev-python/simplejson-2.6.2
[ebuild  N     ] dev-lang/nacl-toolchain-newlib-0_p9093
[ebuild  N     ] dev-python/ply-3.4  USE="-examples"
[ebuild  N     ] www-client/chromium-23.0.1271.95  USE="cups -bindist -custom-cflags -gnome -gnome-keyring -kerberos (-pulseaudio) (-selinux) (-tcmalloc) {-test}" LINGUAS="fr -am -ar -bg -bn -ca -cs -da -de -el -en_GB -es -es_LA -et -fa -fi -fil -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh_CN -zh_TW"

The following keyword changes are necessary to proceed:
#required by dev-db/virtuoso-server-6.1.6, required by dev-libs/soprano-2.8.0[virtuoso], required by kde-base/nepomuk-core-4.9.3, required by kde-base/nepomuk-4.9.3, required by kde-base/kdebase-runtime-meta-4.9.3[semantic-desktop], required by kde-base/kdebase-startkde-4.9.3, required by kde-base/kdebase-meta-4.9.3, required by kde-base/kde-meta-4.9.3, required by @selected, required by @world (argument)
=dev-libs/libxml2-2.9.0 ~amd64

The following mask changes are necessary to proceed:
#required by dev-db/virtuoso-server-6.1.6, required by dev-libs/soprano-2.8.0[virtuoso], required by kde-base/nepomuk-core-4.9.3, required by kde-base/nepomuk-4.9.3, required by kde-base/kdebase-runtime-meta-4.9.3[semantic-desktop], required by kde-base/kdebase-startkde-4.9.3, required by kde-base/kdebase-meta-4.9.3, required by kde-base/kde-meta-4.9.3, required by @selected, required by @world (argument)
# /usr/portage/profiles/package.mask:
# Alexandre Rostovtsev <tetromino@gentoo.org> (25 Sep 2012)
# GNOME 3.6 mask
# Core libraries to be unmasked first:
# Other stuff
=dev-libs/libxml2-2.9.0

The following USE changes are necessary to proceed:
#required by www-client/chromium-23.0.1271.95, required by chromium (argument)
>=dev-libs/libxml2-2.9.0 icu

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.


Code:


new-host jaaf # echo ">=dev-libs/libxml2-2.9.0 icu" >> /etc/portage/package.use


Code:

new-host jaaf # emerge -p chromium

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/ppl-0.11.2-r1  USE="-doc -lpsol -pch -static-libs {-test} -watchdog"
[ebuild  N     ] media-libs/libwebp-0.2.1  USE="-experimental -static-libs"
[ebuild  N     ] media-libs/speex-1.2_rc1  USE="ogg sse -static-libs"
[ebuild  N     ] dev-libs/cloog-ppl-0.15.10  USE="-static-libs"
[ebuild   R    ] dev-libs/libxml2-2.8.0-r3  USE="icu*"
[ebuild  N     ] dev-lang/v8-3.13.7.5
[ebuild  N     ] dev-python/simplejson-2.6.2
[ebuild  N     ] dev-lang/nacl-toolchain-newlib-0_p9093
[ebuild  N     ] dev-python/ply-3.4  USE="-examples"
[ebuild  N     ] www-client/chromium-23.0.1271.95  USE="cups -bindist -custom-cflags -gnome -gnome-keyring -kerberos (-pulseaudio) (-selinux) (-tcmalloc) {-test}" LINGUAS="fr -am -ar -bg -bn -ca -cs -da -de -el -en_GB -es -es_LA -et -fa -fi -fil -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh_CN -zh_TW"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libxml2:2

  (dev-libs/libxml2-2.8.0-r3::gentoo, installed) pulled in by
    dev-libs/libxml2:2[!icu?] required by (x11-libs/qt-webkit-4.8.2::gentoo, installed)

  (dev-libs/libxml2-2.8.0-r3::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libxml2[icu] required by (www-client/chromium-23.0.1271.95::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


new-host jaaf #



Last edited by augustin2 on Sun Dec 02, 2012 4:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
megabaks
Apprentice
Apprentice


Joined: 22 Jan 2012
Posts: 253
Location: Russia && Saint-Petersburg

PostPosted: Sun Dec 02, 2012 2:13 pm    Post subject: Reply with quote

Code:
echo "x11-libs/qt-webkit icu" >> /etc/portage/package.use
Back to top
View user's profile Send private message
augustin2
Apprentice
Apprentice


Joined: 16 Mar 2012
Posts: 177
Location: France

PostPosted: Sun Dec 02, 2012 2:50 pm    Post subject: Reply with quote

Thank you for answer.

Are you sure of what you are saying because I don't understand ?

I am not a computer scientist but understand that qt-webqkit and chromium require a different version of libxml2 and if so, how can this use change makes qt-webkit not require the conflicting version any longer ?

Please don't feel offended if I wait for a second opinion or a strong confirmation from you.
Back to top
View user's profile Send private message
megabaks
Apprentice
Apprentice


Joined: 22 Jan 2012
Posts: 253
Location: Russia && Saint-Petersburg

PostPosted: Sun Dec 02, 2012 3:12 pm    Post subject: Reply with quote

Quote:
qt-webqkit and chromium require a different version of libxml2
what o_O?
just rebuild qt-webkit with icu use-flag
Code:
[ root@desktop ] megabaks # qlist -IUv libxml2 chromium qt-webkit
dev-libs/libxml2-2.8.0-r3 (icu lzma python readline)
www-client/chromium-23.0.1271.95 (custom-cflags linguas_ru)
x11-libs/qt-webkit-4.8.3 (exceptions gstreamer icu jit)
[ root@desktop ] megabaks #
Back to top
View user's profile Send private message
fr3eatlast
n00b
n00b


Joined: 21 Jul 2012
Posts: 41
Location: Marquette, MI

PostPosted: Sun Dec 02, 2012 4:08 pm    Post subject: Reply with quote

I had this same problem the first time I installed chromium. You are going to have to rebuild both libxml and qt-webkit with icu support.
Code:
echo "x11-libs/qt-webkit icu" >> /etc/portage/package.use && echo "dev-libs/libxml2 icu" >> /etc/portage/package.use

will tell portage to build icu support in both qt-webkit and libxml2. You should then be able to emerge chromium as usual.
Back to top
View user's profile Send private message
augustin2
Apprentice
Apprentice


Joined: 16 Mar 2012
Posts: 177
Location: France

PostPosted: Sun Dec 02, 2012 4:31 pm    Post subject: Reply with quote

megabaks is right. Rebuilding qt-webkit with icu use flag solves the problem.
But I still have trouble understanding the reasoning that could have lead me to this. I probably need more learning.

Thanks to you all.
Back to top
View user's profile Send private message
megabaks
Apprentice
Apprentice


Joined: 22 Jan 2012
Posts: 253
Location: Russia && Saint-Petersburg

PostPosted: Sun Dec 02, 2012 5:12 pm    Post subject: Reply with quote

augustin2 wrote:
But I still have trouble understanding the reasoning that could have lead me to this. I probably need more learning.

Code:
equery g www-client/chromium-23.0.1271.95
output
Code:
....
   `--  dev-libs/libxml2-2.8.0-r3  (dev-libs/libxml2) x86  [icu]
....
chromium need libxml2 with icu use-flag enabled
Code:
equery g x11-libs/qt-webkit-4.8.2
output
Code:
....
   `--  dev-libs/libxml2-2.8.0-r3  (dev-libs/libxml2) x86  [!icu?]
....
qt-webkit need libxml2 with same state of icu use-flag(enable/disable)
So, if u need chromium and qt-webkit, u need enabled icu use-flag for libxml2 and for qt-webkit
/sorry my bad english
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1136

PostPosted: Sun Dec 02, 2012 5:57 pm    Post subject: Reply with quote

Enabling the new USE flag globaly , followed by an inspection issuing of "emerge -pDN world"
would have prevented such trouble for this simple task :)
_________________
fun2gen2
Back to top
View user's profile Send private message
augustin2
Apprentice
Apprentice


Joined: 16 Mar 2012
Posts: 177
Location: France

PostPosted: Sun Dec 02, 2012 6:08 pm    Post subject: Reply with quote

@megabaks Thank you for your teaching.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum