Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cleaning up RUBY-mix between gentoo-portage and RVM
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
kami22
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2006
Posts: 108

PostPosted: Sun Dec 16, 2012 8:25 am    Post subject: Cleaning up RUBY-mix between gentoo-portage and RVM Reply with quote

HI,

i got some problems with my ruby on gentoo. Something is mixed up between rvm and gentoo portage.

Code:
 # gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.8.24
  - RUBY VERSION: 1.9.3 (2012-04-20 patchlevel 194) [x86_64-linux]
  - INSTALLATION DIRECTORY: /usr/local/rvm/gems/ruby-1.9.3-p327
  - RUBY EXECUTABLE: /usr/bin/ruby19
  - EXECUTABLE DIRECTORY: /usr/local/rvm/gems/ruby-1.9.3-p327/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86_64-linux
  - GEM PATHS:
     - /usr/local/rvm/gems/ruby-1.9.3-p327
     - /usr/local/rvm/gems/ruby-1.9.3-p327@global
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://rubygems.org/


 # gem list

*** LOCAL GEMS ***

bundler (1.2.3)
CFPropertyList (2.2.0, 2.1.2)
eventmachine (1.0.0)
geocoder (1.1.5)
i18n (0.6.1)
json (1.7.5)
mail (2.5.3)
mime-types (1.19)
mysql (2.9.0)
polyglot (0.3.3)
pony (1.4)
rake (10.0.3, 10.0.2)
rubygems-bundler (1.1.0)
rvm (1.11.3.5)
siriproxy (0.11.3)
treetop (1.4.12)
uuidtools (2.1.3)


I get this Output. But if i try to install some packages with emerge i get this output path:

>>> Completed installing json-1.6.7 into /var/tmp/portage/dev-ruby/json-1.6.7/image/

strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment -R .GCC.command.line
usr/lib64/ruby/gems/1.9.1/gems/json-1.6.7/lib/json/ext/parser.so
usr/lib64/ruby/gems/1.9.1/gems/json-1.6.7/lib/json/ext/generator.so

>>> Installing (1 of 1) dev-ruby/json-1.6.7

So the 1.9.1. is wrong.

Maybe someone can help me?

Cu kami
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum