Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] new installation cairo error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
OKAN
n00b
n00b


Joined: 23 Apr 2009
Posts: 50
Location: Türkiye

PostPosted: Mon Nov 26, 2012 5:32 pm    Post subject: [solved] new installation cairo error Reply with quote

I want to make a new gentoo installation. I installed base system. And now, I want to install kde4. When I try this command:
Code:
# USE="qt3support consolekit gudev hwdb policykit ogg vorbis" emerge  kdebase-startkde

this error seems:
Code:
/usr/lib/gcc/i686-pc-linux-gnu/4.5.4/../../../../lib/libEGL.so: undefined reference to `udev_device_get_parent'
/usr/lib/gcc/i686-pc-linux-gnu/4.5.4/../../../../lib/libEGL.so: undefined reference to `udev_device_unref'
/usr/lib/gcc/i686-pc-linux-gnu/4.5.4/../../../../lib/libEGL.so: undefined reference to `udev_device_get_property_value'
/usr/lib/gcc/i686-pc-linux-gnu/4.5.4/../../../../lib/libEGL.so: undefined reference to `udev_device_new_from_devnum'
/usr/lib/gcc/i686-pc-linux-gnu/4.5.4/../../../../lib/libEGL.so: undefined reference to `udev_unref'
/usr/lib/gcc/i686-pc-linux-gnu/4.5.4/../../../../lib/libEGL.so: undefined reference to `udev_new'
collect2: ld returned 1 exit status
make[4]: *** [cairo-sphinx] Error 1
make[4]: Leaving directory `/var/tmp/portage/x11-libs/cairo-1.12.8/work/cairo-1.12.8/util/cairo-sphinx'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/x11-libs/cairo-1.12.8/work/cairo-1.12.8/util'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/x11-libs/cairo-1.12.8/work/cairo-1.12.8/util'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-libs/cairo-1.12.8/work/cairo-1.12.8'
make: *** [all] Error 2
 * ERROR: x11-libs/cairo-1.12.8 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-libs/cairo-1.12.8'`,
 * the complete build log and the output of `emerge -pqv '=x11-libs/cairo-1.12.8'`.
 * The complete build log is located at '/var/tmp/portage/x11-libs/cairo-1.12.8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/cairo-1.12.8/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-libs/cairo-1.12.8/work/cairo-1.12.8'
 * S: '/var/tmp/portage/x11-libs/cairo-1.12.8/work/cairo-1.12.8'

>>> Failed to emerge x11-libs/cairo-1.12.8, Log file:

>>>  '/var/tmp/portage/x11-libs/cairo-1.12.8/temp/build.log'

 * Messages for package x11-libs/cairo-1.12.8:

 * ERROR: x11-libs/cairo-1.12.8 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-libs/cairo-1.12.8'`,
 * the complete build log and the output of `emerge -pqv '=x11-libs/cairo-1.12.8'`.
 * The complete build log is located at '/var/tmp/portage/x11-libs/cairo-1.12.8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/cairo-1.12.8/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-libs/cairo-1.12.8/work/cairo-1.12.8'
 * S: '/var/tmp/portage/x11-libs/cairo-1.12.8/work/cairo-1.12.8'


/var/tmp/portage/x11-libs/cairo-1.12.8/temp/build.log: http://bpaste.net/show/60470/
emerge --info: http://bpaste.net/show/60471/

How can I fix this?


Last edited by OKAN on Mon Nov 26, 2012 9:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
gerard82
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2229
Location: Netherlands

PostPosted: Mon Nov 26, 2012 6:10 pm    Post subject: Reply with quote

Emerge --info please.
We need to know your profile.
If it's correct for kde then no need for USE=.
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5618

PostPosted: Mon Nov 26, 2012 7:30 pm    Post subject: Reply with quote

That's not a cairo error, it's a revdep-rebuild error, most likely after udev upgrade.
Back to top
View user's profile Send private message
OKAN
n00b
n00b


Joined: 23 Apr 2009
Posts: 50
Location: Türkiye

PostPosted: Mon Nov 26, 2012 9:17 pm    Post subject: Reply with quote

Yes it was a revdep-rebuild error. It is solved. Thank you @gerard82 and @ VoidMage.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum