Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
/sbin/udevd missing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Negated Void
l33t
l33t


Joined: 25 Dec 2002
Posts: 659

PostPosted: Fri Dec 07, 2012 6:09 am    Post subject: /sbin/udevd missing Reply with quote

So I updated all my packages and rebooted.

udev failed to start because /sbin/udevd was missing. I fixed it temporarily with a symlink to some systemd version. I had to modprobe my own network drivers like a peasant.

I've seen others with the issue, but it's always been they haven't run etc-update or have bad kernel options. I am good there.

[ebuild R ] sys-apps/kmod-12 USE="tools zlib -debug -doc -lzma -static-libs" 0 kB
[ebuild R ] sys-apps/openrc-0.11.6 USE="ncurses pam unicode -debug -newnet (-prefix) (-selinux) -static-libs" 0 kB
[ebuild R ] sys-fs/udev-196-r1 USE="acl gudev hwdb introspection keymap kmod%* openrc -doc (-selinux) -static-libs" 0 kB
[ebuild R ] sys-fs/udev-init-scripts-17-r1::poly-c 0 kB

So, what do I need to change?
/etc/init.d/udev has "command=/sbin/udevd"

# equery b /etc/init.d/udev
* Searching for /etc/init.d/udev ...
sys-fs/udev-init-scripts-17-r1 (/etc/init.d/udev)

Maybe I miss-merged the /etc/init.d/udev? I've never done that before. I tried re-emerging it and it didn't say i had config files to update.
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Fri Dec 07, 2012 3:08 pm    Post subject: Reply with quote

Negated Void,

That ::poly-c toward the end of [ebuild R ] sys-fs/udev-init-scripts-17-r1::poly-c 0 kB looks suspicious :?

Mine looks like
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-fs/udev-init-scripts-17-r1  0 kB

Possible corruption :?
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
Negated Void
l33t
l33t


Joined: 25 Dec 2002
Posts: 659

PostPosted: Fri Dec 07, 2012 6:23 pm    Post subject: Reply with quote

Oh, good call. Some overlay I added for another reason.

Thanks =)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum