Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Failing to emerge gettext-0.18.1.1-(any) [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
keba
Guru
Guru


Joined: 02 Jun 2006
Posts: 304
Location: Switzerland

PostPosted: Fri Jun 29, 2012 11:39 am    Post subject: Failing to emerge gettext-0.18.1.1-(any) [solved] Reply with quote

Hi,

I'm trying to emerge gettext on a fresh install. It keeps failing and I can't find out why/what to do. I've been trying for 3 days. Can anyone help? The error message is below. Thanks in advance. Keba

Code:

...
i686-pc-linux-gnu-gcc -std=gnu99 -DLOCALEDIR=\"/usr/share/locale\" -DBISON_LOCALEDIR=\"\" -DLOCALE_ALIAS_PATH=\"/usr/share/local
=0 -DGETTEXTJEXEDIR=\"/usr/lib/gettext\" -DGETTEXTJAR=\"/usr/share/gettext/gettext.jar\" -DLIBDIR=\"/usr/lib\" -DGETTEXTDATADIR=
PROJECTSDIR=\"/usr/share/gettext/projects\" -DHAVE_CONFIG_H -I. -I..  -I. -I. -I.. -I.. -I../libgrep -I../gnulib-lib -I../gnulib
ttext-runtime/intl -DINSTALLDIR=\"/usr/lib/gettext\"   -O2 -march=pentium-m -msse2 -pipe -fomit-frame-pointer -c -o urlget-urlge
| echo './'`urlget.c
/bin/sh ../libtool  --tag=CC   --mode=link i686-pc-linux-gnu-gcc -std=gnu99  -O2 -march=pentium-m -msse2 -pipe -fomit-frame-poin
ulib-lib/libgettextlib.la  -lc   -Wl,-O1 -Wl,--as-needed -o libgettextsrc.la -rpath /usr/lib message.lo po-error.lo po-xerror.lo
 po-lex.lo po-gram-gen.lo po-charset.lo read-po.lo read-properties.lo read-stringtable.lo open-catalog.lo dir-list.lo str-list.l
o write-catalog.lo write-properties.lo write-stringtable.lo write-po.lo msgl-ascii.lo msgl-iconv.lo msgl-equal.lo msgl-cat.lo ms
.lo msgl-check.lo file-list.lo msgl-charset.lo po-time.lo plural-exp.lo plural-eval.lo plural-table.lo format.lo format-c.lo for
o format-lisp.lo format-elisp.lo format-librep.lo format-scheme.lo format-java.lo format-csharp.lo format-awk.lo format-pascal.l
l.lo format-perl.lo format-perl-brace.lo format-php.lo format-gcc-internal.lo format-gfc-internal.lo format-qt.lo format-qt-plur
t-boost.lo   
/bin/sh ../libtool  --tag=CC   --mode=link i686-pc-linux-gnu-gcc -std=gnu99  -O2 -march=pentium-m -msse2 -pipe -fomit-frame-poin
ded -o recode-sr-latin recode_sr_latin-recode-sr-latin.o recode_sr_latin-filter-sr-latin.o ../gnulib-lib/libgettextlib.la   
libtool: link: i686-pc-linux-gnu-gcc -std=gnu99 -O2 -march=pentium-m -msse2 -pipe -fomit-frame-pointer -Wl,-O1 -o .libs/recode-s
ecode-sr-latin.o recode_sr_latin-filter-sr-latin.o  -Wl,--as-needed ../gnulib-lib/.libs/libgettextlib.so -L/usr/lib -lacl -lc -l
libtool: link: i686-pc-linux-gnu-gcc -std=gnu99 -shared  .libs/message.o .libs/po-error.o .libs/po-xerror.o .libs/read-catalog-a
.libs/po-gram-gen.o .libs/po-charset.o .libs/read-po.o .libs/read-properties.o .libs/read-stringtable.o .libs/open-catalog.o .li
ist.o .libs/read-catalog.o .libs/color.o .libs/write-catalog.o .libs/write-properties.o .libs/write-stringtable.o .libs/write-po
bs/msgl-iconv.o .libs/msgl-equal.o .libs/msgl-cat.o .libs/msgl-header.o .libs/msgl-english.o .libs/msgl-check.o .libs/file-list.
ibs/po-time.o .libs/plural-exp.o .libs/plural-eval.o .libs/plural-table.o .libs/format.o .libs/format-c.o .libs/format-sh.o .lib
ormat-lisp.o .libs/format-elisp.o .libs/format-librep.o .libs/format-scheme.o .libs/format-java.o .libs/format-csharp.o .libs/fo
ascal.o .libs/format-ycp.o .libs/format-tcl.o .libs/format-perl.o .libs/format-perl-brace.o .libs/format-php.o .libs/format-gcc-
fc-internal.o .libs/format-qt.o .libs/format-qt-plural.o .libs/format-kde.o .libs/format-boost.o   -Wl,-rpath -Wl,/var/tmp/porta
.1.1-r3/work/gettext-0.18.1.1/gettext-tools/gnulib-lib/.libs ../gnulib-lib/.libs/libgettextlib.so /usr/bin /usr/sbin /bin /sbin
lncurses -lc -Wl,--as-needed  -march=pentium-m -msse2 -Wl,-O1   -Wl,-soname -Wl,libgettextsrc-0.18.1.so -o .libs/libgettextsrc-0
/usr/bin: file not recognized: Is a directory
collect2: ld returned 1 exit status
make[4]: *** [libgettextsrc.la] Error 1
make[4]: *** Waiting for unfinished jobs....
make[4]: Leaving directory `/var/tmp/portage/sys-devel/gettext-0.18.1.1-r3/work/gettext-0.18.1.1/gettext-tools/src'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/var/tmp/portage/sys-devel/gettext-0.18.1.1-r3/work/gettext-0.18.1.1/gettext-tools/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/sys-devel/gettext-0.18.1.1-r3/work/gettext-0.18.1.1/gettext-tools'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/var/tmp/portage/sys-devel/gettext-0.18.1.1-r3/work/gettext-0.18.1.1/gettext-tools'
make: *** [all-recursive] Error 1
emake failed
 * ERROR: sys-devel/gettext-0.18.1.1-r3 failed (compile phase):
 *   emake failed
 *
 * Call stack:
 *          ebuild.sh, line   85:  Called src_compile
 *        environment, line 4416:  Called _eapi2_src_compile
 *   phase-helpers.sh, line  573:  Called die
 * The specific snippet of code:
 *              emake || die "emake failed"
 *
 * If you need support, post the output of `emerge --info '=sys-devel/gettext-0.18.1.1-r3'`,
 * the complete build log and the output of `emerge -pqv '=sys-devel/gettext-0.18.1.1-r3'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="" JAVA_HOME=""
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info
 * The complete build log is located at '/var/tmp/portage/sys-devel/gettext-0.18.1.1-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/gettext-0.18.1.1-r3/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-devel/gettext-0.18.1.1-r3/work/gettext-0.18.1.1'
 * S: '/var/tmp/portage/sys-devel/gettext-0.18.1.1-r3/work/gettext-0.18.1.1'

_________________
Prayer can change the world!


Last edited by keba on Fri Jun 29, 2012 1:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5426

PostPosted: Fri Jun 29, 2012 1:17 pm    Post subject: Reply with quote

The block you've pasted is too messed up to be significantly usable...
But chances are it's as simple as "are you running from SystemRescueCD ?".
Back to top
View user's profile Send private message
keba
Guru
Guru


Joined: 02 Jun 2006
Posts: 304
Location: Switzerland

PostPosted: Fri Jun 29, 2012 1:26 pm    Post subject: Reply with quote

Yes I am running from SystemRescueCD, and I chrooted into the system. Thought it would be easier because I could easily graphically configure my wifi. Are you saying I should use the gentoo minimal CD instead?
_________________
Prayer can change the world!
Back to top
View user's profile Send private message
keba
Guru
Guru


Joined: 02 Jun 2006
Posts: 304
Location: Switzerland

PostPosted: Fri Jun 29, 2012 1:58 pm    Post subject: Reply with quote

Using the gentoo minimal-CD works! Thanks a lot for the hint. Too bad SysRescueCD doesn't work... Why is that?
_________________
Prayer can change the world!
Back to top
View user's profile Send private message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 2184

PostPosted: Fri Jun 29, 2012 2:16 pm    Post subject: Reply with quote

keba ...

I run into a similar problem with sysrescuecd some months back (it may also have been with gettext, but I can't be sure). The solution was to run "unset path" within the chroot. Sysrescuecd uses zsh as the default shell, and zsh has an array for $PATH called $path, for some reason this causes some builds to fail (probably as the zsh variable $path is space delimited and $PATH is colon delimited).

There is a thread with the gettext (and other package) issues here

best ... khay
Back to top
View user's profile Send private message
mattin
n00b
n00b


Joined: 24 Apr 2011
Posts: 2

PostPosted: Mon Nov 26, 2012 8:01 pm    Post subject: Reply with quote

Thx a lot khayyam. Was messing with a Sysrescuecd and this issue confused the hell out of me.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum