Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
System start after openrc upgrade [Solved (sort of)]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
leighgiles
Tux's lil' helper
Tux's lil' helper


Joined: 26 Mar 2004
Posts: 93
Location: Tasmania

PostPosted: Wed Nov 21, 2012 10:43 pm    Post subject: System start after openrc upgrade [Solved (sort of)] Reply with quote

After the openrc update my system - x86_64 - does the following


  • Loads the kernel
  • displays the login prompt
  • displays the usb devices it finds
  • hangs


/var/log/messages isn't updated

devfs and udev are at the sysinit run level

Any suggestions would be appreciated
_________________
Linux User 368276 - Machine 277813


Last edited by leighgiles on Mon Nov 26, 2012 11:49 pm; edited 2 times in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6714
Location: Goose Creek SC

PostPosted: Thu Nov 22, 2012 1:13 am    Post subject: Reply with quote

Does kernel config have:
Quote:
Device Drivers --->
Generic Driver Options --->
(/sbin/hotplug) path to uevent helper
[*] Maintain a devtmpfs filesystem to mount at /dev
[*] Automount devtmpfs at /dev, after the kernel mounted the rootfs

_________________
Defund the FCC.


Last edited by DONAHUE on Thu Nov 22, 2012 2:32 am; edited 1 time in total
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4742
Location: Saint Amant, Acadiana

PostPosted: Thu Nov 22, 2012 2:07 am    Post subject: Reply with quote

Quote:
[*] Automount devtmpfs at /dev, after the kernel mounted the rootfs


All my boxes, ~x86 and ~amd64, are running fine without this enabled. I see repeated suggestions on these forums to enable this option, yet nobody is willing to test what they are suggesting?
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2943
Location: The Peanut Gallery

PostPosted: Thu Nov 22, 2012 3:06 am    Post subject: Reply with quote

You don't need the second one, but you do need the first.

As for testing what we suggest, of course we do -- you'll see there that the mount option makes things work with LVM in our initramfs-less setup, even when booting into a rescue shell when the udev-mount service is not started, since /dev/mapper links are available at startup (if LVM is builtin to kernel.)

[edit]: it's not devfs which mounts /dev at startup (if not auto-mounted) but udev-mount.


Last edited by steveL on Thu Nov 22, 2012 7:30 am; edited 1 time in total
Back to top
View user's profile Send private message
Carnildo
Guru
Guru


Joined: 17 Jun 2004
Posts: 586

PostPosted: Thu Nov 22, 2012 3:52 am    Post subject: Reply with quote

steveL wrote:
You don't need the second one, but you do need the first.

What about the third?
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2943
Location: The Peanut Gallery

PostPosted: Thu Nov 22, 2012 5:43 am    Post subject: Reply with quote

Carnildo wrote:
What about the third?

I was talking about the two devtmpfs options: you must have the capability built in to "Maintain a devtmpfs filesystem" for udev to work. There is no need as such to automount it, as /etc/init.d/udev-mount will do that for you. (Sorry I misspoke when I said devfs earlier -- that mounts /dev/pts and /dev/shm if they've not already been done by mount from /etc/fstab). udev-mount is depended on by udev via "need sysfs udev-mount" (udev-mount now provides dev-mount as well, so this may change in newer udev. If you want to dig around in initscripts to see what's going on, check out this post.)

However, there's no problem with automounting it, as we do for the initramfs-less split /usr setup I linked to above. You just get an OK message saying "/dev is already mounted". It helps there as you get /dev/mapper/vg-lv device nodes created by the builtin LVM module, at kernel startup, which you can mount in /etc/fstab rather than the usual udev-created /dev/vg/lv links, and these are available to "mount -a" or for your usual mountpoints, when you boot into a rescue shell.

ISTR reading that the "path to hotplug" binary should be empty when using more recent udev, as udev uses netlink and the hotplug binary approach is deprecated (certainly it's been discussed as a negative of mdev.) Checking here, I don't even have an /sbin/hotplug executable any more, so I'll delete that setting in next upgrade.
_________________
creaker wrote:
systemd. It is a really ass pain

update - "a most excellent portage wrapper"

#friendly-coders -- We're still here for you™ ;)
Back to top
View user's profile Send private message
leighgiles
Tux's lil' helper
Tux's lil' helper


Joined: 26 Mar 2004
Posts: 93
Location: Tasmania

PostPosted: Thu Nov 22, 2012 8:18 am    Post subject: Reply with quote

Yes it does
I removed the second one

It still does the same thing except I can login
The file system is read-only

rc-update shows devfs,dmesg,sysfs,udev and udev-mount at sysint
_________________
Linux User 368276 - Machine 277813
Back to top
View user's profile Send private message
leighgiles
Tux's lil' helper
Tux's lil' helper


Joined: 26 Mar 2004
Posts: 93
Location: Tasmania

PostPosted: Mon Nov 26, 2012 11:47 pm    Post subject: Reply with quote

I've given up tring to find the problem and I'm rebuilding the system
_________________
Linux User 368276 - Machine 277813
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum