Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ayuda error vfs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Juan Betancourt
n00b
n00b


Joined: 18 Nov 2012
Posts: 17

PostPosted: Tue Nov 20, 2012 8:50 pm    Post subject: ayuda error vfs Reply with quote

hola medio un error al iniciar gentoo ese error es esl
1.499739 VFS: cannot open root device sda3 or uknown block (0,0) error -6
plese appenden a correct root device

ok bueno tengo el programa de ficheros para ext xx instalado y si estoy seguro que el disco es sda3 y creo que es algo en el kernel les dejo esta información
http://bpaste.net/show/59316/
por que creo que es del driver del ide en la configuración del kernel
pero en realidad buscando en las wiki no me sale asi que ayuda
ya van 3 dias con este error ybueno unado use el genkern funciono a la perfeccion
Back to top
View user's profile Send private message
cameta
l33t
l33t


Joined: 04 Aug 2004
Posts: 695

PostPosted: Tue Nov 20, 2012 10:46 pm    Post subject: Reply with quote

Si mal no recuerdo la causa principal de este tipo de error es que el soporte para ext esta compilado como modulo y para arrancar tiene que estar compilado built-in

A ver que tienes en file systems

Code:
<M> Second extended fs support                                             │ │ 
  │ │     [ ]   Ext2 extended attributes                                             │ │ 
  │ │     [ ]   Ext2 execute in place support                                        │ │ 
  │ │     <M> Ext3 journalling file system support                                   │ │ 
  │ │     [ ]   Default to 'data=ordered' in ext3                                    │ │ 
  │ │     [*]   Ext3 extended attributes                                             │ │ 
  │ │     [*]     Ext3 POSIX Access Control Lists                                    │ │ 
  │ │     [*]     Ext3 Security Labels                                               │ │ 
  │ │     <*> The Extended 4 (ext4) filesystem                                       │ │ 
  │ │     [*]   Ext4 extended attributes                                             │ │ 
  │ │     [*]     Ext4 POSIX Access Control Lists                                    │ │ 
  │ │     [ ]     Ext4 Security Labels                                               │ │ 
  │ │     [ ]   EXT4 debugging support

_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
Juan Betancourt
n00b
n00b


Joined: 18 Nov 2012
Posts: 17

PostPosted: Tue Nov 20, 2012 11:07 pm    Post subject: Reply with quote

cameta wrote:
Si mal no recuerdo la causa principal de este tipo de error es que el soporte para ext esta compilado como modulo y para arrancar tiene que estar compilado built-in

A ver que tienes en file systems

Code:
<M> Second extended fs support                                             │ │ 
  │ │     [ ]   Ext2 extended attributes                                             │ │ 
  │ │     [ ]   Ext2 execute in place support                                        │ │ 
  │ │     <M> Ext3 journalling file system support                                   │ │ 
  │ │     [ ]   Default to 'data=ordered' in ext3                                    │ │ 
  │ │     [*]   Ext3 extended attributes                                             │ │ 
  │ │     [*]     Ext3 POSIX Access Control Lists                                    │ │ 
  │ │     [*]     Ext3 Security Labels                                               │ │ 
  │ │     <*> The Extended 4 (ext4) filesystem                                       │ │ 
  │ │     [*]   Ext4 extended attributes                                             │ │ 
  │ │     [*]     Ext4 POSIX Access Control Lists                                    │ │ 
  │ │     [ ]     Ext4 Security Labels                                               │ │ 
  │ │     [ ]   EXT4 debugging support


no el hecho es que si los tengo con asterisco ya active los drivers via para el disco y se que ficheros tine cada partcion y el nombre y la configurcion de grub y lilo medan el miso error por uqe probe eso tambien al principio instale con el genkerne y correio sin probblemas y quise hacerlo a l modo manual yme da esto
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3733

PostPosted: Wed Nov 21, 2012 10:06 am    Post subject: Reply with quote

lo que te dice Cameta : lo mas probable es o bien que te falta soporte para el sistema de archivos o te falta soporte para la controladora a la que está(n) contectado(s) el/los disco(s) duro(s).
Ojo que he visto en tu primero post que tienes 2 controladoras con 2 drivers diferentes, sata_via y pata_via.

saluetes
Back to top
View user's profile Send private message
cameta
l33t
l33t


Joined: 04 Aug 2004
Posts: 695

PostPosted: Wed Nov 21, 2012 2:04 pm    Post subject: Reply with quote

Si eso de los controladores esta en la sección de Device Drivers
<*> Serial ATA and Parallel ATA drivers --->
Hay que comprobar que hayas seleccionado el controlador que correspinde al chip que tenga la placa base.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
Juan Betancourt
n00b
n00b


Joined: 18 Nov 2012
Posts: 17

PostPosted: Wed Nov 21, 2012 7:50 pm    Post subject: mi .config Reply with quote

http://bpaste.net/show/59617/
Back to top
View user's profile Send private message
Juan Betancourt
n00b
n00b


Joined: 18 Nov 2012
Posts: 17

PostPosted: Wed Nov 21, 2012 9:07 pm    Post subject: Re: mi .config Reply with quote

Juan Betancourt wrote:
http://bpaste.net/show/59617/

esta es la imagen del error
http://www.subirimagenes.net/show-image.php?id=ac8e0cbaba95902843769411534c505a
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 817

PostPosted: Wed Nov 21, 2012 10:07 pm    Post subject: Reply with quote

gringo wrote:
... tienes 2 controladoras con 2 drivers diferentes, sata_via y pata_via.
...

Tienes incluido SATA_VIA en tu configuración. Añade también PATA_VIA (VIA PATA support).
Back to top
View user's profile Send private message
Juan Betancourt
n00b
n00b


Joined: 18 Nov 2012
Posts: 17

PostPosted: Wed Nov 21, 2012 11:36 pm    Post subject: lo logramos Reply with quote

por finn corrio gracias por su apollo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum