Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
MPI execution failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Adjeiinfo
n00b
n00b


Joined: 20 Nov 2012
Posts: 3

PostPosted: Tue Nov 20, 2012 9:26 am    Post subject: MPI execution failed Reply with quote

I am new to fortran.

[xxx]$ gfortran --version
GNU Fortran (GCC) 4.4.6 20110731 (Red Hat 4.4.6-3)
Copyright (C) 2010 Free Software Foundation, Inc.

Then I could build my project using gfortran

I run the following to command to run the code
mpirun -f myhostfile -3 5 /myhome/myproject/mympiexe.x [/quote][/topic]

I got the following error
[quote][mpiexec@c24] set_default_values (./ui/mpich/utils.c:1292): no executable specified
[mpiexec@c24] HYD_uii_mpx_get_parameters (./ui/mpich/utils.c:1510): setting default values failed

Could anyone help me solve this issues?
Back to top
View user's profile Send private message
tony-curtis
Tux's lil' helper
Tux's lil' helper


Joined: 20 May 2006
Posts: 111

PostPosted: Thu Nov 22, 2012 2:23 am    Post subject: Reply with quote

What is "mpirun -3 5 ..." supposed to do? Do you want 5 processes?
Back to top
View user's profile Send private message
Adjeiinfo
n00b
n00b


Joined: 20 Nov 2012
Posts: 3

PostPosted: Thu Nov 29, 2012 2:36 am    Post subject: Reply with quote

Thankyou for your reply. I was out of office.

Following is the my job setting bash file

#! /bin/bash
#$ -S /bin/bash
#nodes=5
#ncpu=`expr $nodes \* 2`
#$ -q node.q
#$ -pe core8 40
#$ -j y
#$ -N mpitst
cat $TMPDIR/machines | sed -e 's/$/:2/' > myexecfile
mpirun -f myexecfile -np $ncpu /myhome/myproject/mympiexe.x <<EOF
Back to top
View user's profile Send private message
tony-curtis
Tux's lil' helper
Tux's lil' helper


Joined: 20 May 2006
Posts: 111

PostPosted: Thu Nov 29, 2012 2:38 am    Post subject: Reply with quote

Ah, GridEngine?

If you build your MPI with GE integration you can just say "mpirun <yourprogram>" at the end and the MPI will take care of all the hostfile and -np bits for you.

Code:
#nodes=5
#ncpu=`expr $nodes \* 2`


these are just comments as far as the shell executing the job is concerned and are ignored.

Not sure what the "here" (<<) on the last line is supposed to do? Are there more lines you truncated?
Back to top
View user's profile Send private message
Adjeiinfo
n00b
n00b


Joined: 20 Nov 2012
Posts: 3

PostPosted: Thu Nov 29, 2012 10:05 am    Post subject: Reply with quote

tony-curtis,

Thank you. It works now. My bad.

Thanks again.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum