Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Catalyst create stage1 failed because USE changes
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
oldiest
n00b
n00b


Joined: 03 Jul 2012
Posts: 9
Location: Indonesia

PostPosted: Tue Jul 03, 2012 10:45 am    Post subject: [Solved] Catalyst create stage1 failed because USE changes Reply with quote

Code:

The following USE changes are necessary to proceed:
#required by dev-perl/XML-Parser-2.410.0, required by dev-util/intltool-0.50.2, required by x11-misc/shared-mime-info-1.0, required by dev-libs/glib-2.30.3, required by dev-util/pkgconfig-0.26, required by virtual/pkgconfig-0, required by dev-util/gtk-doc-am-1.18
=dev-lang/perl-5.12.4-r1 -build

!!! catalyst: run script failed.


Traceback (most recent call last):
  File "modules/generic_stage_target.py", line 1194, in run_local
    "run script failed.",env=self.env)
  File "/usr/lib64/catalyst/modules/catalyst_support.py", line 542, in cmd
    raise CatalystError,myexc
CatalystError
None

!!! catalyst: Stage build aborting due to error.

Traceback (most recent call last):
File "/usr/lib64/catalyst/catalyst", line 206, in build_target
    mytarget.run()
File "modules/generic_stage_target.py", line 1254, in run
    apply(getattr(self,x))
File "modules/generic_stage_target.py", line 1199, in run_local
    raise CatalystError,"Stage build aborting due to error."
CatalystError
!!! catalyst: Error encountered during run of target stage1
Catalyst aborting....
lockfile does not exist '/mnt/data/catalyst/tmp/hamda/stage1-i686-20120703/.catalyst_lock'


My catalyst failed to build stage1 because of need USE -build on dev-lang/perl. How to fix this?
i have search in the forum and internet, but i got nothing. please!


Last edited by oldiest on Wed Jul 11, 2012 6:55 am; edited 1 time in total
Back to top
View user's profile Send private message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 2190

PostPosted: Tue Jul 03, 2012 2:06 pm    Post subject: Reply with quote

oldiest ...

John R. Graham wrote in this post that dev-lang/perl was recently removed from @system, so I imagine this may have something to do with your error. I'm not sure what is needed to fix it as I'm not familar with catalyst, but perhaps the above will provide some clue ...

best ... khay
Back to top
View user's profile Send private message
oldiest
n00b
n00b


Joined: 03 Jul 2012
Posts: 9
Location: Indonesia

PostPosted: Tue Jul 03, 2012 4:01 pm    Post subject: Reply with quote

thanks, khay...
i'll try it ...
Back to top
View user's profile Send private message
chemonz
n00b
n00b


Joined: 07 Jul 2012
Posts: 8
Location: Brasil

PostPosted: Sat Jul 07, 2012 2:55 pm    Post subject: Reply with quote

Please try this "workaround":

1- include this line on your stage1.spec:
portage_confdir: /tmp/catalyst/etc/portage-stage1

2- Make dir:
mkdir -p /tmp/catalyst/etc/portage-stage1

3- Set USE flags for python on stage1:
echo "dev-lang/python gdbm ipv6 ncurses readline sqlite ssl threads wide-unicode xml -build" >> /tmp/catalyst/etc/portage-stage1/package.use

4- Try generate stage1 again:
catalyst -f stage1.spec -a -p


Be Happy! :)
_________________
Att,
Raphael Bastos

Linux Reg. User: 388431 // LPI ID: LPI000214711
email:~> $ echo "vgepqnqikcBdcuvquugtxkeg0eqo0dt" | perl -pe \ 's/(.)/chr(ord($1)-2)/ge'
Projeto pessoal:~> http://wiki.hackstore.com.br
Back to top
View user's profile Send private message
chemonz
n00b
n00b


Joined: 07 Jul 2012
Posts: 8
Location: Brasil

PostPosted: Sat Jul 07, 2012 3:27 pm    Post subject: Reply with quote

chemonz wrote:
Please try this "workaround":

1- include this line on your stage1.spec:
portage_confdir: /tmp/catalyst/etc/portage-stage1

2- Make dir:
mkdir -p /tmp/catalyst/etc/portage-stage1

3- Set USE flags for python on stage1:
echo "dev-lang/python gdbm ipv6 ncurses readline sqlite ssl threads wide-unicode xml -build" >> /tmp/catalyst/etc/portage-stage1/package.use

4- Try generate stage1 again:
catalyst -f stage1.spec -a -p


Be Happy! :)


My USE flags to stage1:

server ~ # cat /home/yaxkin/server/etc/portage-stage1/package.use
dev-lang/perl gdbm -berkdb -build -debug -doc -ithreads
net-misc/rsync acl iconv ipv6 xattr
dev-lang/python -gdbm ipv6 ncurses readline sqlite ssl threads wide-unicode xml -build
dev-db/sqlite:3 fts3 readline tcl threadsafe -debug -icu -secure-delete -soundex extensions -test
_________________
Att,
Raphael Bastos

Linux Reg. User: 388431 // LPI ID: LPI000214711
email:~> $ echo "vgepqnqikcBdcuvquugtxkeg0eqo0dt" | perl -pe \ 's/(.)/chr(ord($1)-2)/ge'
Projeto pessoal:~> http://wiki.hackstore.com.br
Back to top
View user's profile Send private message
oldiest
n00b
n00b


Joined: 03 Jul 2012
Posts: 9
Location: Indonesia

PostPosted: Wed Jul 11, 2012 6:54 am    Post subject: Reply with quote

chemonz wrote:
Please try this "workaround":

1- include this line on your stage1.spec:
portage_confdir: /tmp/catalyst/etc/portage-stage1

2- Make dir:
mkdir -p /tmp/catalyst/etc/portage-stage1

3- Set USE flags for python on stage1:
echo "dev-lang/python gdbm ipv6 ncurses readline sqlite ssl threads wide-unicode xml -build" >> /tmp/catalyst/etc/portage-stage1/package.use

4- Try generate stage1 again:
catalyst -f stage1.spec -a -p


Be Happy! :)


Thanks, chemonz...
It Works ... ;-)
Back to top
View user's profile Send private message
chemonz
n00b
n00b


Joined: 07 Jul 2012
Posts: 8
Location: Brasil

PostPosted: Wed Jul 11, 2012 5:02 pm    Post subject: Reply with quote

You had a problem when generating the stage3 using ccache? can not generate the stage3 of the catalyst after update to version 2.0.8.1-r2
_________________
Att,
Raphael Bastos

Linux Reg. User: 388431 // LPI ID: LPI000214711
email:~> $ echo "vgepqnqikcBdcuvquugtxkeg0eqo0dt" | perl -pe \ 's/(.)/chr(ord($1)-2)/ge'
Projeto pessoal:~> http://wiki.hackstore.com.br
Back to top
View user's profile Send private message
chemonz
n00b
n00b


Joined: 07 Jul 2012
Posts: 8
Location: Brasil

PostPosted: Wed Jul 11, 2012 7:07 pm    Post subject: Reply with quote

chemonz wrote:
You had a problem when generating the stage3 using ccache? can not generate the stage3 of the catalyst after update to version 2.0.8.1-r2


Take a look: http://pastebin.com/xEptnTju
_________________
Att,
Raphael Bastos

Linux Reg. User: 388431 // LPI ID: LPI000214711
email:~> $ echo "vgepqnqikcBdcuvquugtxkeg0eqo0dt" | perl -pe \ 's/(.)/chr(ord($1)-2)/ge'
Projeto pessoal:~> http://wiki.hackstore.com.br
Back to top
View user's profile Send private message
oldiest
n00b
n00b


Joined: 03 Jul 2012
Posts: 9
Location: Indonesia

PostPosted: Sat Jul 14, 2012 7:51 am    Post subject: Reply with quote

i have never generate stage3 with catalyst ... **sorry**
i just generate stage1 for my gentoo installation ...
Back to top
View user's profile Send private message
chemonz
n00b
n00b


Joined: 07 Jul 2012
Posts: 8
Location: Brasil

PostPosted: Sun Nov 18, 2012 4:00 pm    Post subject: Reply with quote

oldiest wrote:
i have never generate stage3 with catalyst ... **sorry**
i just generate stage1 for my gentoo installation ...


I had this problem when using ccache was resolved in version 2.0.12.1. 8)
_________________
Att,
Raphael Bastos

Linux Reg. User: 388431 // LPI ID: LPI000214711
email:~> $ echo "vgepqnqikcBdcuvquugtxkeg0eqo0dt" | perl -pe \ 's/(.)/chr(ord($1)-2)/ge'
Projeto pessoal:~> http://wiki.hackstore.com.br
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum