Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
BIOS does not detect bootable disk (GRUB2) [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
nsh
n00b
n00b


Joined: 25 Nov 2012
Posts: 5

PostPosted: Sun Nov 25, 2012 3:47 am    Post subject: BIOS does not detect bootable disk (GRUB2) [SOLVED] Reply with quote

Hi,
I have software RAID1 installed (booting using mdadm nomdraid nolvm) on 2 disks-system.
I installed Grub2 and my BIOS does not recognize either of disks as bootable, displaying on load "A bootable device has not been detected".
However, when on startup I get to BIOS boot menu and choose the disk, Gentoo loads.

I followed Gentoo GRUB2 HOWTO to install Grub2.
Grub2 config and data reside in /boot/grub2 (/boot is a raid1 partition, mapped to /dev/md121)
I created a small partition in the beginning of each disk (parted mkpart s34..1048k), set bios_grub flag on it and ran grub2-install /dev/sda as well as grub2-install /dev/sdb to have it on the mirror disk.

UEFI boot in BIOS is disabled.

Could you please advise, what did I mess up/forgot?

Thanks in advance.


Last edited by nsh on Sun Nov 25, 2012 7:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32439
Location: 56N 3W

PostPosted: Sun Nov 25, 2012 1:26 pm    Post subject: Reply with quote

nsh,

Welcome to Gentoo.

Some brain dead BIOS check for the bootable flag on one partition on the boot drive. So your fdisk -l output needs to look like
Code:
    Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63       80324       40131   fd  Linux raid autodetect
/dev/sda2           80325     1124549      522112+  82  Linux swap / Solaris
/dev/sda4         1124550  1953520064   976197757+   5  Extended
/dev/sda5         1124613    11631059     5253223+  fd  Linux raid autodetect
/dev/sda6        11631123  1953520064   970944471   fd  Linux raid autodetect
notice the * under bootable.
BIOSes vary. Some don't check at all. Some demand that exactly one partition is marked bootable, others are OK with one or more.

Use fdisk to set the bootable flag on the boot partition of both of the drives in your raid set. Its exactly one bit in the partition table entry for that partition. Your install will not be harmed.
The step is in the Gentoo Handbook
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
nsh
n00b
n00b


Joined: 25 Nov 2012
Posts: 5

PostPosted: Sun Nov 25, 2012 6:50 pm    Post subject: Reply with quote

NeddySeagoon,
Thank you for the reply.

I used parted as I partitioned my disks with GPT, fdisk reports that it does not support GPT.

Code:
parted
GNU Parted 3.1
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) p
Model: ATA WDC WD1002FAEX-0 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

 8      17.4kB  1048kB  1031kB               [GRUB]  bios_grub
 1      1049kB  1000MB  999MB                /boot   boot
 2      1000MB  34.0GB  33.0GB               swap
 3      34.0GB  134GB   100GB                /usr
 4      134GB   144GB   10.0GB               /tmp
 5      144GB   194GB   50.0GB               /var
 6      194GB   204GB   10.0GB               /
 7      204GB   1000GB  796GB                /home


The same is for /dev/sdb .
I set boot flag on /boot but it doesn't seem to be enough. :? :?:
It is HP desktop with DH67BL motherboard. It had RAID support but I disabled it in BIOS as well as UEFI boot.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32439
Location: 56N 3W

PostPosted: Sun Nov 25, 2012 7:01 pm    Post subject: Reply with quote

nsh,

Ahhh.

You actually have two partition tables on your drives.
A legacy MSDOS partition table in Logical Block 0, which is what your BIOS will see and a GPT partition table used by everything else.
If you ignore fdisks dire warnings about not supporting GPT, it will show that you have a single partition of type EE (from memory) filling the entire disk.
This is how fdisk knows that it does not support your partition table.

However, this is where you need to set the bootable flag, not on your boot partition inside the GPT.
Go ahead and use fdisk to set the bootable flag on your protective MSDOS partition, so that the BIOS can see it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
nsh
n00b
n00b


Joined: 25 Nov 2012
Posts: 5

PostPosted: Sun Nov 25, 2012 7:46 pm    Post subject: Reply with quote

NeddySeagoon,
That makes perfect sense, thank you.
And it worked, too! :D

Thanks a lot!

-nsh
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum