Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Restore sound levels - keybord multimedia mute
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1336
Location: /uk/sheffield

PostPosted: Sat Nov 17, 2012 9:54 am    Post subject: [SOLVED] Restore sound levels - keybord multimedia mute Reply with quote

Hi,

I've a M$ Natural Ergonomic Keyboard 4000 and decided to try out the multimedia keys (never used them before).

To my delight the volume Up and Down buttons worked, so I thought I'd try the Mute button, it worked too, but only in one direction, its muted my sound and I now can't work out how to restore it.

I've tried Alsamixer (obviously!) and noticed that "Auto-Mode Mute" was enabled so I've disabled that but no joy.

Aside from that I'm stumped, the Volume Up/Down keys still modify the Master volume but there is no sound. I've tried rebooting and restarting alsa (/etc/init.d/alsasound restart) all to no avail.

Suggestions much appreciated, ta,

slackline
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth


Last edited by slackline on Sun Nov 18, 2012 2:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Sat Nov 17, 2012 11:55 am    Post subject: Re: Restore sound levels - keybord multimedia mute Reply with quote

slack---line wrote:
"Auto-Mode Mute"

That option is to automatically mute the speakers, when headphones are plugged in.

In alsamixer, press M to toggle mute on the controls that have "MM" (muted) or "OO" (open, I assume) at their bottom.
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1336
Location: /uk/sheffield

PostPosted: Sat Nov 17, 2012 3:42 pm    Post subject: Re: Restore sound levels - keybord multimedia mute Reply with quote

PaulBredbury wrote:
slack---line wrote:
"Auto-Mode Mute"

That option is to automatically mute the speakers, when headphones are plugged in.

In alsamixer, press M to toggle mute on the controls that have "MM" (muted) or "OO" (open, I assume) at their bottom.


Here in lies the problem!

There aren't any controls that are "MM" to toggle back to unmuted/open, hence the question (sorry for not being explicit on this in the first instance).

EDIT : And thats running alsamixer as user and as root.

I'm flummoxed!
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1336
Location: /uk/sheffield

PostPosted: Sun Nov 18, 2012 2:55 pm    Post subject: Reply with quote

Solved this, I was looking at the main sound card, the key had muted the "Default" sound device, unmuting that sorted it. :oops:

Time to rebind that key correctly!
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum