Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
"<sys-apps/util-linux-2.22.1" blocking ntfs3g-2012.1.15-r2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
paluszak
Apprentice
Apprentice


Joined: 28 Jun 2004
Posts: 201
Location: Warsaw, Poland

PostPosted: Tue Dec 04, 2012 9:41 am    Post subject: "<sys-apps/util-linux-2.22.1" blocking ntfs3g-2 Reply with quote

Hi,

After last update emerge -uDNvp @world spits out something like this:

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] x11-themes/faenza-icon-theme-1.3 [1.2-r1] USE="-minimal" 24,360 kB
[ebuild   R    ] sys-fs/ntfs3g-2012.1.15-r2  USE="crypt external-fuse ntfsprogs xattr -acl -debug -static-libs -suid (-extras%)" 0 kB
[ebuild   R    ] media-libs/gst-plugins-bad-0.10.22:0.10  USE="nls%* orc" 0 kB
[ebuild   R    ] media-libs/gst-plugins-good-0.10.30:0.10  USE="nls%* orc (-debug%)" 3,283 kB
[ebuild   R    ] media-libs/gst-plugins-ugly-0.10.18:0.10  USE="nls%* (-debug%)" 1,046 kB
[ebuild   R    ] media-plugins/gst-plugins-a52dec-0.10.18:0.10  USE="(-orc%*)" 0 kB
[ebuild     U  ] www-client/firefox-10.0.11 [10.0.7] USE="alsa dbus ipc libnotify minimal startup-notification webm -bindist -custom-cflags -custom-optimization -debug -pgo (-selinux) -system-sqlite -wifi" LINGUAS="pl -af -ak -ar -as -ast -be -bg -bn_BD -bn_IN -br -bs -ca -cs -csb -cy -da -de -el -en_GB -en_ZA -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy_NL -ga_IE -gd -gl -gu_IN -he -hi_IN -hr -hu -hy_AM -id -is -it -ja -kk -kn -ko -ku -lg -lt -lv -mai -mk -ml -mr -nb_NO -nl -nn_NO -nso -or -pa_IN -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zh_CN -zh_TW -zu" 73,923 kB
[ebuild     U  ] mail-client/thunderbird-10.0.11 [10.0.7] USE="alsa crypt dbus ipc libnotify lightning minimal startup-notification webm -bindist -custom-cflags -custom-optimization -debug -gconf -mozdom (-selinux) -system-sqlite -wifi" LINGUAS="pl -ar -ast -be -bg -bn_BD -br -ca -cs -da -de -el -en_GB -es_AR -es_ES -et -eu -fi -fr -fy_NL -ga_IE -gd -gl -he -hu -id -is -it -ja -ko -lt -nb_NO -nl -nn_NO -pa_IN -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -sq -sr -sv_SE -ta_LK -tr -uk -vi -zh_CN -zh_TW" 95,886 kB
[ebuild     U ~] net-im/skype-4.1.0.20 [4.0.0.8-r1] USE="-pax_kernel (-selinux) (-qt-static%)" 29,786 kB
[ebuild     U  ] net-libs/libssh-0.5.3 [0.5.2] USE="server sftp zlib -debug -doc -examples -gcrypt -pcap -ssh1 -static-libs {-test}" 361 kB
[blocks B      ] <sys-apps/util-linux-2.22.1 ("<sys-apps/util-linux-2.22.1" is blocking sys-fs/ntfs3g-2012.1.15-r2)

Total: 10 packages (5 upgrades, 5 reinstalls), Size of downloads: 228,643 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/ntfs3g-2012.1.15-r2::gentoo, ebuild scheduled for merge) pulled in by
    sys-fs/ntfs3g required by @selected
    sys-fs/ntfs3g required by (app-admin/testdisk-6.12::gentoo, installed)

  (sys-apps/util-linux-2.21.2::gentoo, installed) pulled in by
    >=sys-apps/util-linux-2.20.1-r2 required by (sys-fs/udisks-1.0.4-r2::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/udev-171-r9::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (x11-libs/libSM-1.2.1::gentoo, installed)
    >=sys-apps/util-linux-2.13 required by (sys-power/pm-utils-1.4.1-r2::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/e2fsprogs-1.42::gentoo, installed)
    sys-apps/util-linux required by (www-client/opera-12.11.1661::gentoo, installed)
    sys-apps/util-linux required by (sys-apps/udevil-0.3.3-r1::gentoo, installed)
    sys-apps/util-linux required by @system
    sys-apps/util-linux required by (app-i18n/ibus-pinyin-1.4.0::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/lvm2-2.02.88::gentoo, installed)
    sys-apps/util-linux required by (app-text/build-docbook-catalog-1.4::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (dev-libs/apr-1.4.5::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Both ntfs3g and util-linux are at the latest stable versions. Is there something borked with those packages in the portage tree? Anyone got the same results? BTW, I'm running a stable x86 system.

J.
Back to top
View user's profile Send private message
figueroa
Apprentice
Apprentice


Joined: 14 Aug 2005
Posts: 221
Location: GA-USA

PostPosted: Tue Dec 04, 2012 5:34 pm    Post subject: Reply with quote

Yes, borked, but I solved it temporarily, yesterday, by masking sys-fs/ntfs3g-2012.1.15-r2, which downgraded my installation to sys-fs/ntfs3g-2012.1.15-r1. And, with a new sync this morning about 05:00 US Eastern Time, the problem resolved itself. I cannot, however, see what might have changed.
_________________
Andy Figueroa
andy@andyfigueroa.us
Back to top
View user's profile Send private message
paluszak
Apprentice
Apprentice


Joined: 28 Jun 2004
Posts: 201
Location: Warsaw, Poland

PostPosted: Tue Dec 04, 2012 9:40 pm    Post subject: Reply with quote

After next update everything seems to be back to normal. Just a bad time to do my portage sync, I think.

J.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum