Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
New Nvidia drivers are not working right for me.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
l1t
n00b
n00b


Joined: 17 Oct 2012
Posts: 13

PostPosted: Tue Nov 20, 2012 1:20 pm    Post subject: New Nvidia drivers are not working right for me. Reply with quote

I recently upgraded to the most recent kernel(3.5.7) and software. Now when when I play doom2 using openGL the graphics are choppy and xinerama does not work correctly. When I maximize a window it stretches across both screens rather than just one. Everything else seems to be fine.

I've tried module-rebuilding , re modprobing the nvidia module.
re-creating xorg
messing with nvidia-settings
etc.

I want to fix this without downgrading nvidia drivers to 290.57(or somethign similar). It's odd now if I downgrade nvidia drivers and the x11-base (which I have tried too) the new x.conf files I generate don't allow mouse and keyboard to work.
Back to top
View user's profile Send private message
snkmoorthy
Guru
Guru


Joined: 19 Nov 2002
Posts: 333

PostPosted: Tue Nov 20, 2012 3:20 pm    Post subject: can you update with Reply with quote

Code:
eselect opengl list
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 2389
Location: Dallas area

PostPosted: Tue Nov 20, 2012 3:50 pm    Post subject: Reply with quote

The 3.4 series of the kernel is long term stable, the 3.5 series is more betaish.
_________________
Asus m5a99fx, FX 8320 - amd64-multilib, 3.15.9-zen, glibc-2.17, gcc-4.7.3-r1, eudev
xorg-server-1.16, openbox w/lxpanel, nouveau, oss4
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2643
Location: Slovenia

PostPosted: Tue Nov 20, 2012 3:55 pm    Post subject: Reply with quote

Anon-E-moose wrote:
the 3.5 series is more betaish.

The 3.5 series is end-of-life actually. But I don't think the kernel is the issue here.

@l1t: Don't go generating any config files, all those generators are outdated. You need this:
Code:
Section "Device"
  Identifier "Nvidia Graphics"
  Driver "nvidia"
EndSection

That's it. That and only that. If it won't work as xorg.conf, save it instead as /etc/X11/xorg.conf.d/20-nvidia.conf. But it should work as xorg.conf too.
Back to top
View user's profile Send private message
l1t
n00b
n00b


Joined: 17 Oct 2012
Posts: 13

PostPosted: Tue Nov 20, 2012 4:27 pm    Post subject: Reply with quote

snkmoorthy wrote:
eselect opengl list

Ok not sure what this does but i'll try it. I know i have done eselect nvidia set opengl or something like that slready and the command completed successfully.

Gusar wrote:
Anon-E-moose wrote:
the 3.5 series is more betaish.

The 3.5 series is end-of-life actually. But I don't think the kernel is the issue here.

@l1t: Don't go generating any config files, all those generators are outdated. You need this:
Code:
Section "Device"
  Identifier "Nvidia Graphics"
  Driver "nvidia"
EndSection

That's it. That and only that. If it won't work as xorg.conf, save it instead as /etc/X11/xorg.conf.d/20-nvidia.conf. But it should work as xorg.conf too.


Really just that no input device and all that jazz? And ok I will try again when I get home today. I remember the error I got when I downgraded the nvidia drivers to the ones I used to use which I think were the 209.57 ones it said failed to initialize the nvidia module. But when I use the latest drivers Xorg -configure then re-modprobing the nvidia module works fine. One last question if I downgrade my nvidia drivers to 209.57 and try that again do I also need to downgrade x11-base? I think it automatically downgraded that last time because when I re-upgraded to the latest nvidia drivers I had to re-install x11-base as well for startx to actually work.
Back to top
View user's profile Send private message
l1t
n00b
n00b


Joined: 17 Oct 2012
Posts: 13

PostPosted: Tue Nov 20, 2012 9:44 pm    Post subject: Reply with quote

Anyone have any other recommendations or comments about what I should try? I'm getting home from work soon and i'm looking for more things attempt to troubleshoot the issue.
Back to top
View user's profile Send private message
l1t
n00b
n00b


Joined: 17 Oct 2012
Posts: 13

PostPosted: Tue Nov 20, 2012 11:42 pm    Post subject: Reply with quote

Gusar wrote:
Anon-E-moose wrote:
the 3.5 series is more betaish.

The 3.5 series is end-of-life actually. But I don't think the kernel is the issue here.

@l1t: Don't go generating any config files, all those generators are outdated. You need this:
Code:
Section "Device"
  Identifier "Nvidia Graphics"
  Driver "nvidia"
EndSection

That's it. That and only that. If it won't work as xorg.conf, save it instead as /etc/X11/xorg.conf.d/20-nvidia.conf. But it should work as xorg.conf too.


Unfortunately this did not change a thing. Windows are still maximized across both screens and opengl is choppy.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2643
Location: Slovenia

PostPosted: Tue Nov 20, 2012 11:49 pm    Post subject: Reply with quote

Then Gentoo is doing something really weird. It works fine on Arch. Seeing your /var/log/Xorg.0.log would be nice. And I'm assuming you have everything compiled with the xinerama use flag. How exactly are you activating the second display, using nvidia-settings?
Back to top
View user's profile Send private message
l1t
n00b
n00b


Joined: 17 Oct 2012
Posts: 13

PostPosted: Wed Nov 21, 2012 12:00 am    Post subject: Reply with quote

Gusar wrote:
Then Gentoo is doing something really weird. It works fine on Arch. Seeing your /var/log/Xorg.0.log would be nice. And I'm assuming you have everything compiled with the xinerama use flag. How exactly are you activating the second display, using nvidia-settings?


Not sure why but even when I try to manually set xinerama using sudo USE="xinerama" emerge -av x11-drivers/nvidia-drivers
it does not show it's about to compile it using that flag. The only flags it has set are X,acpi (multilib) , tools , -pax_kernel

I try to dual monitor by setting configuration: seperate x screen with the xinerama checkbox checked.
Back to top
View user's profile Send private message
l1t
n00b
n00b


Joined: 17 Oct 2012
Posts: 13

PostPosted: Wed Nov 21, 2012 12:01 am    Post subject: Reply with quote

l1t wrote:
Gusar wrote:
Then Gentoo is doing something really weird. It works fine on Arch. Seeing your /var/log/Xorg.0.log would be nice. And I'm assuming you have everything compiled with the xinerama use flag. How exactly are you activating the second display, using nvidia-settings?


Not sure why but even when I try to manually set xinerama using sudo USE="xinerama" emerge -av x11-drivers/nvidia-drivers
it does not show it's about to compile it using that flag. The only flags it has set are X,acpi (multilib) , tools , -pax_kernel

I try to dual monitor by setting configuration: seperate x screen with the xinerama checkbox checked.


Btw I do have opengl nvidia set using eselect and now when I start my doom2 source port the screen goes whitish when using openGL. Software rendering is fine still.

Here is the Xorg.0.log :
http://www.hastebin.com/vadibuveci.coffee
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2643
Location: Slovenia

PostPosted: Wed Nov 21, 2012 12:14 am    Post subject: Reply with quote

The xinerama flag not for the nvidia driver, but for *everything* else. If you want apps to handle multi-monitor, they need to speak the xinerama protocol

And try nvidia-settings without checking the xinerama checkbox. Using the xinerama extension is outdated and has a performance penalty and other shortcomings. If that sounded confusing right now, read this thread about protocol vs. extension: http://forums.gentoo.org/viewtopic-t-912824-highlight-.html
Back to top
View user's profile Send private message
l1t
n00b
n00b


Joined: 17 Oct 2012
Posts: 13

PostPosted: Wed Nov 21, 2012 12:27 am    Post subject: Reply with quote

Gusar wrote:
The xinerama flag not for the nvidia driver, but for *everything* else. If you want apps to handle multi-monitor, they need to speak the xinerama protocol

And try nvidia-settings without checking the xinerama checkbox. Using the xinerama extension is outdated and has a performance penalty and other shortcomings. If that sounded confusing right now, read this thread about protocol vs. extension: http://forums.gentoo.org/viewtopic-t-912824-highlight-.html


Oh yes I remember xinerama was used for everything else such as my DE etc.
I did try that. If I unchecked xinerama I cannot drag windows between each screen and I like the top gnome 2 bar at the top to stretch aross and either way my opengl is still choppy compared to what it used to be and it now fades the entire screen white when I render with opengl. I think this is a kernel issue. Is there anyway I can go back to the nvidia drivers I was using before and my kernerl I was using before I did and emerge world update easily? I just want everything to work again I'm not interested in this new kernel or these new nvidia drivers that are not working correctly whatsoever.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2643
Location: Slovenia

PostPosted: Wed Nov 21, 2012 9:15 am    Post subject: Reply with quote

I don't see how this could be a kernel issue. The nvidia driver is a blob, it'll work the same way regardless of kernel.

Quote:
If I unchecked xinerama I cannot drag windows between

I wish I had my nvidia card with me, so I could see how nvidia-settings works nowadays. I always used xorg.conf to set up multi-monitor. Try that: http://forums.gentoo.org/viewtopic-p-7093688.html#7093688
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Wed Nov 21, 2012 9:42 am    Post subject: Reply with quote

Gusar wrote:
@l1t: Don't go generating any config files, all those generators are outdated. You need this:
Code:
Section "Device"
  Identifier "Nvidia Graphics"
  Driver "nvidia"
EndSection

That's it. That and only that. If it won't work as xorg.conf, save it instead as /etc/X11/xorg.conf.d/20-nvidia.conf. But it should work as xorg.conf too.

That used to be the case. But doing this implies that you will rely on xorg default settings which are based on the nvidia driver auto-detection capabilities.
This used to work well but, in my case too (different from the OP's one but related to xinerama) xorg guessed wrong from nvidia monitors autodetection.

I had no time to investigate deeper and just fixed things the quick & dirty way :

- Launch the nvidia X server settings applet.
- Select the X server display configuration and configure each screen individually before saving to X configuration file.

Of course, you'll need to restart the X server.

Of course, you will want to reclean your xorg.conf of all the needless input entries the nvidia X server settings will have forced and that are correctly managed by the xorg server thanks to the default /usr/share/etc/X11/xorg.conf.d/10... definitions.
_________________
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2643
Location: Slovenia

PostPosted: Wed Nov 21, 2012 10:22 am    Post subject: Reply with quote

The xorg default is cloned displays in the highest resolution both displays can handle. Is that not the case anymore with nvidia? If you want something diffrerent, click that link I gave in my previous post.
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Wed Nov 21, 2012 10:36 am    Post subject: Reply with quote

Gusar wrote:
The xorg default is cloned displays in the highest resolution both displays can handle. Is that not the case anymore with nvidia? If you want something diffrerent, click that link I gave in my previous post.

In my particular case, I get a single monitor accepting both analog and digital input.
New nvidia-driver sees this monitor as two co-existing different monitors, one DFP and the other one CRT
Apparently twinview is now a default option with xorg-1.13 and xorg server, by default, makes a single screen from the "two" monitors detected by the nvidia driver of twice the actual width of my actually single monitor.
=> To bypass this I have had to explicitly deactivate xinerama in my xorg.conf and design dedicated monitor & screen sections.

But, once more, I have not had the time to investigate precisely the culprit and agree that the advice I gave to the OP is certainly a quick and dirty way to workaround his problem.
_________________
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2643
Location: Slovenia

PostPosted: Wed Nov 21, 2012 11:01 am    Post subject: Reply with quote

Sounds like a driver bug. And yeah, twinview is now on by default (nothing to do with the server though, it's about the nvidia driver, twinview is on by default in all 300+ versions). But rather than what you're doing, I'd just deactivate the "phantom" display:
Code:
Section "Monitor"
    Identifier  "VGA-0"
    Option      "Ignore"  "true"
EndSection

Adjust Identifier to the output you wish to disable.
Back to top
View user's profile Send private message
l1t
n00b
n00b


Joined: 17 Oct 2012
Posts: 13

PostPosted: Wed Nov 21, 2012 1:53 pm    Post subject: Reply with quote

So I fixed the openGL choppy issue in doom2 by package.masking everything => nvidia drivers 295.75 so now i'm on 295.71 nvidia drivers. (or something similar. I'm at work again and cannot check.) I'm still having issues with the dual monitor window maximization but I have a feeling I just need to mess with the settings and I will try everything everyone has recommended and commented about thanks guys I will keep you posted.
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Wed Nov 21, 2012 4:35 pm    Post subject: Reply with quote

Gusar wrote:
Sounds like a driver bug. And yeah, twinview is now on by default (nothing to do with the server though, it's about the nvidia driver, twinview is on by default in all 300+ versions). But rather than what you're doing, I'd just deactivate the "phantom" display:
Code:
Section "Monitor"
    Identifier  "VGA-0"
    Option      "Ignore"  "true"
EndSection

Adjust Identifier to the output you wish to disable.

Does'nt work!
Originally, xorg comes with CRT-0 and DFP-1
If I try to ignore CRT-0 the way you suggest then xorg will still come with two monitors... CRT-1 and DFP-0
And if I try to ignore CRT-1, it will come back with CRT-0 and DFP-1
:?
_________________
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2643
Location: Slovenia

PostPosted: Wed Nov 21, 2012 5:16 pm    Post subject: Reply with quote

And if you ignore both (with two Monitor sections)?

This definitely looks a driver bug, you should report it: https://devtalk.nvidia.com/default/board/98/linux/
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Wed Nov 21, 2012 6:12 pm    Post subject: Reply with quote

Gusar wrote:
And if you ignore both (with two Monitor sections)?

:lol:
This suggestion (ignoring both CRT-0 and CRT-1) has got the impressive advantage to divide by 10 the content of my xorglog ! :twisted:

Fatal error : No screen found ! :evil:

Edit : Problem solved. I simply had to specify Option "ConnectedMonitor" "DFP" in the device section.
_________________
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum