Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Skype blocca webcam ed altre usb
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
UnoSD
Apprentice
Apprentice


Joined: 27 Jun 2011
Posts: 249

PostPosted: Sat Sep 29, 2012 1:04 pm    Post subject: [RISOLTO] Skype blocca webcam ed altre usb Reply with quote

Salve a tutti,

sto cercando di usare la webcam su Skype, ma (sia con la versione 2.x che la 4.x) parte, si vede per qualche secondo, poi blocca Skype ed anche il mouse usb e la penna usb per internet (credo tutto quello che ci sia sul bus 2).

Può per caso aver a che fare con libv4l in qualche modo? C'è un avvertimento a fine installazione di Skype che dice:

Code:
 * For webcam support, see "LD_PRELOAD" section of "README.lib" document provided by
 * media-libs/libv4l package and "README" document of this package.
 * You can install app-emulation/emul-linux-x86-medialibs package for the 32bit
 * libraries from the media-libs/libv4l package.


Grazie.


Last edited by UnoSD on Wed Nov 14, 2012 8:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
doom555
n00b
n00b


Joined: 29 Oct 2012
Posts: 57

PostPosted: Tue Oct 30, 2012 3:22 pm    Post subject: Reply with quote

Ho appena risposto ad un altro post su problemi alla webcam, ipotizzando che si trattasse del problema che descrivi tu, adesso leggo questo!
:D

Secondo me la tua webcam utilizza uvcvideo...
controlla se è così:
Code:
# lsmod | grep uvcvideo

Se è così, allora:
Code:
# rmmod uvcvideo
# modprobe uvcvideo nodrop=1

Adesso prova se la webcam funziona su skype...
Nel caso funzionasse:
Code:
# echo "options uvcvideo nodrop=1" >> /etc/modprobe.d/uvcvideo.conf


Non ho idea di cosa cambi il parametro nodrop... è una soluzione che avevo trovato in giro!
Back to top
View user's profile Send private message
UnoSD
Apprentice
Apprentice


Joined: 27 Jun 2011
Posts: 249

PostPosted: Tue Oct 30, 2012 8:34 pm    Post subject: Reply with quote

Salve!

lsmod non funziona perché ho il driver integrato nel kernel, ma comunque sto usando uvcvideo.

Code:
$ dmesg | grep uvcvideo
[    6.015140] usbcore: registered new interface driver uvcvideo
[    6.789759] uvcvideo 1-1.3:1.0: usb_probe_interface
[    6.789763] uvcvideo 1-1.3:1.0: usb_probe_interface - got id
[    6.789775] uvcvideo: Found UVC 1.00 device Integrated Webcam (05ca:18a0)


C'è un modo per usare quest'opzione senza usare il modulo?

Comunque il mio problema è leggermente diverso, ma vorrei provare questa soluzione lo stesso.

Oggi "magicamente" ha funzionato (guarda un po', giusto quando volevo fare una prova -.-)

Alla fine della sessione con la webcam l'unico output sullo stdout di skype è stato: libv4l2: error dequeuing buf: Invalid argument.

P.s. Ok, mi rispondo da solo: aggiungo alla riga del kernel: uvcvideo.nodrop=1, al prossimo riavvio do notizie!
Back to top
View user's profile Send private message
UnoSD
Apprentice
Apprentice


Joined: 27 Jun 2011
Posts: 249

PostPosted: Wed Nov 14, 2012 8:36 pm    Post subject: Reply with quote

Allora, usando:
Code:

LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so /opt/bin/skype


E l'opzione per il modulo, funziona!

Grazie mille!

P.s. Non so se anche solo l'opzione funziona, ma sono troppo pigro per provare...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum