Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge povray fails - [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Skippy204
Apprentice
Apprentice


Joined: 09 May 2008
Posts: 187
Location: Fort Collins, Colorado, USA

PostPosted: Sat Nov 10, 2012 5:33 pm    Post subject: emerge povray fails - [solved] Reply with quote

Greetings. When trying to emerge povray I get this error:

Code:

unix/unixconsole.cpp:381:28: warning: ignoring return value of ‘ssize_t read(int, void*, size_t)’, declared with attribute warn_unused_result [-Wunused-result]
rm -f libvfe.a
x86_64-pc-linux-gnu-ar cru libvfe.a vfecontrol.o vfedisplay.o vfepovms.o vfe.o vfesession.o vfeprecomp.o platformbase.o unixoptions.o vfeplatform.o unixconsole.o
x86_64-pc-linux-gnu-ranlib libvfe.a
make[2]: Leaving directory `/var/tmp/portage/media-gfx/povray-3.7.0_rc5-r1/work/povray-3.7.0.RC5/vfe'
Making all in unix
make[2]: Entering directory `/var/tmp/portage/media-gfx/povray-3.7.0_rc5-r1/work/povray-3.7.0.RC5/unix'
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I..  -I.. -I../source -I../source -I../source/backend -I../source/base -I../source/frontend -I../vfe -I../vfe/unix -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -Iyes/../include  -DPOVLIBDIR=\"/usr/share/povray\" -DPOVCONFDIR=\"/etc/povray\"  -pthread  -I/usr/include  -pipe -Wno-multichar -Wno-write-strings -fno-enforce-eh-specs -march=core2 -msse4 -mcx16 -msahf -O2 -pipe -pthread -c -o disp_sdl.o disp_sdl.cpp
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I..  -I.. -I../source -I../source -I../source/backend -I../source/base -I../source/frontend -I../vfe -I../vfe/unix -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -Iyes/../include  -DPOVLIBDIR=\"/usr/share/povray\" -DPOVCONFDIR=\"/etc/povray\"  -pthread  -I/usr/include  -pipe -Wno-multichar -Wno-write-strings -fno-enforce-eh-specs -march=core2 -msse4 -mcx16 -msahf -O2 -pipe -pthread -c -o disp_text.o disp_text.cpp
/bin/sh ../libtool --tag=CXX   --mode=link x86_64-pc-linux-gnu-g++  -pipe -Wno-multichar -Wno-write-strings -fno-enforce-eh-specs -march=core2 -msse4 -mcx16 -msahf -O2 -pipe -pthread  -Lyes -Wl,-O1 -Wl,--as-needed -L/usr/local/lib  -L/usr/lib -o povray disp_sdl.o disp_text.o ../vfe/libvfe.a ../source/backend/libbackend.a ../source/frontend/libfrontend.a ../source/base/libbase.a ../source/libpovray.a -lSDL -lSDL -lpthread -lXpm  -lSM -lICE -lX11  -ltiff -ljpeg -lpng -lz -lrt -lm -lboost_thread-mt -pthread  -pthread
../libtool: line 6007: cd: yes: No such file or directory
libtool: link: cannot determine absolute directory name of `yes'
make[2]: *** [povray] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-gfx/povray-3.7.0_rc5-r1/work/povray-3.7.0.RC5/unix'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-gfx/povray-3.7.0_rc5-r1/work/povray-3.7.0.RC5'
make: *** [all] Error 2
 * ERROR: media-gfx/povray-3.7.0_rc5-r1 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=media-gfx/povray-3.7.0_rc5-r1'`,
 * the complete build log and the output of `emerge -pqv '=media-gfx/povray-3.7.0_rc5-r1'`.
 * The complete build log is located at '/var/tmp/portage/media-gfx/povray-3.7.0_rc5-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/povray-3.7.0_rc5-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/media-gfx/povray-3.7.0_rc5-r1/work/povray-3.7.0.RC5'
 * S: '/var/tmp/portage/media-gfx/povray-3.7.0_rc5-r1/work/povray-3.7.0.RC5'


My first semi-educated guess is something to do with libtools. I re-emerged libtools and that worked out fine, but no change when emerging povray.

Code:

 root # eix libtool
[I] sys-devel/libtool
     Available versions: 
   (1.3)   1.3.5
   (1.5)   **1.5.26 (~)1.5.26-r1
   (2)   2.2.10{tbz2} 2.4-r1{tbz2} (~)2.4-r4{tbz2} (~)2.4.2{tbz2} **9999
   {{static-libs test vanilla}}
     Installed versions:  2.4.2(2){tbz2}(09:56:29 AM 11/10/2012)(-static-libs -test -vanilla)
     Homepage:            http://www.gnu.org/software/libtool/
     Description:         A shared library tool for developers


Observations please? Thanks.


Last edited by Skippy204 on Thu Nov 15, 2012 3:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5434

PostPosted: Sat Nov 10, 2012 5:48 pm    Post subject: Reply with quote

Scroll a few lines back, take a look at configure output, then at config.log content.
I kinda doubt libtool plays any real role here.
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8852

PostPosted: Sat Nov 10, 2012 8:40 pm    Post subject: Reply with quote

That -Lyes looks quite strange. What is the output of emerge --info --verbose?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5434

PostPosted: Sat Nov 10, 2012 10:46 pm    Post subject: Reply with quote

There's a bug about this already.
Current theory is that the automagic patch is not quite correct.
Back to top
View user's profile Send private message
Skippy204
Apprentice
Apprentice


Joined: 09 May 2008
Posts: 187
Location: Fort Collins, Colorado, USA

PostPosted: Thu Nov 15, 2012 3:36 pm    Post subject: Reply with quote

It's fixed now whatever it was.

Emerged without any problems after a portage sync.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum