Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo unresponsive when emerging chromium/libreoffice
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
ryanli
n00b
n00b


Joined: 20 Oct 2010
Posts: 25
Location: Beijing, China

PostPosted: Thu Nov 08, 2012 4:34 pm    Post subject: Gentoo unresponsive when emerging chromium/libreoffice Reply with quote

It's an issue that has been troubling me for quite a long time. When I am using my Gentoo box and emerging large applications, incl. chromium and libreoffice, the system will absolutely become unresponsive during that time. Moving the mouse/switching to tty took a hell couple minutes for the computer to respond.

I could wait for this to end, but usually it will take one or two hours, when the emerge process finishes (and probably successfully). After that some my Chromium tabs will display "He's dead, Jim!".

This happens on both of my laptops, each of which is equipped with Intel Core i5 processor, and 4 GiB RAM, with no swap space. I am not sure whether no swap space is the cause, but when I run free when emerging it usually shows that I have more than 1 GiB free memory.

Would be great if there's someone who could help me out there!
Back to top
View user's profile Send private message
Chiitoo
l33t
l33t


Joined: 28 Feb 2010
Posts: 887
Location: Here and Away Again

PostPosted: Thu Nov 08, 2012 4:54 pm    Post subject: ><)))°€ Reply with quote

Teegrins, ryanli!

I can only say that, what you describe, is exactly how my system would perform when I was low on memory (was down to 2 GiB from 4 due to one stick going bad). The builds would usually fail, too, depending of the size.

So even if you do seem to have enough of it (4 I think should still be adequate, I would guess, even though some packages has become quite ridonkulous), I would suggest trying to add some swap space. I'm pretty sure it can't at least hurt to try!

That's what I'd try.

I guess there could be something specific to how the laptops do things (as in, do they perhaps reserve some memory so that the free you are seeing is not available), that I don't currently know of, and could be tweaked to make a difference without swap... Just guessing here. Might be waaay off. ^^;


Good luck!
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
ryanli
n00b
n00b


Joined: 20 Oct 2010
Posts: 25
Location: Beijing, China

PostPosted: Thu Nov 08, 2012 5:26 pm    Post subject: Re: ><)))°€ Reply with quote

Thanks!

/me swapon /dev/sdb3 # 40 GiB SSD

Chiitoo wrote:
Teegrins, ryanli!

I can only say that, what you describe, is exactly how my system would perform when I was low on memory (was down to 2 GiB from 4 due to one stick going bad). The builds would usually fail, too, depending of the size.

So even if you do seem to have enough of it (4 I think should still be adequate, I would guess, even though some packages has become quite ridonkulous), I would suggest trying to add some swap space. I'm pretty sure it can't at least hurt to try!

That's what I'd try.

I guess there could be something specific to how the laptops do things (as in, do they perhaps reserve some memory so that the free you are seeing is not available), that I don't currently know of, and could be tweaked to make a difference without swap... Just guessing here. Might be waaay off. ^^;


Good luck!
Back to top
View user's profile Send private message
^marcs
Apprentice
Apprentice


Joined: 09 Mar 2005
Posts: 169

PostPosted: Fri Nov 09, 2012 8:46 am    Post subject: Reply with quote

It is also a good idea to decrease parallel make jobs for those packages, on my 3GB system at work I'm using -j1 for chromium and it's working OK even when I'm using bunch of other programs at the same time - downside of this solution is that compilation takes better chunk of my work-day :o

You can set separate MAKEOPTS for different packages via package.env
Back to top
View user's profile Send private message
kimmie
Guru
Guru


Joined: 08 Sep 2004
Posts: 531
Location: Australia

PostPosted: Fri Nov 09, 2012 9:15 am    Post subject: Reply with quote

You are setting PORTAGE_NICENESS in make.conf, right?

Try setting PORTAGE_NICENESS=11

I use this along with MAKEOPTS="-j9 -l8" and EMERGE_DEFAULT_OPTS="--jobs=3"... I can happily watch a video and browse the web while building libreoffice or chromium. Although I'm on an i7 with 12GB ram.

But even on my last pentium-M laptop with 2G ram I could still browse and watch a vid while building. If your processor has 4 cores, try setting MAKEOPTS="-j5 -l4" and EMERGE_DEFAULT_OPTS="--jobs=2". This will keep all cores busy without any thrashing, and along with PORTAGE_NICENESS it shouldn't interfere with your desktop.

If you're still having trouble, you may need to change kernel settings. CONFIG_PREEMPT is bad for throughput, as is CONFIG_HZ_1000. Unless you have special needs CONFIG_HZ_300 is better.

Also, nearly all filesystems start to suck when nearly full, so make sure there's a good amount of room in /var/tmp/portage. I think the libreoffice ebuild requires 6G, make sure it has a couple of gig headroom.

Swap == RAM is good. You're on a laptop right? Suspend/resume works really well....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum