Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Python] Problème avec python 3.2 pour un seul package
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Wed Nov 07, 2012 11:50 am    Post subject: [Python] Problème avec python 3.2 pour un seul package Reply with quote

Bonjour, j'aimerais savoir si on peut forcer l'utilisation d'une version de python pour un package en particulier ?

J'ai ceci comme problème depuis un bon bout de temps, j'utilise python 3.2 mais il semble que je dois utiliser python 2.7 seulement pour le package hplip :

https://bugs.gentoo.org/show_bug.cgi?id=414195
https://bugs.gentoo.org/show_bug.cgi?id=438886

J'ai vu la nouvelle à propos de la nouvelle variable python, par contre je ne sais pas si on peut l'utiliser dans /etc/portage/package.use ?

Merci !
_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3319
Location: Paris - France

PostPosted: Wed Nov 07, 2012 1:26 pm    Post subject: Reply with quote

Oui on peut.
Il y a dans les eclass python ce qu'il faut pour:
- setter python 2.X pendant l'emerge
- réécrire les shebang pour y forcer "python2" au lieu de "python"

J'avais fait fixer l'ebuild de tribler comme ça il y a quelques temps.

Basiquement, il faut un :
Code:
PYTHON_DEPEND="2"


Et un

Code:
pkg_setup() {
        python_set_active_version 2
        python_pkg_setup
}


Et dans le src_prepare() un
Code:
python_convert_shebangs -r 2 .

_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Thu Nov 08, 2012 6:07 pm    Post subject: Reply with quote

J'ai dû utiliser eselect python list et sélectionner temporairement python 2.7 pour que le package hplip fonctionne comme du monde.

Je vais ouvrir un bugzilla en ce sens.
_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum